summaryrefslogtreecommitdiffstats
path: root/recipes-core/ecj/ecj-bootstrap-native.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/ecj/ecj-bootstrap-native.bb')
-rw-r--r--recipes-core/ecj/ecj-bootstrap-native.bb8
1 files changed, 7 insertions, 1 deletions
diff --git a/recipes-core/ecj/ecj-bootstrap-native.bb b/recipes-core/ecj/ecj-bootstrap-native.bb
index e159c9d..276a8f0 100644
--- a/recipes-core/ecj/ecj-bootstrap-native.bb
+++ b/recipes-core/ecj/ecj-bootstrap-native.bb
@@ -27,7 +27,13 @@ inherit native
27do_compile() { 27do_compile() {
28 # Create the start script 28 # Create the start script
29 echo "#!/bin/sh" > ecj-bootstrap 29 echo "#!/bin/sh" > ecj-bootstrap
30 echo "ECJ_JAR=${STAGING_DATADIR}/java/${JAR}" >> ecj-bootstrap 30
31 # get absolute path to parent directory, and use that as base path for the jar
32 echo "SH_DIR=\`dirname "\$0"\`" >> ecj-bootstrap
33 echo "CURRENT_DIR=\`cd "\${SH_DIR}" && pwd\`" >> ecj-bootstrap
34 echo "PARENT_DIR=\`dirname \${CURRENT_DIR}\`" >> ecj-bootstrap
35
36 echo "ECJ_JAR=\${PARENT_DIR}/share/java/${JAR}" >> ecj-bootstrap
31 echo "RUNTIME=java" >> ecj-bootstrap 37 echo "RUNTIME=java" >> ecj-bootstrap
32 cat ecj.in >> ecj-bootstrap 38 cat ecj.in >> ecj-bootstrap
33} 39}