summaryrefslogtreecommitdiffstats
path: root/recipes-core/classpath
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/classpath')
-rw-r--r--recipes-core/classpath/classpath-initial-native_0.93.bb2
-rw-r--r--recipes-core/classpath/classpath-native_0.99.bb2
-rw-r--r--recipes-core/classpath/classpath.inc38
3 files changed, 21 insertions, 21 deletions
diff --git a/recipes-core/classpath/classpath-initial-native_0.93.bb b/recipes-core/classpath/classpath-initial-native_0.93.bb
index 51229ec..7bb1ca1 100644
--- a/recipes-core/classpath/classpath-initial-native_0.93.bb
+++ b/recipes-core/classpath/classpath-initial-native_0.93.bb
@@ -28,7 +28,7 @@ EXTRA_OECONF += "\
28# Ensure tools.zip is not installed at same path as classpath-native 28# Ensure tools.zip is not installed at same path as classpath-native
29EXTRA_OEMAKE += "pkgdatadir=${STAGING_DATADIR_NATIVE}/classpath-initial" 29EXTRA_OEMAKE += "pkgdatadir=${STAGING_DATADIR_NATIVE}/classpath-initial"
30 30
31do_install_append() { 31do_install:append() {
32 # remove files clashing with classpath-native in sysroot 32 # remove files clashing with classpath-native in sysroot
33 rm \ 33 rm \
34 ${D}${bindir}/gappletviewer \ 34 ${D}${bindir}/gappletviewer \
diff --git a/recipes-core/classpath/classpath-native_0.99.bb b/recipes-core/classpath/classpath-native_0.99.bb
index daf7611..ecf8c0a 100644
--- a/recipes-core/classpath/classpath-native_0.99.bb
+++ b/recipes-core/classpath/classpath-native_0.99.bb
@@ -23,7 +23,7 @@ EXTRA_OECONF += "\
23 --includedir=${STAGING_INCDIR}/classpath \ 23 --includedir=${STAGING_INCDIR}/classpath \
24" 24"
25 25
26do_compile_append () { 26do_compile:append () {
27 # tools using java-initial rather than java sed it out 27 # tools using java-initial rather than java sed it out
28 cd tools 28 cd tools
29 sed -e "s/java-initial/java/g" \ 29 sed -e "s/java-initial/java/g" \
diff --git a/recipes-core/classpath/classpath.inc b/recipes-core/classpath/classpath.inc
index e23b752..42c5daf 100644
--- a/recipes-core/classpath/classpath.inc
+++ b/recipes-core/classpath/classpath.inc
@@ -11,15 +11,15 @@ inherit autotools java gettext
11 11
12DEPENDS = "virtual/javac-native fastjar-native zip-native gmp antlr-native gtk+ gconf libxtst file" 12DEPENDS = "virtual/javac-native fastjar-native zip-native gmp antlr-native gtk+ gconf libxtst file"
13 13
14RPROVIDES_${PN} = "" 14RPROVIDES:${PN} = ""
15 15
16RDEPENDS_${PN} = "${PBN}-common (>= ${PV})" 16RDEPENDS:${PN} = "${PBN}-common (>= ${PV})"
17RDEPENDS_${PN}-examples = "java2-runtime ${PN}-awt" 17RDEPENDS:${PN}-examples = "java2-runtime ${PN}-awt"
18RDEPENDS_${PN}-tools = "java2-runtime" 18RDEPENDS:${PN}-tools = "java2-runtime"
19 19
20RPROVIDES_${PN} = "${PBN}" 20RPROVIDES:${PN} = "${PBN}"
21RPROVIDES_${PN}-common = "${PBN}-common" 21RPROVIDES:${PN}-common = "${PBN}-common"
22RPROVIDES_${PN}-gtk = "${PBN}-awt" 22RPROVIDES:${PN}-gtk = "${PBN}-awt"
23 23
24PR = "r3" 24PR = "r3"
25 25
@@ -49,7 +49,7 @@ EXTRA_OECONF = "\
49EXTRA_OECONF += "\ 49EXTRA_OECONF += "\
50 " 50 "
51 51
52do_configure_prepend () { 52do_configure:prepend () {
53 cp ${STAGING_DATADIR_NATIVE}/gettext/config.rpath ${S} 53 cp ${STAGING_DATADIR_NATIVE}/gettext/config.rpath ${S}
54} 54}
55 55
@@ -60,7 +60,7 @@ do_install() {
60} 60}
61 61
62# We really have valid non-symlink .so files 62# We really have valid non-symlink .so files
63INSANE_SKIP_${PN} = "dev-so" 63INSANE_SKIP:${PN} = "dev-so"
64 64
65# Defines the packages that this classpath recipe creates. 65# Defines the packages that this classpath recipe creates.
66# This allows the classpath-minimal variants to override this 66# This allows the classpath-minimal variants to override this
@@ -71,20 +71,20 @@ CPPACKAGES = "${PBN}-common ${PN}-examples \
71 71
72PACKAGES =+ "${CPPACKAGES}" 72PACKAGES =+ "${CPPACKAGES}"
73 73
74FILES_${PN}-dev += "${libdir}/${PBN}/*.la ${incdir}/${PBN}" 74FILES:${PN}-dev += "${libdir}/${PBN}/*.la ${incdir}/${PBN}"
75 75
76FILES_${PBN}-common = "${datadir}/${PBN}/glibj.zip ${libdir}/logging.properties ${libdir}/${PBN}/security" 76FILES:${PBN}-common = "${datadir}/${PBN}/glibj.zip ${libdir}/logging.properties ${libdir}/${PBN}/security"
77FILES_${PN}-examples = "${datadir}/${PBN}/examples" 77FILES:${PN}-examples = "${datadir}/${PBN}/examples"
78 78
79FILES_${PN}-tools = "${datadir}/${PBN}/tools.zip ${bindir}" 79FILES:${PN}-tools = "${datadir}/${PBN}/tools.zip ${bindir}"
80FILES_${PN}-tools-doc = "${mandir}" 80FILES:${PN}-tools-doc = "${mandir}"
81 81
82FILES_${PN}-dbg += "${libdir}/${PBN}/.debug" 82FILES:${PN}-dbg += "${libdir}/${PBN}/.debug"
83FILES_${PN}-doc = "${infodir}" 83FILES:${PN}-doc = "${infodir}"
84 84
85# gcjwebplugin - not built yet 85# gcjwebplugin - not built yet
86#FILES_${PN}-gcjwebplugin = "${libdir}/${PBN}/libgcjwebplugin.so" 86#FILES_${PN}-gcjwebplugin = "${libdir}/${PBN}/libgcjwebplugin.so"
87FILES_${PN}-gtk = "${libdir}/${PBN}/libgtkpeer.so ${libdir}/${PBN}/libjawt.so" 87FILES:${PN}-gtk = "${libdir}/${PBN}/libgtkpeer.so ${libdir}/${PBN}/libjawt.so"
88FILES_${PN}-gconf = "${libdir}/${PBN}/libgconfpeer.so" 88FILES:${PN}-gconf = "${libdir}/${PBN}/libgconfpeer.so"
89FILES_${PN} = "${libdir}/${PBN}/lib*so*" 89FILES:${PN} = "${libdir}/${PBN}/lib*so*"
90 90