summaryrefslogtreecommitdiffstats
path: root/recipes-core/cacao/cacao-1.6.1/system-boehm-gc.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/cacao/cacao-1.6.1/system-boehm-gc.patch')
-rw-r--r--recipes-core/cacao/cacao-1.6.1/system-boehm-gc.patch60
1 files changed, 60 insertions, 0 deletions
diff --git a/recipes-core/cacao/cacao-1.6.1/system-boehm-gc.patch b/recipes-core/cacao/cacao-1.6.1/system-boehm-gc.patch
new file mode 100644
index 0000000..c30f5be
--- /dev/null
+++ b/recipes-core/cacao/cacao-1.6.1/system-boehm-gc.patch
@@ -0,0 +1,60 @@
1cacao: use system's boehm garbage collector
2
3This is a Gentoo's patch [1] to force the use of system's bdwgc.
4
5Cacao was installing an internal version of bdwgc which conflicts
6with the system's version.
7
8[1] https://gitweb.gentoo.org/proj/java.git/plain/dev-java/cacao/files/system-boehm-gc.patch
9
10Upstream-Status: Inappropriate [not author]
11
12Signed-off-by: Hugo Vasconcelos Saldanha <hugo.saldanha@aker.com.br>
13
14diff --git a/configure.ac b/configure.ac
15--- a/configure.ac
16+++ b/configure.ac
17@@ -691,6 +691,8 @@
18
19 AC_CHECK_ENABLE_PIC_ASM
20
21+PKG_CHECK_MODULES([BOEHM], bdw-gc,,AC_MSG_ERROR[boehm-gc not found])
22+
23 dnl Define version numbers.
24 AC_VERSION_DETAIL
25 AC_VERSION_CONFIG
26@@ -793,12 +795,6 @@
27 )
28
29
30-dnl We only build the shared library objects but we use it as
31-dnl noinst_LTLIBRARIES.
32-ac_configure_args="$ac_configure_args --disable-static"
33-AC_CONFIG_SUBDIRS(src/mm/boehm-gc)
34-
35-
36 AC_OUTPUT
37
38
39diff --git a/src/mm/Makefile.am b/src/mm/Makefile.am
40--- a/src/mm/Makefile.am
41+++ b/src/mm/Makefile.am
42@@ -35,14 +35,13 @@
43 endif
44
45 if ENABLE_GC_BOEHM
46-SUBDIRS = \
47- boehm-gc
48-
49 GC_FILE = \
50 gc-boehm.cpp
51
52-GC_LIB = \
53- $(top_builddir)/src/mm/boehm-gc/libgc.la
54+AM_CPPFLAGS += $(BOEHM_CFLAGS)
55+
56+GC_LIB = $(BOEHM_LIBS)
57+
58 endif
59
60 if ENABLE_GC_CACAO