summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--classes/java-library.bbclass8
-rw-r--r--recipes-core/libmatthew/libmatthew.inc2
-rw-r--r--recipes-extended/rxtx/rxtx_2.2.0.bb2
3 files changed, 8 insertions, 4 deletions
diff --git a/classes/java-library.bbclass b/classes/java-library.bbclass
index ce1cd28..e0159ba 100644
--- a/classes/java-library.bbclass
+++ b/classes/java-library.bbclass
@@ -10,9 +10,13 @@
10# 10#
11# package archs are set to all, if the recipe builds also packages which 11# package archs are set to all, if the recipe builds also packages which
12# can not be used for all archs, then set the PACKAGE_ARCH of that package 12# can not be used for all archs, then set the PACKAGE_ARCH of that package
13# manually, see rxtx_xx.bb for an example. 13# manually *before* inheriting the class, see rxtx_xx.bb for an example.
14 14
15inherit java allarch 15inherit java
16PACKAGE_ARCH ?= "all"
17# Fully expanded - so it applies the overrides as well
18PACKAGE_ARCH_EXPANDED := "${PACKAGE_ARCH}"
19inherit ${@oe.utils.ifelse(d.getVar('PACKAGE_ARCH_EXPANDED') == 'all', 'allarch', '')}
16 20
17# use java_stage for native packages 21# use java_stage for native packages
18JAVA_NATIVE_STAGE_INSTALL = "1" 22JAVA_NATIVE_STAGE_INSTALL = "1"
diff --git a/recipes-core/libmatthew/libmatthew.inc b/recipes-core/libmatthew/libmatthew.inc
index 7db979b..2119c0b 100644
--- a/recipes-core/libmatthew/libmatthew.inc
+++ b/recipes-core/libmatthew/libmatthew.inc
@@ -7,8 +7,8 @@ DEPENDS = "virtual/java-native classpath-native classpath"
7 7
8S = "${WORKDIR}/libmatthew-java-${PV}" 8S = "${WORKDIR}/libmatthew-java-${PV}"
9 9
10inherit java-library
11PACKAGE_ARCH = "${TUNE_PKGARCH}" 10PACKAGE_ARCH = "${TUNE_PKGARCH}"
11inherit java-library
12 12
13# Some internal version numbers which change from time to time. 13# Some internal version numbers which change from time to time.
14# Allowing to override them makes this include file more 14# Allowing to override them makes this include file more
diff --git a/recipes-extended/rxtx/rxtx_2.2.0.bb b/recipes-extended/rxtx/rxtx_2.2.0.bb
index e54dad7..d4fbb9d 100644
--- a/recipes-extended/rxtx/rxtx_2.2.0.bb
+++ b/recipes-extended/rxtx/rxtx_2.2.0.bb
@@ -28,8 +28,8 @@ S = "${WORKDIR}/rxtx-2.2pre2"
28 28
29INSANE_SKIP_${JPN} += "dev-so" 29INSANE_SKIP_${JPN} += "dev-so"
30 30
31inherit autotools-brokensep java-library remove-libtool
32PACKAGE_ARCH = "${TUNE_PKGARCH}" 31PACKAGE_ARCH = "${TUNE_PKGARCH}"
32inherit autotools-brokensep java-library remove-libtool
33 33
34JARFILENAME = "RXTXcomm.jar" 34JARFILENAME = "RXTXcomm.jar"
35EXTRA_OEMAKE += "RXTX_PATH=${D}${libdir_jni} \ 35EXTRA_OEMAKE += "RXTX_PATH=${D}${libdir_jni} \