summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-core/ecj/libecj-bootstrap.inc9
-rw-r--r--recipes-core/junit/junit_3.8.2.bb5
2 files changed, 8 insertions, 6 deletions
diff --git a/recipes-core/ecj/libecj-bootstrap.inc b/recipes-core/ecj/libecj-bootstrap.inc
index 4f85ba9..9e1cc1d 100644
--- a/recipes-core/ecj/libecj-bootstrap.inc
+++ b/recipes-core/ecj/libecj-bootstrap.inc
@@ -25,17 +25,18 @@ do_unpackpost() {
25 fi 25 fi
26 26
27 # Remove crap. 27 # Remove crap.
28 rm about.html build.xml 28 rm -f about.html build.xml
29 rm -rf META-INF 29 rm -rf META-INF
30 30
31 # Move source into separate subdir. 31 # Move source into separate subdir.
32 mv org source/ 32 if [ -d org ]; then
33 33 mv org source/
34 fi
34 # Remove stuff unneeded for the bootstrap compiler. 35 # Remove stuff unneeded for the bootstrap compiler.
35 rm -rf source/org/eclipse/jdt/internal/compiler/apt 36 rm -rf source/org/eclipse/jdt/internal/compiler/apt
36 rm -rf source/org/eclipse/jdt/internal/compiler/tool 37 rm -rf source/org/eclipse/jdt/internal/compiler/tool
37 rm -rf source/org/eclipse/jdt/internal/antadapter 38 rm -rf source/org/eclipse/jdt/internal/antadapter
38 rm source/org/eclipse/jdt/core/JDTCompilerAdapter.java 39 rm -f source/org/eclipse/jdt/core/JDTCompilerAdapter.java
39 40
40 # Make a copy of the remaining source to get the embedded 41 # Make a copy of the remaining source to get the embedded
41 # resources. 42 # resources.
diff --git a/recipes-core/junit/junit_3.8.2.bb b/recipes-core/junit/junit_3.8.2.bb
index 9d56618..ded03f2 100644
--- a/recipes-core/junit/junit_3.8.2.bb
+++ b/recipes-core/junit/junit_3.8.2.bb
@@ -14,8 +14,9 @@ do_unpackpost() {
14 mkdir -p src 14 mkdir -p src
15 15
16 # Prevent deletion by do_removebinaries. 16 # Prevent deletion by do_removebinaries.
17 mv src.jar src.zip 17 if [ -e src.jar ]; then
18 18 mv src.jar src.zip
19 fi
19 unzip src.zip -d src 20 unzip src.zip -d src
20} 21}
21 22