summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--classes/java.bbclass18
-rw-r--r--recipes-core/xml-commons/dom4j_1.6.1.bb2
-rw-r--r--recipes-core/xml-commons/jaxen_1.1.1.bb2
-rw-r--r--recipes-core/xml-commons/jdom_1.1.bb2
4 files changed, 12 insertions, 12 deletions
diff --git a/classes/java.bbclass b/classes/java.bbclass
index 49c4c29..235ab23 100644
--- a/classes/java.bbclass
+++ b/classes/java.bbclass
@@ -5,21 +5,21 @@
5# the Debian distribution. 5# the Debian distribution.
6 6
7# Jar location on target 7# Jar location on target
8datadir_java ?= ${datadir}/java 8datadir_java ?= "${datadir}/java"
9 9
10# JNI library location on target 10# JNI library location on target
11libdir_jni ?= ${libdir}/jni 11libdir_jni ?= "${libdir}/jni"
12 12
13# JVM bundle location on target 13# JVM bundle location on target
14libdir_jvm ?= ${libdir}/jvm 14libdir_jvm ?= "${libdir}/jvm"
15 15
16STAGING_DATADIR_JAVA ?= ${STAGING_DATADIR}/java 16STAGING_DATADIR_JAVA ?= "${STAGING_DATADIR}/java"
17STAGING_LIBDIR_JNI ?= ${STAGING_LIBDIR}/jni 17STAGING_LIBDIR_JNI ?= "${STAGING_LIBDIR}/jni"
18STAGING_LIBDIR_JVM ?= ${STAGING_LIBDIR}/jvm 18STAGING_LIBDIR_JVM ?= "${STAGING_LIBDIR}/jvm"
19 19
20STAGING_DATADIR_JAVA_NATIVE ?= ${STAGING_DATADIR_NATIVE}/java 20STAGING_DATADIR_JAVA_NATIVE ?= "${STAGING_DATADIR_NATIVE}/java"
21STAGING_LIBDIR_JNI_NATIVE ?= ${STAGING_LIBDIR_NATIVE}/jni 21STAGING_LIBDIR_JNI_NATIVE ?= "${STAGING_LIBDIR_NATIVE}/jni"
22STAGING_LIBDIR_JVM_NATIVE ?= ${STAGING_LIBDIR_NATIVE}/jvm 22STAGING_LIBDIR_JVM_NATIVE ?= "${STAGING_LIBDIR_NATIVE}/jvm"
23 23
24oe_jarinstall() { 24oe_jarinstall() {
25 # Purpose: Install a jar file and create all the given symlinks to it. 25 # Purpose: Install a jar file and create all the given symlinks to it.
diff --git a/recipes-core/xml-commons/dom4j_1.6.1.bb b/recipes-core/xml-commons/dom4j_1.6.1.bb
index 94bd807..d26d2ee 100644
--- a/recipes-core/xml-commons/dom4j_1.6.1.bb
+++ b/recipes-core/xml-commons/dom4j_1.6.1.bb
@@ -1,7 +1,7 @@
1DESCRIPTION = "dom4j is a simple and flexible Java library for working with XML, XPath and XSLT" 1DESCRIPTION = "dom4j is a simple and flexible Java library for working with XML, XPath and XSLT"
2LICENSE = "BSD" 2LICENSE = "BSD"
3 3
4HOMEPAGE = "http://dom4j.org 4HOMEPAGE = "http://dom4j.org"
5 5
6DEPENDS = "fastjar-native xerces-j xalan-j xpp2 xpp3 jaxen" 6DEPENDS = "fastjar-native xerces-j xalan-j xpp2 xpp3 jaxen"
7 7
diff --git a/recipes-core/xml-commons/jaxen_1.1.1.bb b/recipes-core/xml-commons/jaxen_1.1.1.bb
index 7180dda..147ccf9 100644
--- a/recipes-core/xml-commons/jaxen_1.1.1.bb
+++ b/recipes-core/xml-commons/jaxen_1.1.1.bb
@@ -1,7 +1,7 @@
1DESCRIPTION = "XPath library written in Java" 1DESCRIPTION = "XPath library written in Java"
2LICENSE = "BSD" 2LICENSE = "BSD"
3 3
4HOMEPAGE = "http://jaxen.codehaus.org/ 4HOMEPAGE = "http://jaxen.codehaus.org/"
5 5
6DEPENDS = "fastjar-native xerces-j xom" 6DEPENDS = "fastjar-native xerces-j xom"
7 7
diff --git a/recipes-core/xml-commons/jdom_1.1.bb b/recipes-core/xml-commons/jdom_1.1.bb
index 1a77f05..cb53734 100644
--- a/recipes-core/xml-commons/jdom_1.1.bb
+++ b/recipes-core/xml-commons/jdom_1.1.bb
@@ -1,7 +1,7 @@
1DESCRIPTION = "Parses, manipulates, and outputs XML using standard Java constructs" 1DESCRIPTION = "Parses, manipulates, and outputs XML using standard Java constructs"
2LICENSE = "BSD" 2LICENSE = "BSD"
3 3
4HOMEPAGE = "http://jdom.org/ 4HOMEPAGE = "http://jdom.org/"
5 5
6DEPENDS = "fastjar-native jaxen" 6DEPENDS = "fastjar-native jaxen"
7 7