summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-core/classpath/classpath-initial_0.93.bb3
-rw-r--r--recipes-core/classpath/classpath-native.inc2
-rw-r--r--recipes-core/classpath/classpath.inc2
-rw-r--r--recipes-core/icedtea/icedtea6-native.inc2
-rw-r--r--recipes-core/jamvm/jamvm-initial_1.4.5.bb2
-rw-r--r--recipes-core/jamvm/jamvm_git.bb2
6 files changed, 12 insertions, 1 deletions
diff --git a/recipes-core/classpath/classpath-initial_0.93.bb b/recipes-core/classpath/classpath-initial_0.93.bb
index 77831c1..13ede10 100644
--- a/recipes-core/classpath/classpath-initial_0.93.bb
+++ b/recipes-core/classpath/classpath-initial_0.93.bb
@@ -32,6 +32,9 @@ EXTRA_OECONF = " \
32 --with-vm=java \ 32 --with-vm=java \
33 " 33 "
34 34
35# Ensure tools.zip is not installed at same path as classpath-native
36EXTRA_OEMAKE += "pkgdatadir=${STAGING_DATADIR_NATIVE}/classpath-initial"
37
35SRC_URI[md5sum] = "ffa9e9cac31c5acbf0ea9eff9efa923d" 38SRC_URI[md5sum] = "ffa9e9cac31c5acbf0ea9eff9efa923d"
36SRC_URI[sha256sum] = "df2d093612abd23fe67e9409d89bb2a8e79b1664fe2b2da40e1c8ed693e32945" 39SRC_URI[sha256sum] = "df2d093612abd23fe67e9409d89bb2a8e79b1664fe2b2da40e1c8ed693e32945"
37 40
diff --git a/recipes-core/classpath/classpath-native.inc b/recipes-core/classpath/classpath-native.inc
index aefbf6d..16c1498 100644
--- a/recipes-core/classpath/classpath-native.inc
+++ b/recipes-core/classpath/classpath-native.inc
@@ -4,6 +4,8 @@ LICENSE = "Classpath"
4 4
5DEPENDS = "ecj-initial fastjar-native zip-native gettext-native" 5DEPENDS = "ecj-initial fastjar-native zip-native gettext-native"
6 6
7PR = "r1"
8
7inherit autotools native 9inherit autotools native
8 10
9SRC_URI = "${GNU_MIRROR}/classpath/classpath-${PV}.tar.gz" 11SRC_URI = "${GNU_MIRROR}/classpath/classpath-${PV}.tar.gz"
diff --git a/recipes-core/classpath/classpath.inc b/recipes-core/classpath/classpath.inc
index 38037f3..55a3f6c 100644
--- a/recipes-core/classpath/classpath.inc
+++ b/recipes-core/classpath/classpath.inc
@@ -21,6 +21,8 @@ RPROVIDES_${PN} = "${PBN}"
21RPROVIDES_${PN}-common = "${PBN}-common" 21RPROVIDES_${PN}-common = "${PBN}-common"
22RPROVIDES_${PN}-gtk = "${PBN}-awt" 22RPROVIDES_${PN}-gtk = "${PBN}-awt"
23 23
24PR = "r1"
25
24SRC_URI = "${GNU_MIRROR}/classpath/classpath-${PV}.tar.gz" 26SRC_URI = "${GNU_MIRROR}/classpath/classpath-${PV}.tar.gz"
25 27
26S = "${WORKDIR}/${PBN}-${PV}" 28S = "${WORKDIR}/${PBN}-${PV}"
diff --git a/recipes-core/icedtea/icedtea6-native.inc b/recipes-core/icedtea/icedtea6-native.inc
index 7287462..700bfb0 100644
--- a/recipes-core/icedtea/icedtea6-native.inc
+++ b/recipes-core/icedtea/icedtea6-native.inc
@@ -1,7 +1,7 @@
1DESCRIPTION = "Harness to build the source code from OpenJDK using Free Software build tools" 1DESCRIPTION = "Harness to build the source code from OpenJDK using Free Software build tools"
2HOMEPAGE = "http://icedtea.classpath.org" 2HOMEPAGE = "http://icedtea.classpath.org"
3LICENSE = "GPL with Classpath Exception" 3LICENSE = "GPL with Classpath Exception"
4INC_PR = "r4" 4INC_PR = "r5"
5 5
6DEPENDS = "virtual/javac-native virtual/java-native classpath-native \ 6DEPENDS = "virtual/javac-native virtual/java-native classpath-native \
7 xalan-j-native xerces-j-native rhino-native \ 7 xalan-j-native xerces-j-native rhino-native \
diff --git a/recipes-core/jamvm/jamvm-initial_1.4.5.bb b/recipes-core/jamvm/jamvm-initial_1.4.5.bb
index 5fa9080..ea5a9d2 100644
--- a/recipes-core/jamvm/jamvm-initial_1.4.5.bb
+++ b/recipes-core/jamvm/jamvm-initial_1.4.5.bb
@@ -7,6 +7,8 @@ DEPENDS = "zlib-native classpath-initial jikes-initial libffi-native"
7 7
8PROVIDES = "virtual/java-initial" 8PROVIDES = "virtual/java-initial"
9 9
10PR = "r1"
11
10S = "${WORKDIR}/jamvm-${PV}" 12S = "${WORKDIR}/jamvm-${PV}"
11 13
12SRC_URI = "${SOURCEFORGE_MIRROR}/jamvm/jamvm-${PV}.tar.gz \ 14SRC_URI = "${SOURCEFORGE_MIRROR}/jamvm/jamvm-${PV}.tar.gz \
diff --git a/recipes-core/jamvm/jamvm_git.bb b/recipes-core/jamvm/jamvm_git.bb
index e6b6132..2a4213b 100644
--- a/recipes-core/jamvm/jamvm_git.bb
+++ b/recipes-core/jamvm/jamvm_git.bb
@@ -6,6 +6,8 @@ require jamvm.inc
6SRCREV = "4617da717ecb05654ea5bb9572338061106a414d" 6SRCREV = "4617da717ecb05654ea5bb9572338061106a414d"
7PV = "1.5.5+1.6.0-devel+git${SRCPV}" 7PV = "1.5.5+1.6.0-devel+git${SRCPV}"
8 8
9PR = "r1"
10
9SRC_URI = "git://git.berlios.de/jamvm;protocol=git \ 11SRC_URI = "git://git.berlios.de/jamvm;protocol=git \
10 file://jamvm-jni_h-noinst.patch \ 12 file://jamvm-jni_h-noinst.patch \
11 file://libffi.patch \ 13 file://libffi.patch \