diff options
-rw-r--r-- | recipes-core/jakarta-commons/commons-configuration_1.5.bb | 2 | ||||
-rw-r--r-- | recipes-core/jakarta-commons/commons-jxpath_1.3.bb | 2 | ||||
-rw-r--r-- | recipes-core/xml-commons/dom4j_1.6.1.bb | 2 | ||||
-rw-r--r-- | recipes-core/xml-commons/jaxen_1.1.1.bb | 2 | ||||
-rw-r--r-- | recipes-core/xml-commons/jaxme_0.5.2.bb | 14 | ||||
-rw-r--r-- | recipes-core/xml-commons/jdom_1.1.bb | 2 | ||||
-rw-r--r-- | recipes-core/xml-commons/xom_1.1.bb | 11 |
7 files changed, 35 insertions, 0 deletions
diff --git a/recipes-core/jakarta-commons/commons-configuration_1.5.bb b/recipes-core/jakarta-commons/commons-configuration_1.5.bb index 54409e5..eebb7f7 100644 --- a/recipes-core/jakarta-commons/commons-configuration_1.5.bb +++ b/recipes-core/jakarta-commons/commons-configuration_1.5.bb | |||
@@ -9,6 +9,8 @@ SRC_URI = " \ | |||
9 | http://ftp.hosting-studio.de/pub/linux/apache/ant/source/apache-ant-1.7.1-src.tar.bz2;name=ant \ | 9 | http://ftp.hosting-studio.de/pub/linux/apache/ant/source/apache-ant-1.7.1-src.tar.bz2;name=ant \ |
10 | " | 10 | " |
11 | 11 | ||
12 | PNBLACKLIST[commons-configuration] ?= "BROKEN: indirectly depends on broken 'xom'" | ||
13 | |||
12 | DEPENDS += "commons-logging commons-collections3 commons-beanutils commons-codec commons-digester commons-jxpath commons-lang servlet2.4" | 14 | DEPENDS += "commons-logging commons-collections3 commons-beanutils commons-codec commons-digester commons-jxpath commons-lang servlet2.4" |
13 | RDEPENDS_${PN} = "libcommons-logging-java libcommons-collections3-java libcommons-beanutils-java libcommons-codec-java libcommons-digester-java libcommons-jxpath-java libcommons-lang-java libservlet2.4-java" | 15 | RDEPENDS_${PN} = "libcommons-logging-java libcommons-collections3-java libcommons-beanutils-java libcommons-codec-java libcommons-digester-java libcommons-jxpath-java libcommons-lang-java libservlet2.4-java" |
14 | 16 | ||
diff --git a/recipes-core/jakarta-commons/commons-jxpath_1.3.bb b/recipes-core/jakarta-commons/commons-jxpath_1.3.bb index d380ed9..8ccbad1 100644 --- a/recipes-core/jakarta-commons/commons-jxpath_1.3.bb +++ b/recipes-core/jakarta-commons/commons-jxpath_1.3.bb | |||
@@ -6,6 +6,8 @@ DESCRIPTION = "JXPath interpreter for Java" | |||
6 | 6 | ||
7 | SRC_URI = "http://archive.apache.org/dist/commons/jxpath/source/${BP}-src.tar.gz" | 7 | SRC_URI = "http://archive.apache.org/dist/commons/jxpath/source/${BP}-src.tar.gz" |
8 | 8 | ||
9 | PNBLACKLIST[commons-jxpath] ?= "BROKEN: indirectly depends on broken 'xom'" | ||
10 | |||
9 | DEPENDS += "commons-logging commons-collections3 commons-beanutils servlet2.3 jdom" | 11 | DEPENDS += "commons-logging commons-collections3 commons-beanutils servlet2.3 jdom" |
10 | RDEPENDS_${PN} = "libcommons-logging-java libcommons-collections3-java libcommons-beanutils-java libservlet2.3-java libjdom-java" | 12 | RDEPENDS_${PN} = "libcommons-logging-java libcommons-collections3-java libcommons-beanutils-java libservlet2.3-java libjdom-java" |
11 | 13 | ||
diff --git a/recipes-core/xml-commons/dom4j_1.6.1.bb b/recipes-core/xml-commons/dom4j_1.6.1.bb index d26d2ee..19dca74 100644 --- a/recipes-core/xml-commons/dom4j_1.6.1.bb +++ b/recipes-core/xml-commons/dom4j_1.6.1.bb | |||
@@ -11,6 +11,8 @@ SRC_URI = "\ | |||
11 | file://debian.patch \ | 11 | file://debian.patch \ |
12 | " | 12 | " |
13 | 13 | ||
14 | PNBLACKLIST[dom4j] ?= "BROKEN: indirectly depends on broken 'xom'" | ||
15 | |||
14 | inherit java-library | 16 | inherit java-library |
15 | 17 | ||
16 | do_compile() { | 18 | do_compile() { |
diff --git a/recipes-core/xml-commons/jaxen_1.1.1.bb b/recipes-core/xml-commons/jaxen_1.1.1.bb index 147ccf9..4853683 100644 --- a/recipes-core/xml-commons/jaxen_1.1.1.bb +++ b/recipes-core/xml-commons/jaxen_1.1.1.bb | |||
@@ -10,6 +10,8 @@ SRC_URI = "\ | |||
10 | http://www.jdom.org/dist/binary/archive/jdom-1.1.tar.gz;name=jdom \ | 10 | http://www.jdom.org/dist/binary/archive/jdom-1.1.tar.gz;name=jdom \ |
11 | " | 11 | " |
12 | 12 | ||
13 | PNBLACKLIST[jaxen] ?= "BROKEN: depends on broken 'xom'" | ||
14 | |||
13 | inherit java-library | 15 | inherit java-library |
14 | 16 | ||
15 | do_compile() { | 17 | do_compile() { |
diff --git a/recipes-core/xml-commons/jaxme_0.5.2.bb b/recipes-core/xml-commons/jaxme_0.5.2.bb index b4ec750..03f4f57 100644 --- a/recipes-core/xml-commons/jaxme_0.5.2.bb +++ b/recipes-core/xml-commons/jaxme_0.5.2.bb | |||
@@ -9,6 +9,20 @@ SRC_URI = "\ | |||
9 | http://ftp.hosting-studio.de/pub/linux/apache/ant/source/apache-ant-1.7.1-src.tar.bz2;name=ant \ | 9 | http://ftp.hosting-studio.de/pub/linux/apache/ant/source/apache-ant-1.7.1-src.tar.bz2;name=ant \ |
10 | " | 10 | " |
11 | 11 | ||
12 | # do_compile: | ||
13 | # 2. ERROR in src/jaxme/org/apache/ws/jaxme/generator/XJCTask.java (at line 30) | ||
14 | # import org.apache.ws.jaxme.generator.sg.SGFactoryChain; | ||
15 | # ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ | ||
16 | # The import org.apache.ws.jaxme.generator.sg.SGFactoryChain cannot be resolved | ||
17 | # ---------- | ||
18 | # 3. ERROR in src/jaxme/org/apache/ws/jaxme/generator/XJCTask.java (at line 1055) | ||
19 | # if (!SGFactoryChain.class.isAssignableFrom(c)) { | ||
20 | # ^^^^^^^^^^^^^^ | ||
21 | # SGFactoryChain cannot be resolved to a type | ||
22 | # ---------- | ||
23 | # ... and many more | ||
24 | PNBLACKLIST[jaxme] ?= "BROKEN: do_compile fails" | ||
25 | |||
12 | S = "${WORKDIR}/ws-${P}" | 26 | S = "${WORKDIR}/ws-${P}" |
13 | 27 | ||
14 | inherit java-library | 28 | inherit java-library |
diff --git a/recipes-core/xml-commons/jdom_1.1.bb b/recipes-core/xml-commons/jdom_1.1.bb index cb53734..4867e82 100644 --- a/recipes-core/xml-commons/jdom_1.1.bb +++ b/recipes-core/xml-commons/jdom_1.1.bb | |||
@@ -9,6 +9,8 @@ SRC_URI = "\ | |||
9 | http://www.jdom.org/dist/binary/archive/jdom-${PV}.tar.gz \ | 9 | http://www.jdom.org/dist/binary/archive/jdom-${PV}.tar.gz \ |
10 | " | 10 | " |
11 | 11 | ||
12 | PNBLACKLIST[jdom] ?= "BROKEN: indirectly depends on broken 'xom'" | ||
13 | |||
12 | inherit java-library | 14 | inherit java-library |
13 | 15 | ||
14 | do_compile() { | 16 | do_compile() { |
diff --git a/recipes-core/xml-commons/xom_1.1.bb b/recipes-core/xml-commons/xom_1.1.bb index 7405dab..c37965b 100644 --- a/recipes-core/xml-commons/xom_1.1.bb +++ b/recipes-core/xml-commons/xom_1.1.bb | |||
@@ -10,6 +10,17 @@ SRC_URI = "\ | |||
10 | file://04_remove_sun_import.patch \ | 10 | file://04_remove_sun_import.patch \ |
11 | " | 11 | " |
12 | 12 | ||
13 | # DEBUG: Executing shell function do_compile | ||
14 | # ---------- | ||
15 | # 1. ERROR in src/nu/xom/UnicodeUtil.java (at line 0) | ||
16 | # /* Copyright 2005 Elliotte Rusty Harold | ||
17 | # ^ | ||
18 | # Internal compiler error: java.lang.StackOverflowError at org.eclipse.jdt.internal.compiler.ast.Expression.checkNPE(Expression.java:511) | ||
19 | # ---------- | ||
20 | # Exception in thread "main" java.lang.StackOverflowError | ||
21 | # at org.eclipse.jdt.internal.compiler.ast.Expression.checkNPE(Expression.java:511) | ||
22 | PNBLACKLIST[xom] ?= "BROKEN: do_compile fails with internal javac error" | ||
23 | |||
13 | S = "${WORKDIR}/XOM" | 24 | S = "${WORKDIR}/XOM" |
14 | 25 | ||
15 | inherit java-library | 26 | inherit java-library |