diff options
-rw-r--r-- | recipes-core/icedtea/icedtea7-native.inc | 9 |
1 files changed, 9 insertions, 0 deletions
diff --git a/recipes-core/icedtea/icedtea7-native.inc b/recipes-core/icedtea/icedtea7-native.inc index d624b7a..3344acb 100644 --- a/recipes-core/icedtea/icedtea7-native.inc +++ b/recipes-core/icedtea/icedtea7-native.inc | |||
@@ -17,6 +17,13 @@ PACKAGECONFIG[x11] = ",--disable-headful,libx11-native xproto-native libxt-nativ | |||
17 | OEMAKE_BUILD_HEADLESS_ONLY = "${@bb.utils.contains('PACKAGECONFIG', 'x11', '', 'BUILD_HEADLESS_ONLY=1', d)}" | 17 | OEMAKE_BUILD_HEADLESS_ONLY = "${@bb.utils.contains('PACKAGECONFIG', 'x11', '', 'BUILD_HEADLESS_ONLY=1', d)}" |
18 | CFLAGS_append = "${@bb.utils.contains('PACKAGECONFIG', 'x11', '', ' -DHEADLESS=true', d)}" | 18 | CFLAGS_append = "${@bb.utils.contains('PACKAGECONFIG', 'x11', '', ' -DHEADLESS=true', d)}" |
19 | 19 | ||
20 | # Disable dead store elimination and set C++ standard to C++98. | ||
21 | # There are dead stores in the JVM that would be pretty hard to | ||
22 | # remove, so disable the optimisation in the compiler. | ||
23 | CFLAGS_append = " -fno-tree-dse" | ||
24 | CXXFLAGS_append = " -fno-tree-dse" | ||
25 | CXX_append = " -std=gnu++98" | ||
26 | |||
20 | inherit native java autotools pkgconfig | 27 | inherit native java autotools pkgconfig |
21 | 28 | ||
22 | JAVA_HOME[unexport] = "1" | 29 | JAVA_HOME[unexport] = "1" |
@@ -153,6 +160,8 @@ do_configure_append() { | |||
153 | for F in openjdk/hotspot/make/linux/makefiles/gcc.make openjdk/hotspot/agent/src/os/linux/Makefile ; | 160 | for F in openjdk/hotspot/make/linux/makefiles/gcc.make openjdk/hotspot/agent/src/os/linux/Makefile ; |
154 | do | 161 | do |
155 | sed -i \ | 162 | sed -i \ |
163 | -e"s|HOST_GCC = gcc$|HOST_GCC = ${CC}|" \ | ||
164 | -e"s|HOST_CPP = g++$|HOST_CPP = ${CXX}|" \ | ||
156 | -e"s|gcc\$(GCC_SUFFIX)|${CC}|" \ | 165 | -e"s|gcc\$(GCC_SUFFIX)|${CC}|" \ |
157 | -e"s|g++\$(GCC_SUFFIX)|${CXX}|" \ | 166 | -e"s|g++\$(GCC_SUFFIX)|${CXX}|" \ |
158 | $F | 167 | $F |