diff options
37 files changed, 51 insertions, 49 deletions
diff --git a/classes/java-bootstrap-components.bbclass b/classes/java-bootstrap-components.bbclass new file mode 100644 index 0000000..0c62b5b --- /dev/null +++ b/classes/java-bootstrap-components.bbclass | |||
@@ -0,0 +1,7 @@ | |||
1 | # This is to be used by recipes which rely on java-library.bbclass | ||
2 | # infrastructure and their a *-native recipe are parts of the bootstrap | ||
3 | # process | ||
4 | # | ||
5 | |||
6 | DEPENDS_prepend_class-native = " ecj-bootstrap-native " | ||
7 | DEPENDS_prepend_class-target = " virtual/javac-native " | ||
diff --git a/classes/java-library.bbclass b/classes/java-library.bbclass index 144cd2f..a192f14 100644 --- a/classes/java-library.bbclass +++ b/classes/java-library.bbclass | |||
@@ -35,7 +35,8 @@ def java_package_name(d): | |||
35 | 35 | ||
36 | JPN ?= "${@java_package_name(d)}" | 36 | JPN ?= "${@java_package_name(d)}" |
37 | 37 | ||
38 | DEPENDS_prepend = "virtual/javac-native fastjar-native " | 38 | DEPENDS_prepend = " fastjar-native " |
39 | DEPENDS_prepend_class-target = " virtual/javac-native " | ||
39 | 40 | ||
40 | PACKAGES += "${JPN}" | 41 | PACKAGES += "${JPN}" |
41 | 42 | ||
diff --git a/recipes-core/ant/ant-native_1.8.1.bb b/recipes-core/ant/ant-native_1.8.1.bb index 35b45d6..6cdbc80 100644 --- a/recipes-core/ant/ant-native_1.8.1.bb +++ b/recipes-core/ant/ant-native_1.8.1.bb | |||
@@ -11,7 +11,7 @@ SRC_URI = "http://archive.apache.org/dist/ant/source/apache-ant-${PV}-src.tar.gz | |||
11 | 11 | ||
12 | S = "${WORKDIR}/apache-ant-${PV}" | 12 | S = "${WORKDIR}/apache-ant-${PV}" |
13 | 13 | ||
14 | inherit java-library java-native | 14 | inherit java-library java-native java-bootstrap-components |
15 | 15 | ||
16 | DEPENDS = " \ | 16 | DEPENDS = " \ |
17 | jsch-native bsf-native xalan-j-native xerces-j-native \ | 17 | jsch-native bsf-native xalan-j-native xerces-j-native \ |
diff --git a/recipes-core/cacao/cacao_1.6.1.bb b/recipes-core/cacao/cacao_1.6.1.bb index 8e212af..a8c1f19 100644 --- a/recipes-core/cacao/cacao_1.6.1.bb +++ b/recipes-core/cacao/cacao_1.6.1.bb | |||
@@ -7,7 +7,9 @@ SECTION = "interpreters" | |||
7 | DEPENDS_class-native = "zlib-native libtool-native ecj-initial-native fastjar-native classpath-native bdwgc-native" | 7 | DEPENDS_class-native = "zlib-native libtool-native ecj-initial-native fastjar-native classpath-native bdwgc-native" |
8 | PROVIDES_class-native = "virtual/java-native" | 8 | PROVIDES_class-native = "virtual/java-native" |
9 | 9 | ||
10 | DEPENDS = "zlib libtool classpath virtual/javac-native bdwgc" | 10 | DEPENDS_class-target = " virtual/javac-native " |
11 | |||
12 | DEPENDS = "zlib libtool classpath bdwgc" | ||
11 | RPROVIDES_${PN} = "java2-runtime" | 13 | RPROVIDES_${PN} = "java2-runtime" |
12 | 14 | ||
13 | SRC_URI = "http://www.complang.tuwien.ac.at/cacaojvm/download/cacao-${PV}/cacao-${PV}.tar.xz \ | 15 | SRC_URI = "http://www.complang.tuwien.ac.at/cacaojvm/download/cacao-${PV}/cacao-${PV}.tar.xz \ |
diff --git a/recipes-core/classpath/classpath.inc b/recipes-core/classpath/classpath.inc index 1bdfd78..c56c0c3 100644 --- a/recipes-core/classpath/classpath.inc +++ b/recipes-core/classpath/classpath.inc | |||
@@ -7,9 +7,9 @@ LICENSE = "Classpath" | |||
7 | 7 | ||
8 | PBN = "classpath" | 8 | PBN = "classpath" |
9 | 9 | ||
10 | inherit autotools java gettext | 10 | inherit autotools java gettext java-bootstrap-components |
11 | 11 | ||
12 | DEPENDS = "virtual/javac-native fastjar-native zip-native gmp antlr-native gtk+ gconf libxtst file" | 12 | DEPENDS = " fastjar-native zip-native gmp antlr-native gtk+ gconf libxtst file" |
13 | 13 | ||
14 | RPROVIDES_${PN} = "" | 14 | RPROVIDES_${PN} = "" |
15 | 15 | ||
diff --git a/recipes-core/classpathx/gnujaf_1.1.1.bb b/recipes-core/classpathx/gnujaf_1.1.1.bb index 0bd8b57..5520ef7 100644 --- a/recipes-core/classpathx/gnujaf_1.1.1.bb +++ b/recipes-core/classpathx/gnujaf_1.1.1.bb | |||
@@ -10,7 +10,7 @@ SRC_URI = "http://ftp.gnu.org/gnu/classpathx/activation-${PV}.tar.gz \ | |||
10 | file://MimeType-symbols-fix.patch \ | 10 | file://MimeType-symbols-fix.patch \ |
11 | " | 11 | " |
12 | 12 | ||
13 | inherit java-library | 13 | inherit java-library java-bootstrap-components |
14 | 14 | ||
15 | S = "${WORKDIR}/activation-${PV}" | 15 | S = "${WORKDIR}/activation-${PV}" |
16 | 16 | ||
diff --git a/recipes-core/classpathx/gnumail_1.1.2.bb b/recipes-core/classpathx/gnumail_1.1.2.bb index 5e81a45..41417c0 100644 --- a/recipes-core/classpathx/gnumail_1.1.2.bb +++ b/recipes-core/classpathx/gnumail_1.1.2.bb | |||
@@ -8,7 +8,7 @@ SRC_URI = "http://ftp.gnu.org/gnu/classpathx/mail-${PV}.tar.gz \ | |||
8 | file://datadir_java.patch \ | 8 | file://datadir_java.patch \ |
9 | " | 9 | " |
10 | 10 | ||
11 | inherit java-library autotools | 11 | inherit java-library java-bootstrap-components autotools |
12 | 12 | ||
13 | S = "${WORKDIR}/mail-${PV}" | 13 | S = "${WORKDIR}/mail-${PV}" |
14 | 14 | ||
diff --git a/recipes-core/classpathx/inetlib_1.1.1.bb b/recipes-core/classpathx/inetlib_1.1.1.bb index f078e33..3b3f299 100644 --- a/recipes-core/classpathx/inetlib_1.1.1.bb +++ b/recipes-core/classpathx/inetlib_1.1.1.bb | |||
@@ -9,7 +9,7 @@ SRC_URI = "http://ftp.gnu.org/gnu/classpath/${BP}.tar.gz \ | |||
9 | file://datadir_java.patch \ | 9 | file://datadir_java.patch \ |
10 | " | 10 | " |
11 | 11 | ||
12 | inherit java-library autotools | 12 | inherit java-library java-bootstrap-components autotools |
13 | 13 | ||
14 | JPN = "libgnuinet-java" | 14 | JPN = "libgnuinet-java" |
15 | 15 | ||
diff --git a/recipes-core/ecj/ecj-bootstrap-native.bb b/recipes-core/ecj/ecj-bootstrap-native.bb index e159c9d..a4a1c17 100644 --- a/recipes-core/ecj/ecj-bootstrap-native.bb +++ b/recipes-core/ecj/ecj-bootstrap-native.bb | |||
@@ -12,7 +12,7 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d | |||
12 | " | 12 | " |
13 | PR = "r1" | 13 | PR = "r1" |
14 | 14 | ||
15 | DEPENDS = "libecj-bootstrap-native virtual/java-native" | 15 | DEPENDS = "libecj-bootstrap-native cacao-native" |
16 | 16 | ||
17 | PROVIDES = "virtual/javac-native" | 17 | PROVIDES = "virtual/javac-native" |
18 | 18 | ||
diff --git a/recipes-core/ecj/libecj-bootstrap.inc b/recipes-core/ecj/libecj-bootstrap.inc index 020b8d3..a634a31 100644 --- a/recipes-core/ecj/libecj-bootstrap.inc +++ b/recipes-core/ecj/libecj-bootstrap.inc | |||
@@ -5,7 +5,7 @@ HOMEPAGE = "http://www.eclipse.org/" | |||
5 | LICENSE = "EPL-1.0" | 5 | LICENSE = "EPL-1.0" |
6 | LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/EPL-1.0;md5=57f8d5e2b3e98ac6e088986c12bf94e6" | 6 | LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/EPL-1.0;md5=57f8d5e2b3e98ac6e088986c12bf94e6" |
7 | 7 | ||
8 | DEPENDS = "fastjar-native jikes-initial-native virtual/java-initial-native" | 8 | DEPENDS = "fastjar-native jikes-initial-native cacao-initial-native" |
9 | 9 | ||
10 | INC_PR = "r5" | 10 | INC_PR = "r5" |
11 | 11 | ||
diff --git a/recipes-core/icedtea/icedtea7-native.inc b/recipes-core/icedtea/icedtea7-native.inc index 43385e9..279700b 100644 --- a/recipes-core/icedtea/icedtea7-native.inc +++ b/recipes-core/icedtea/icedtea7-native.inc | |||
@@ -3,7 +3,7 @@ HOMEPAGE = "http://icedtea.classpath.org" | |||
3 | LICENSE = "GPL-2.0-with-classpath-exception" | 3 | LICENSE = "GPL-2.0-with-classpath-exception" |
4 | INC_PR = "r1" | 4 | INC_PR = "r1" |
5 | 5 | ||
6 | DEPENDS = "virtual/javac-native virtual/java-native classpath-native \ | 6 | DEPENDS = "fastjar-native cacao-native classpath-native \ |
7 | rhino-native ant-native libxslt-native attr-native \ | 7 | rhino-native ant-native libxslt-native attr-native \ |
8 | giflib-native jpeg-native libpng-native \ | 8 | giflib-native jpeg-native libpng-native \ |
9 | glib-2.0-native freetype-native zlib-native \ | 9 | glib-2.0-native freetype-native zlib-native \ |
diff --git a/recipes-core/jacl/jacl_1.4.1.bb b/recipes-core/jacl/jacl_1.4.1.bb index b413719..f9808ca 100644 --- a/recipes-core/jacl/jacl_1.4.1.bb +++ b/recipes-core/jacl/jacl_1.4.1.bb | |||
@@ -10,7 +10,7 @@ HOMEPAGE = "http://sourceforge.net/projects/tcljava" | |||
10 | 10 | ||
11 | SRC_URI = "http://downloads.sourceforge.net/tcljava/jacl${PV}.tar.gz" | 11 | SRC_URI = "http://downloads.sourceforge.net/tcljava/jacl${PV}.tar.gz" |
12 | 12 | ||
13 | inherit java-library | 13 | inherit java-library java-bootstrap-components |
14 | 14 | ||
15 | S = "${WORKDIR}/jacl${PV}" | 15 | S = "${WORKDIR}/jacl${PV}" |
16 | 16 | ||
diff --git a/recipes-core/jakarta-commons/commons-logging_1.1.1.bb b/recipes-core/jakarta-commons/commons-logging_1.1.1.bb index b3b508a..8b1efe0 100644 --- a/recipes-core/jakarta-commons/commons-logging_1.1.1.bb +++ b/recipes-core/jakarta-commons/commons-logging_1.1.1.bb | |||
@@ -1,5 +1,7 @@ | |||
1 | require jakarta-commons.inc | 1 | require jakarta-commons.inc |
2 | 2 | ||
3 | inherit java-bootstrap-components | ||
4 | |||
3 | PR = "${INC_PR}.1" | 5 | PR = "${INC_PR}.1" |
4 | 6 | ||
5 | DESCRIPTION = "Java Internet protocol suite library" | 7 | DESCRIPTION = "Java Internet protocol suite library" |
diff --git a/recipes-core/jakarta-commons/commons-net_1.4.1.bb b/recipes-core/jakarta-commons/commons-net_1.4.1.bb index 275ebb9..7c03b82 100644 --- a/recipes-core/jakarta-commons/commons-net_1.4.1.bb +++ b/recipes-core/jakarta-commons/commons-net_1.4.1.bb | |||
@@ -1,5 +1,7 @@ | |||
1 | require jakarta-commons.inc | 1 | require jakarta-commons.inc |
2 | 2 | ||
3 | inherit java-bootstrap-components | ||
4 | |||
3 | PR = "${INC_PR}.1" | 5 | PR = "${INC_PR}.1" |
4 | 6 | ||
5 | DESCRIPTION = "Java Internet protocol suite library" | 7 | DESCRIPTION = "Java Internet protocol suite library" |
diff --git a/recipes-core/jakarta-libs/avalon-framework-api_4.3.bb b/recipes-core/jakarta-libs/avalon-framework-api_4.3.bb index 081cfe7..2e2bb59 100644 --- a/recipes-core/jakarta-libs/avalon-framework-api_4.3.bb +++ b/recipes-core/jakarta-libs/avalon-framework-api_4.3.bb | |||
@@ -9,7 +9,7 @@ SRC_URI = " \ | |||
9 | http://archive.apache.org/dist/avalon/logkit/source/logkit-1.2.2-src.tar.gz;name=logkit \ | 9 | http://archive.apache.org/dist/avalon/logkit/source/logkit-1.2.2-src.tar.gz;name=logkit \ |
10 | " | 10 | " |
11 | 11 | ||
12 | inherit java-library | 12 | inherit java-library java-bootstrap-components |
13 | 13 | ||
14 | do_compile() { | 14 | do_compile() { |
15 | mkdir -p build | 15 | mkdir -p build |
diff --git a/recipes-core/jakarta-libs/bsf_2.4.0.bb b/recipes-core/jakarta-libs/bsf_2.4.0.bb index 0213004..e23503c 100644 --- a/recipes-core/jakarta-libs/bsf_2.4.0.bb +++ b/recipes-core/jakarta-libs/bsf_2.4.0.bb | |||
@@ -6,7 +6,7 @@ LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=b1e01b26bacfc2232046c90a330332b3" | |||
6 | 6 | ||
7 | SRC_URI = "http://archive.apache.org/dist/jakarta/bsf/source/bsf-src-${PV}.tar.gz" | 7 | SRC_URI = "http://archive.apache.org/dist/jakarta/bsf/source/bsf-src-${PV}.tar.gz" |
8 | 8 | ||
9 | inherit java-library | 9 | inherit java-library java-bootstrap-components |
10 | 10 | ||
11 | DEPENDS = "jacl commons-logging rhino xalan-j bcel" | 11 | DEPENDS = "jacl commons-logging rhino xalan-j bcel" |
12 | DEPENDS_virtclass-native = "jacl-native commons-logging-native rhino-native xalan-j-native bcel-native" | 12 | DEPENDS_virtclass-native = "jacl-native commons-logging-native rhino-native xalan-j-native bcel-native" |
diff --git a/recipes-core/jakarta-libs/log4j1.2_1.2.17.bb b/recipes-core/jakarta-libs/log4j1.2_1.2.17.bb index b4ccd2c..50ef4a2 100644 --- a/recipes-core/jakarta-libs/log4j1.2_1.2.17.bb +++ b/recipes-core/jakarta-libs/log4j1.2_1.2.17.bb | |||
@@ -7,7 +7,7 @@ PR = "r2" | |||
7 | 7 | ||
8 | SRC_URI = "http://archive.apache.org/dist/logging/log4j/${PV}/log4j-${PV}.tar.gz" | 8 | SRC_URI = "http://archive.apache.org/dist/logging/log4j/${PV}/log4j-${PV}.tar.gz" |
9 | 9 | ||
10 | inherit java-library | 10 | inherit java-library java-bootstrap-components |
11 | 11 | ||
12 | DEPENDS = "gnumail gnujaf" | 12 | DEPENDS = "gnumail gnujaf" |
13 | DEPENDS_virtclass-native = "gnumail-native gnujaf-native" | 13 | DEPENDS_virtclass-native = "gnumail-native gnujaf-native" |
diff --git a/recipes-core/jakarta-libs/logkit_1.2.2.bb b/recipes-core/jakarta-libs/logkit_1.2.2.bb index c3b612b..24fdfac 100644 --- a/recipes-core/jakarta-libs/logkit_1.2.2.bb +++ b/recipes-core/jakarta-libs/logkit_1.2.2.bb | |||
@@ -6,7 +6,7 @@ PR = "r1" | |||
6 | 6 | ||
7 | SRC_URI = "http://archive.apache.org/dist/avalon/logkit/source/${BP}-src.tar.gz" | 7 | SRC_URI = "http://archive.apache.org/dist/avalon/logkit/source/${BP}-src.tar.gz" |
8 | 8 | ||
9 | inherit java-library | 9 | inherit java-library java-bootstrap-components |
10 | 10 | ||
11 | S = "${WORKDIR}/${BP}-dev" | 11 | S = "${WORKDIR}/${BP}-dev" |
12 | 12 | ||
diff --git a/recipes-core/jakarta-libs/oro_2.0.8.bb b/recipes-core/jakarta-libs/oro_2.0.8.bb index 0a7fba3..308eb55 100644 --- a/recipes-core/jakarta-libs/oro_2.0.8.bb +++ b/recipes-core/jakarta-libs/oro_2.0.8.bb | |||
@@ -6,7 +6,7 @@ PR = "r1" | |||
6 | 6 | ||
7 | SRC_URI = "http://archive.apache.org/dist/jakarta/oro/source/jakarta-${BP}.tar.gz" | 7 | SRC_URI = "http://archive.apache.org/dist/jakarta/oro/source/jakarta-${BP}.tar.gz" |
8 | 8 | ||
9 | inherit java-library | 9 | inherit java-library java-bootstrap-components |
10 | 10 | ||
11 | S = "${WORKDIR}/jakarta-${BP}" | 11 | S = "${WORKDIR}/jakarta-${BP}" |
12 | 12 | ||
diff --git a/recipes-core/jakarta-libs/poi_3.0.bb b/recipes-core/jakarta-libs/poi_3.0.bb index f9178f2..55279c1 100644 --- a/recipes-core/jakarta-libs/poi_3.0.bb +++ b/recipes-core/jakarta-libs/poi_3.0.bb | |||
@@ -9,7 +9,7 @@ S = "${WORKDIR}/${BPN}-3.0-rc4" | |||
9 | 9 | ||
10 | inherit java-library | 10 | inherit java-library |
11 | 11 | ||
12 | DEPENDS = "fastjar-native commons-collections3 commons-logging commons-lang commons-beanutils log4j1.2 xalan-j" | 12 | DEPENDS = "commons-collections3 commons-logging commons-lang commons-beanutils log4j1.2 xalan-j" |
13 | 13 | ||
14 | do_compile() { | 14 | do_compile() { |
15 | mkdir -p build | 15 | mkdir -p build |
diff --git a/recipes-core/jakarta-libs/regexp_1.5.bb b/recipes-core/jakarta-libs/regexp_1.5.bb index ce6150c..d482e4a 100644 --- a/recipes-core/jakarta-libs/regexp_1.5.bb +++ b/recipes-core/jakarta-libs/regexp_1.5.bb | |||
@@ -6,7 +6,7 @@ PR = "r1" | |||
6 | 6 | ||
7 | SRC_URI = "http://archive.apache.org/dist/jakarta/regexp/source/jakarta-${BP}.tar.gz" | 7 | SRC_URI = "http://archive.apache.org/dist/jakarta/regexp/source/jakarta-${BP}.tar.gz" |
8 | 8 | ||
9 | inherit java-library | 9 | inherit java-library java-bootstrap-components |
10 | 10 | ||
11 | S = "${WORKDIR}/jakarta-${BP}" | 11 | S = "${WORKDIR}/jakarta-${BP}" |
12 | 12 | ||
diff --git a/recipes-core/jamvm/jamvm.inc b/recipes-core/jamvm/jamvm.inc index 5893cbc..6480225 100644 --- a/recipes-core/jamvm/jamvm.inc +++ b/recipes-core/jamvm/jamvm.inc | |||
@@ -3,7 +3,7 @@ HOMEPAGE = "http://jamvm.sourceforge.net/" | |||
3 | LICENSE = "GPL-2.0" | 3 | LICENSE = "GPL-2.0" |
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3" | 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3" |
5 | 5 | ||
6 | DEPENDS = "zlib classpath virtual/javac-native libffi" | 6 | DEPENDS = "zlib classpath libffi" |
7 | DEPENDS_virtclass-native = "zlib-native classpath-native ecj-initial-native libffi-native" | 7 | DEPENDS_virtclass-native = "zlib-native classpath-native ecj-initial-native libffi-native" |
8 | 8 | ||
9 | RDEPENDS_${PN} = "classpath" | 9 | RDEPENDS_${PN} = "classpath" |
@@ -21,7 +21,7 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/jamvm/jamvm-${PV}.tar.gz \ | |||
21 | " | 21 | " |
22 | 22 | ||
23 | 23 | ||
24 | inherit java autotools update-alternatives pkgconfig | 24 | inherit java autotools update-alternatives pkgconfig java-bootstrap-components |
25 | 25 | ||
26 | # This uses 32 bit arm, so force the instruction set to arm, not thumb | 26 | # This uses 32 bit arm, so force the instruction set to arm, not thumb |
27 | ARM_INSTRUCTION_SET = "arm" | 27 | ARM_INSTRUCTION_SET = "arm" |
diff --git a/recipes-core/jcraft/jsch_0.1.40.bb b/recipes-core/jcraft/jsch_0.1.40.bb index 337a8eb..d22eb0a 100644 --- a/recipes-core/jcraft/jsch_0.1.40.bb +++ b/recipes-core/jcraft/jsch_0.1.40.bb | |||
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=55e3b6a0987ccd0c34530f3df2d206ae" | |||
5 | 5 | ||
6 | SRC_URI = "${SOURCEFORGE_MIRROR}/jsch/jsch-${PV}.zip" | 6 | SRC_URI = "${SOURCEFORGE_MIRROR}/jsch/jsch-${PV}.zip" |
7 | 7 | ||
8 | inherit java-library | 8 | inherit java-library java-bootstrap-components |
9 | 9 | ||
10 | DEPENDS = "jzlib" | 10 | DEPENDS = "jzlib" |
11 | DEPENDS_virtclass-native = "jzlib-native" | 11 | DEPENDS_virtclass-native = "jzlib-native" |
diff --git a/recipes-core/jcraft/jzlib_1.0.7.bb b/recipes-core/jcraft/jzlib_1.0.7.bb index b6f3f64..79fc4d4 100644 --- a/recipes-core/jcraft/jzlib_1.0.7.bb +++ b/recipes-core/jcraft/jzlib_1.0.7.bb | |||
@@ -6,7 +6,7 @@ HOMEPAGE = "http://www.jcraft.com/jzlib" | |||
6 | 6 | ||
7 | SRC_URI = "http://www.jcraft.com/jzlib/jzlib-${PV}.tar.gz" | 7 | SRC_URI = "http://www.jcraft.com/jzlib/jzlib-${PV}.tar.gz" |
8 | 8 | ||
9 | inherit java-library | 9 | inherit java-library java-bootstrap-components |
10 | 10 | ||
11 | do_compile() { | 11 | do_compile() { |
12 | mkdir -p build | 12 | mkdir -p build |
diff --git a/recipes-core/jdepend/jdepend_2.9.1.bb b/recipes-core/jdepend/jdepend_2.9.1.bb index 9f74f44..8f41c00 100644 --- a/recipes-core/jdepend/jdepend_2.9.1.bb +++ b/recipes-core/jdepend/jdepend_2.9.1.bb | |||
@@ -8,7 +8,7 @@ HOMEPAGE = "http://clarkware.com/software/JDepend.html" | |||
8 | 8 | ||
9 | SRC_URI = "http://www.clarkware.com/software/jdepend-${PV}.zip" | 9 | SRC_URI = "http://www.clarkware.com/software/jdepend-${PV}.zip" |
10 | 10 | ||
11 | inherit java-library | 11 | inherit java-library java-bootstrap-components |
12 | 12 | ||
13 | do_compile() { | 13 | do_compile() { |
14 | mkdir -p build | 14 | mkdir -p build |
diff --git a/recipes-core/jlex/jlex_1.2.6.bb b/recipes-core/jlex/jlex_1.2.6.bb index 4dbe63e..9290fa5 100644 --- a/recipes-core/jlex/jlex_1.2.6.bb +++ b/recipes-core/jlex/jlex_1.2.6.bb | |||
@@ -8,7 +8,7 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d | |||
8 | RDEPENDS_${PN} = "java2-runtime" | 8 | RDEPENDS_${PN} = "java2-runtime" |
9 | RDEPENDS_${PN}_virtclass-native = "" | 9 | RDEPENDS_${PN}_virtclass-native = "" |
10 | 10 | ||
11 | inherit java-library | 11 | inherit java-library java-bootstrap-components |
12 | 12 | ||
13 | SRC_URI = "http://www.cs.princeton.edu/~appel/modern/java/JLex/Archive/${PV}/Main.java \ | 13 | SRC_URI = "http://www.cs.princeton.edu/~appel/modern/java/JLex/Archive/${PV}/Main.java \ |
14 | file://jlex \ | 14 | file://jlex \ |
diff --git a/recipes-core/junit/junit4_4.3.1.bb b/recipes-core/junit/junit4_4.3.1.bb index 1cb8674..8d9dd31 100644 --- a/recipes-core/junit/junit4_4.3.1.bb +++ b/recipes-core/junit/junit4_4.3.1.bb | |||
@@ -8,9 +8,7 @@ SRC_URI = "http://downloads.sourceforge.net/junit/junit-${PV}-src.jar" | |||
8 | 8 | ||
9 | S = "${WORKDIR}" | 9 | S = "${WORKDIR}" |
10 | 10 | ||
11 | inherit java-library | 11 | inherit java-library java-bootstrap-components |
12 | |||
13 | DEPENDS = "fastjar-native" | ||
14 | 12 | ||
15 | do_compile() { | 13 | do_compile() { |
16 | mkdir -p build | 14 | mkdir -p build |
diff --git a/recipes-core/junit/junit_3.8.2.bb b/recipes-core/junit/junit_3.8.2.bb index bae022d..54ce9fe 100644 --- a/recipes-core/junit/junit_3.8.2.bb +++ b/recipes-core/junit/junit_3.8.2.bb | |||
@@ -11,7 +11,7 @@ S = "${WORKDIR}/junit${PV}" | |||
11 | 11 | ||
12 | DEPENDS += "unzip-native" | 12 | DEPENDS += "unzip-native" |
13 | 13 | ||
14 | inherit java-library | 14 | inherit java-library java-bootstrap-components |
15 | 15 | ||
16 | do_unpackpost() { | 16 | do_unpackpost() { |
17 | mkdir -p src | 17 | mkdir -p src |
diff --git a/recipes-core/rhino/rhino_1.7r4.bb b/recipes-core/rhino/rhino_1.7r4.bb index 7898d23..76c3057 100644 --- a/recipes-core/rhino/rhino_1.7r4.bb +++ b/recipes-core/rhino/rhino_1.7r4.bb | |||
@@ -4,7 +4,7 @@ LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=8e2372bdbf22c99279ae4599a13cc458" | |||
4 | 4 | ||
5 | BBCLASSEXTEND = "native" | 5 | BBCLASSEXTEND = "native" |
6 | 6 | ||
7 | inherit java-library | 7 | inherit java-library java-bootstrap-components |
8 | 8 | ||
9 | SRC_URI = "\ | 9 | SRC_URI = "\ |
10 | https://github.com/downloads/mozilla/rhino/rhino1_7R4.zip \ | 10 | https://github.com/downloads/mozilla/rhino/rhino1_7R4.zip \ |
diff --git a/recipes-core/servlet-api/servlet2.3_4.1.37.bb b/recipes-core/servlet-api/servlet2.3_4.1.37.bb index fbda5c8..f5f6d4a 100644 --- a/recipes-core/servlet-api/servlet2.3_4.1.37.bb +++ b/recipes-core/servlet-api/servlet2.3_4.1.37.bb | |||
@@ -6,12 +6,10 @@ PR = "r1" | |||
6 | 6 | ||
7 | SRC_URI = "http://archive.apache.org/dist/tomcat/tomcat-4/v${PV}/src/apache-tomcat-${PV}-src.tar.gz" | 7 | SRC_URI = "http://archive.apache.org/dist/tomcat/tomcat-4/v${PV}/src/apache-tomcat-${PV}-src.tar.gz" |
8 | 8 | ||
9 | inherit java-library | 9 | inherit java-library java-bootstrap-components |
10 | 10 | ||
11 | S = "${WORKDIR}/apache-tomcat-${PV}-src/servletapi" | 11 | S = "${WORKDIR}/apache-tomcat-${PV}-src/servletapi" |
12 | 12 | ||
13 | DEPENDS = "fastjar-native" | ||
14 | |||
15 | # Value of implementation.revision in build.xml | 13 | # Value of implementation.revision in build.xml |
16 | IMPL_REVISION = "1" | 14 | IMPL_REVISION = "1" |
17 | 15 | ||
diff --git a/recipes-core/servlet-api/servlet2.4_5.5.26.bb b/recipes-core/servlet-api/servlet2.4_5.5.26.bb index b34b23d..7d0feb3 100644 --- a/recipes-core/servlet-api/servlet2.4_5.5.26.bb +++ b/recipes-core/servlet-api/servlet2.4_5.5.26.bb | |||
@@ -9,8 +9,6 @@ S = "${WORKDIR}/apache-tomcat-${PV}-src/servletapi/jsr154" | |||
9 | 9 | ||
10 | inherit java-library | 10 | inherit java-library |
11 | 11 | ||
12 | DEPENDS = "fastjar-native" | ||
13 | |||
14 | # Value of implementation.revision in build.xml | 12 | # Value of implementation.revision in build.xml |
15 | IMPL_REVISION = "1" | 13 | IMPL_REVISION = "1" |
16 | 14 | ||
diff --git a/recipes-core/xalan-j/xalan-j_2.7.1.bb b/recipes-core/xalan-j/xalan-j_2.7.1.bb index 317b3c9..16f5396 100644 --- a/recipes-core/xalan-j/xalan-j_2.7.1.bb +++ b/recipes-core/xalan-j/xalan-j_2.7.1.bb | |||
@@ -21,7 +21,7 @@ SRC_URI = "\ | |||
21 | 21 | ||
22 | S = "${WORKDIR}/${BPN}_2_7_1" | 22 | S = "${WORKDIR}/${BPN}_2_7_1" |
23 | 23 | ||
24 | inherit java-library | 24 | inherit java-library java-bootstrap-components |
25 | 25 | ||
26 | JPN = "libxalan2-java" | 26 | JPN = "libxalan2-java" |
27 | 27 | ||
diff --git a/recipes-core/xerces-j/xerces-j_2.11.0.bb b/recipes-core/xerces-j/xerces-j_2.11.0.bb index f9e497e..4130457 100644 --- a/recipes-core/xerces-j/xerces-j_2.11.0.bb +++ b/recipes-core/xerces-j/xerces-j_2.11.0.bb | |||
@@ -16,12 +16,12 @@ SRC_URI = "http://archive.apache.org/dist/xerces/j/Xerces-J-src.${PV}.tar.gz" | |||
16 | 16 | ||
17 | S = "${WORKDIR}/xerces-2_11_0" | 17 | S = "${WORKDIR}/xerces-2_11_0" |
18 | 18 | ||
19 | inherit java-library | 19 | inherit java-library java-bootstrap-components |
20 | 20 | ||
21 | JPN = "libxerces2-java" | 21 | JPN = "libxerces2-java" |
22 | 22 | ||
23 | DEPENDS = "fastjar-native jaxp1.3 xml-commons-resolver1.1" | 23 | DEPENDS = "jaxp1.3 xml-commons-resolver1.1" |
24 | DEPENDS_virtclass-native = "fastjar-native jaxp1.3-native xml-commons-resolver1.1-native" | 24 | DEPENDS_virtclass-native = "jaxp1.3-native xml-commons-resolver1.1-native" |
25 | 25 | ||
26 | RDEPENDS_${PN} = "libjaxp1.3-java libxml-commons-resolver1.1-java" | 26 | RDEPENDS_${PN} = "libjaxp1.3-java libxml-commons-resolver1.1-java" |
27 | RDEPENDS_${PN}_virtclass-native = "" | 27 | RDEPENDS_${PN}_virtclass-native = "" |
diff --git a/recipes-core/xml-commons/jaxp1.3_1.4.01.bb b/recipes-core/xml-commons/jaxp1.3_1.4.01.bb index a6eeb57..765b766 100644 --- a/recipes-core/xml-commons/jaxp1.3_1.4.01.bb +++ b/recipes-core/xml-commons/jaxp1.3_1.4.01.bb | |||
@@ -11,9 +11,7 @@ LIC_FILES_CHKSUM = " \ | |||
11 | 11 | ||
12 | SRC_URI = "http://archive.apache.org/dist/xml/commons/source/xml-commons-external-${PV}-src.tar.gz;subdir=${BPN}-${PV}" | 12 | SRC_URI = "http://archive.apache.org/dist/xml/commons/source/xml-commons-external-${PV}-src.tar.gz;subdir=${BPN}-${PV}" |
13 | 13 | ||
14 | inherit java-library | 14 | inherit java-library java-bootstrap-components |
15 | |||
16 | DEPENDS = "fastjar-native" | ||
17 | 15 | ||
18 | JARFILENAME = "jaxp-1.3.jar" | 16 | JARFILENAME = "jaxp-1.3.jar" |
19 | ALTJARFILENAMES = "xml-apis.jar" | 17 | ALTJARFILENAMES = "xml-apis.jar" |
diff --git a/recipes-core/xml-commons/xml-commons-resolver1.1_1.2.bb b/recipes-core/xml-commons/xml-commons-resolver1.1_1.2.bb index 5853895..ca1f2f2 100644 --- a/recipes-core/xml-commons/xml-commons-resolver1.1_1.2.bb +++ b/recipes-core/xml-commons/xml-commons-resolver1.1_1.2.bb | |||
@@ -6,12 +6,12 @@ LIC_FILES_CHKSUM = "file://LICENSE.resolver.txt;md5=d229da563da18fe5d58cd95a6467 | |||
6 | 6 | ||
7 | SRC_URI = "http://archive.apache.org/dist/xml/commons/xml-commons-resolver-${PV}.tar.gz" | 7 | SRC_URI = "http://archive.apache.org/dist/xml/commons/xml-commons-resolver-${PV}.tar.gz" |
8 | 8 | ||
9 | inherit java-library | 9 | inherit java-library java-bootstrap-components |
10 | 10 | ||
11 | S = "${WORKDIR}/xml-commons-resolver-${PV}" | 11 | S = "${WORKDIR}/xml-commons-resolver-${PV}" |
12 | 12 | ||
13 | DEPENDS = "fastjar-native jaxp1.3" | 13 | DEPENDS = "jaxp1.3" |
14 | DEPENDS_virtclass-native = "fastjar-native jaxp1.3-native" | 14 | DEPENDS_virtclass-native = "jaxp1.3-native" |
15 | 15 | ||
16 | do_unpackpost() { | 16 | do_unpackpost() { |
17 | find src -exec \ | 17 | find src -exec \ |
diff --git a/recipes-core/xml-commons/xpp2_2.1.10.bb b/recipes-core/xml-commons/xpp2_2.1.10.bb index d3baca4..402d38d 100644 --- a/recipes-core/xml-commons/xpp2_2.1.10.bb +++ b/recipes-core/xml-commons/xpp2_2.1.10.bb | |||
@@ -9,8 +9,6 @@ S = "${WORKDIR}/PullParser${PV}" | |||
9 | 9 | ||
10 | inherit java-library | 10 | inherit java-library |
11 | 11 | ||
12 | DEPENDS = "fastjar-native virtual/javac-native" | ||
13 | |||
14 | do_compile() { | 12 | do_compile() { |
15 | if [ -d build-oe ]; then | 13 | if [ -d build-oe ]; then |
16 | rm -rf build-oe | 14 | rm -rf build-oe |
diff --git a/recipes-core/xml-commons/xpp3_1.1.3.4.O.bb b/recipes-core/xml-commons/xpp3_1.1.3.4.O.bb index bedb8a9..a472a0d 100644 --- a/recipes-core/xml-commons/xpp3_1.1.3.4.O.bb +++ b/recipes-core/xml-commons/xpp3_1.1.3.4.O.bb | |||
@@ -8,8 +8,6 @@ SRC_URI = "http://www.extreme.indiana.edu/dist/java-repository/xpp3/distribution | |||
8 | 8 | ||
9 | inherit java-library | 9 | inherit java-library |
10 | 10 | ||
11 | DEPENDS = "fastjar-native virtual/javac-native" | ||
12 | |||
13 | PACKAGES = "libxpp3-xpath-java ${JPN}" | 11 | PACKAGES = "libxpp3-xpath-java ${JPN}" |
14 | 12 | ||
15 | do_compile() { | 13 | do_compile() { |