diff options
author | Henning Heinold <henning@itconsulting-heinold.de> | 2014-03-01 21:40:46 +0100 |
---|---|---|
committer | Henning Heinold <henning@itconsulting-heinold.de> | 2014-03-05 22:41:27 +0100 |
commit | 6c01d9fa201b5578d64650c0fdab1c13a82a0c42 (patch) | |
tree | 252092d3e65af3d3e67093919b2b0bc24d99d0d7 /recipes-core | |
parent | a664d984e31223b36aff7033bd07e6cf25dedca1 (diff) | |
download | meta-java-6c01d9fa201b5578d64650c0fdab1c13a82a0c42.tar.gz |
openjdk-common.inc: fix qemu usage
* compile all binaries, which are executed by qemu, with the static compilerflag,
because of a memleak inside qemu
* remove lib- and ld-path for qemu usage, because all binaries
are compiled static now, openjdk7 seems to compile fine anyway
Diffstat (limited to 'recipes-core')
-rw-r--r-- | recipes-core/openjdk/openjdk-6-6b27/icedtea-crosscompile-fix.patch | 13 | ||||
-rw-r--r-- | recipes-core/openjdk/openjdk-common.inc | 2 |
2 files changed, 14 insertions, 1 deletions
diff --git a/recipes-core/openjdk/openjdk-6-6b27/icedtea-crosscompile-fix.patch b/recipes-core/openjdk/openjdk-6-6b27/icedtea-crosscompile-fix.patch index 09db502..9a60bd6 100644 --- a/recipes-core/openjdk/openjdk-6-6b27/icedtea-crosscompile-fix.patch +++ b/recipes-core/openjdk/openjdk-6-6b27/icedtea-crosscompile-fix.patch | |||
@@ -454,3 +454,16 @@ index 2021434..9035da7 100644 | |||
454 | -I$(SHARE_SRC)/native/$(PKGDIR)/image \ | 454 | -I$(SHARE_SRC)/native/$(PKGDIR)/image \ |
455 | -I$(SHARE_SRC)/native/$(PKGDIR)/image/cvutils \ | 455 | -I$(SHARE_SRC)/native/$(PKGDIR)/image/cvutils \ |
456 | -I$(SHARE_SRC)/native/$(PKGDIR)/alphacomposite \ | 456 | -I$(SHARE_SRC)/native/$(PKGDIR)/alphacomposite \ |
457 | diff --git openjdk/jdk/make/sun/xawt/Makefile openjdk/jdk/make/sun/xawt/Makefile | ||
458 | index 1fa311d..f3d06ad 100644 | ||
459 | --- openjdk/jdk/make/sun/xawt/Makefile | ||
460 | +++ openjdk/jdk/make/sun/xawt/Makefile | ||
461 | @@ -232,7 +232,7 @@ XLIBTYPES=$(PLATFORM_SRC)/classes/sun/awt/X11/generator/xlibtypes.txt | ||
462 | |||
463 | $(SIZERS): $(SIZERS_C) | ||
464 | $(prep-target) | ||
465 | - $(CC) $(CFLAGS_$(subst .,,$(suffix $@))) $(CPPFLAGS) -o $@ $(SIZER)$(suffix $@).c | ||
466 | + $(CC) $(CFLAGS_$(subst .,,$(suffix $@))) $(CPPFLAGS) -static -o $@ $(SIZER)$(suffix $@).c | ||
467 | |||
468 | $(WRAPPER_GENERATOR_CLASS): $(WRAPPER_GENERATOR_JAVA) | ||
469 | $(prep-target) | ||
diff --git a/recipes-core/openjdk/openjdk-common.inc b/recipes-core/openjdk/openjdk-common.inc index a993ea0..9c746de 100644 --- a/recipes-core/openjdk/openjdk-common.inc +++ b/recipes-core/openjdk/openjdk-common.inc | |||
@@ -72,6 +72,6 @@ export WANT_LLVM_RELEASE = "2.8" | |||
72 | export LLVM_CONFIGURE_ARCH="${@get_llvm_configure_arch(d)}" | 72 | export LLVM_CONFIGURE_ARCH="${@get_llvm_configure_arch(d)}" |
73 | 73 | ||
74 | # Large stack is required at least on x86_64 host, otherwise random segfaults appear: | 74 | # Large stack is required at least on x86_64 host, otherwise random segfaults appear: |
75 | QEMU = "${@qemu_target_binary(d)} ${QEMU_OPTIONS} -s 2097152 -L ${STAGING_DIR_TARGET} -E LD_LIBRARY_PATH=${STAGING_BASELIBDIR}" | 75 | QEMU = "${@qemu_target_binary(d)} ${QEMU_OPTIONS} -s 2097152" |
76 | 76 | ||
77 | EXTRA_OEMAKE += 'QEMU="${QEMU}"' | 77 | EXTRA_OEMAKE += 'QEMU="${QEMU}"' |