summaryrefslogtreecommitdiffstats
path: root/recipes-core
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2013-05-12 02:01:47 -0700
committerHenning Heinold <heinold@inf.fu-berlin.de>2013-09-29 21:49:39 +0200
commitbac4a2703747dbe7644bb9c9bee331dc1ecc6ac1 (patch)
tree852103d046ffa74a227ccf6c35ccaf3989fe119f /recipes-core
parent3b0d35ce4741a4a98f8c38a59f466d6e0b69851e (diff)
downloadmeta-java-bac4a2703747dbe7644bb9c9bee331dc1ecc6ac1.tar.gz
icedtea: Make shared state friendly
icedtea-native encodes absolute build time classpaths which wont work in sstate however at same time we can override it with env variables like BOOTCLASSPATH and LD_LIBRARY_PATH to reflect current build environment. Secondly, exclude ICEDTEA_PARALLEL_MAKE from shared state signatures, it can alter signatures if PARALLEL_MAKE value between producer and consumer of sstate is not matching. Now that icedtea7-native is shared state safe, remove the shared state invalidation on jamvm-native that was needed for icedtea7-native to build Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes-core')
-rw-r--r--recipes-core/icedtea/icedtea7-native.inc10
-rw-r--r--recipes-core/jamvm/jamvm-initial_1.4.5.bb2
-rw-r--r--recipes-core/jamvm/jamvm.inc2
3 files changed, 7 insertions, 7 deletions
diff --git a/recipes-core/icedtea/icedtea7-native.inc b/recipes-core/icedtea/icedtea7-native.inc
index b9e2056..aa105b7 100644
--- a/recipes-core/icedtea/icedtea7-native.inc
+++ b/recipes-core/icedtea/icedtea7-native.inc
@@ -35,6 +35,8 @@ B = "${S}/build"
35# openjdk looks in /usr/include and /usr/lib for freetype by default. 35# openjdk looks in /usr/include and /usr/lib for freetype by default.
36export ALT_FREETYPE_HEADERS_PATH = "${STAGING_INCDIR}/freetype2" 36export ALT_FREETYPE_HEADERS_PATH = "${STAGING_INCDIR}/freetype2"
37export ALT_FREETYPE_LIB_PATH = "${STAGING_LIBDIR}" 37export ALT_FREETYPE_LIB_PATH = "${STAGING_LIBDIR}"
38export LD_LIBRARY_PATH = "$LD_LIBRARY_PATH:${STAGING_LIBDIR}/classpath:${STAGING_LIBDIR}/jamvm"
39export BOOTCLASSPATH = "${STAGING_DATADIR}/jamvm/classes.zip:${STAGING_DATADIR}/classpath/glibj.zip"
38 40
39# OpenJDK supports parallel compilation but uses a plain number for this. 41# OpenJDK supports parallel compilation but uses a plain number for this.
40# In OE we have PARALLEL_MAKE which is the actual option passed to make, 42# In OE we have PARALLEL_MAKE which is the actual option passed to make,
@@ -55,10 +57,8 @@ def get_jdk7_native_jobs(d):
55 # Whatever found in PARALLEL_MAKE was not suitable. 57 # Whatever found in PARALLEL_MAKE was not suitable.
56 return "1" 58 return "1"
57 59
58JDK_JOBS = "${@get_jdk7_native_jobs(d)}"
59
60EXTRA_OECONF = "\ 60EXTRA_OECONF = "\
61 --with-parallel-jobs=${JDK_JOBS} \ 61 --with-parallel-jobs=${@get_jdk7_native_jobs(d)} \
62 \ 62 \
63 --disable-tests \ 63 --disable-tests \
64 --disable-hotspot-tests \ 64 --disable-hotspot-tests \
@@ -88,8 +88,6 @@ JDK_DIR = "icedtea7-native"
88JDK_INSTALL_DIR = "${D}/${libdir_jvm}/${JDK_DIR}" 88JDK_INSTALL_DIR = "${D}/${libdir_jvm}/${JDK_DIR}"
89 89
90do_configure_prepend() { 90do_configure_prepend() {
91 echo "Configure with parallel-jobs: ${JDK_JOBS}"
92
93 case "${TRANSLATED_TARGET_ARCH}" in 91 case "${TRANSLATED_TARGET_ARCH}" in
94 x86-64) 92 x86-64)
95 libarch=amd64 93 libarch=amd64
@@ -248,3 +246,5 @@ do_install() {
248 # Fix missing write permissions on the files. 246 # Fix missing write permissions on the files.
249 chmod ug+w -R ${JDK_INSTALL_DIR} 247 chmod ug+w -R ${JDK_INSTALL_DIR}
250} 248}
249
250get_jdk7_native_jobs[vardepsexclude] += "ICEDTEA_PARALLEL_MAKE"
diff --git a/recipes-core/jamvm/jamvm-initial_1.4.5.bb b/recipes-core/jamvm/jamvm-initial_1.4.5.bb
index d317695..4c64f6a 100644
--- a/recipes-core/jamvm/jamvm-initial_1.4.5.bb
+++ b/recipes-core/jamvm/jamvm-initial_1.4.5.bb
@@ -47,4 +47,4 @@ SRC_URI[md5sum] = "3f538bab6e1c77aed331e5e71f754f5b"
47SRC_URI[sha256sum] = "f329d1c8f42c06b53a3e82763d33900b100b8e9acd7afe02f7583c51253fd6e5" 47SRC_URI[sha256sum] = "f329d1c8f42c06b53a3e82763d33900b100b8e9acd7afe02f7583c51253fd6e5"
48# shared state for jamvm-native does not work 48# shared state for jamvm-native does not work
49# since the paths are hardcoded 49# since the paths are hardcoded
50SSTATE_MIRRORS_class-native = "" 50#SSTATE_MIRRORS_class-native = ""
diff --git a/recipes-core/jamvm/jamvm.inc b/recipes-core/jamvm/jamvm.inc
index ee0e5c0..84c8513 100644
--- a/recipes-core/jamvm/jamvm.inc
+++ b/recipes-core/jamvm/jamvm.inc
@@ -49,5 +49,5 @@ ALTERNATIVE_PATH = "${bindir}/jamvm"
49ALTERNATIVE_PRIORITY = "4" 49ALTERNATIVE_PRIORITY = "4"
50# shared state for jamvm-native does not work 50# shared state for jamvm-native does not work
51# since the paths are hardcoded 51# since the paths are hardcoded
52SSTATE_MIRRORS_class-native = "" 52#SSTATE_MIRRORS_class-native = ""
53 53