summaryrefslogtreecommitdiffstats
path: root/recipes-core
diff options
context:
space:
mode:
authorMario Domenech Goulart <mario@ossystems.com.br>2015-08-18 17:14:29 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2015-08-18 18:54:17 -0300
commit15ed9662e26ed4ac8d843fb9d2335a49a9c03088 (patch)
treea8eb428c5e22f6cb3e4fc117d192740f9d438f65 /recipes-core
parent5cdef85d4a3e06c0ce680a3bb115f4f060adc949 (diff)
downloadmeta-java-15ed9662e26ed4ac8d843fb9d2335a49a9c03088.tar.gz
Don't depend on a hardcoded compiler
The recipes below depended on a hardcoded native compile (ecj-initial-native). Since we may use another native compiler to build them, we set the dependency in virtual/javac-native instead. * cacao * classpath-native * jamvm Signed-off-by: Mario Domenech Goulart <mario@ossystems.com.br> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-core')
-rw-r--r--recipes-core/cacao/cacao_1.6.1.bb2
-rw-r--r--recipes-core/classpath/classpath-native_0.99.bb2
-rw-r--r--recipes-core/jamvm/jamvm.inc2
3 files changed, 3 insertions, 3 deletions
diff --git a/recipes-core/cacao/cacao_1.6.1.bb b/recipes-core/cacao/cacao_1.6.1.bb
index 65aaf93..14ff019 100644
--- a/recipes-core/cacao/cacao_1.6.1.bb
+++ b/recipes-core/cacao/cacao_1.6.1.bb
@@ -4,7 +4,7 @@ LICENSE = "GPL-2.0"
4LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552" 4LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
5SECTION = "interpreters" 5SECTION = "interpreters"
6 6
7DEPENDS_class-native = "zlib-native libtool-native ecj-initial-native fastjar-native classpath-native bdwgc-native" 7DEPENDS_class-native = "zlib-native libtool-native virtual/javac-native fastjar-native classpath-native bdwgc-native"
8PROVIDES_class-native = "virtual/java-native" 8PROVIDES_class-native = "virtual/java-native"
9 9
10DEPENDS = "zlib libtool classpath virtual/javac-native bdwgc" 10DEPENDS = "zlib libtool classpath virtual/javac-native bdwgc"
diff --git a/recipes-core/classpath/classpath-native_0.99.bb b/recipes-core/classpath/classpath-native_0.99.bb
index 02951b9..cf297d9 100644
--- a/recipes-core/classpath/classpath-native_0.99.bb
+++ b/recipes-core/classpath/classpath-native_0.99.bb
@@ -1,7 +1,7 @@
1require classpath-native.inc 1require classpath-native.inc
2 2
3LIC_FILES_CHKSUM = "file://COPYING;md5=af0004801732bc4b20d90f351cf80510" 3LIC_FILES_CHKSUM = "file://COPYING;md5=af0004801732bc4b20d90f351cf80510"
4DEPENDS += "ecj-initial-native" 4DEPENDS += "virtual/javac-native"
5 5
6PR = "${INC_PR}.0" 6PR = "${INC_PR}.0"
7 7
diff --git a/recipes-core/jamvm/jamvm.inc b/recipes-core/jamvm/jamvm.inc
index 5893cbc..bed1c5d 100644
--- a/recipes-core/jamvm/jamvm.inc
+++ b/recipes-core/jamvm/jamvm.inc
@@ -4,7 +4,7 @@ LICENSE = "GPL-2.0"
4LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3" 4LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
5 5
6DEPENDS = "zlib classpath virtual/javac-native libffi" 6DEPENDS = "zlib classpath virtual/javac-native libffi"
7DEPENDS_virtclass-native = "zlib-native classpath-native ecj-initial-native libffi-native" 7DEPENDS_virtclass-native = "zlib-native classpath-native virtual/javac-native libffi-native"
8 8
9RDEPENDS_${PN} = "classpath" 9RDEPENDS_${PN} = "classpath"
10RDEPENDS_${PN}_virtclass-native = "" 10RDEPENDS_${PN}_virtclass-native = ""