summaryrefslogtreecommitdiffstats
path: root/recipes-core/xml-commons
diff options
context:
space:
mode:
authorMax Krummenacher <max.oss.09@gmail.com>2015-02-17 10:57:16 +0100
committerOtavio Salvador <otavio@ossystems.com.br>2015-02-17 10:53:34 -0200
commit77f0eabfff1ff614f5c10abc35a164e8968e5130 (patch)
treeea1a21b3510d34eb6139cf7686cc5feb5f976207 /recipes-core/xml-commons
parent9b33eee75b70bd431f6cac098e97d3b6dd220b51 (diff)
downloadmeta-java-77f0eabfff1ff614f5c10abc35a164e8968e5130.tar.gz
mark broken recipes with PNBLACKLIST
While testing commit 'java-library: inherit allarch' I found some recipes throwing errors in do_compile. The recipes jaxme and xom currently don't build with compiler errors. jaxen, dom4j, jdom, commons-jxpath, commons-configuration depend directly or indirectly on jaxme and/or xom and thus are unbildable. Signed-off-by: Max Krummenacher <max.oss.09@gmail.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-core/xml-commons')
-rw-r--r--recipes-core/xml-commons/dom4j_1.6.1.bb2
-rw-r--r--recipes-core/xml-commons/jaxen_1.1.1.bb2
-rw-r--r--recipes-core/xml-commons/jaxme_0.5.2.bb14
-rw-r--r--recipes-core/xml-commons/jdom_1.1.bb2
-rw-r--r--recipes-core/xml-commons/xom_1.1.bb11
5 files changed, 31 insertions, 0 deletions
diff --git a/recipes-core/xml-commons/dom4j_1.6.1.bb b/recipes-core/xml-commons/dom4j_1.6.1.bb
index d26d2ee..19dca74 100644
--- a/recipes-core/xml-commons/dom4j_1.6.1.bb
+++ b/recipes-core/xml-commons/dom4j_1.6.1.bb
@@ -11,6 +11,8 @@ SRC_URI = "\
11 file://debian.patch \ 11 file://debian.patch \
12 " 12 "
13 13
14PNBLACKLIST[dom4j] ?= "BROKEN: indirectly depends on broken 'xom'"
15
14inherit java-library 16inherit java-library
15 17
16do_compile() { 18do_compile() {
diff --git a/recipes-core/xml-commons/jaxen_1.1.1.bb b/recipes-core/xml-commons/jaxen_1.1.1.bb
index 147ccf9..4853683 100644
--- a/recipes-core/xml-commons/jaxen_1.1.1.bb
+++ b/recipes-core/xml-commons/jaxen_1.1.1.bb
@@ -10,6 +10,8 @@ SRC_URI = "\
10 http://www.jdom.org/dist/binary/archive/jdom-1.1.tar.gz;name=jdom \ 10 http://www.jdom.org/dist/binary/archive/jdom-1.1.tar.gz;name=jdom \
11 " 11 "
12 12
13PNBLACKLIST[jaxen] ?= "BROKEN: depends on broken 'xom'"
14
13inherit java-library 15inherit java-library
14 16
15do_compile() { 17do_compile() {
diff --git a/recipes-core/xml-commons/jaxme_0.5.2.bb b/recipes-core/xml-commons/jaxme_0.5.2.bb
index b4ec750..03f4f57 100644
--- a/recipes-core/xml-commons/jaxme_0.5.2.bb
+++ b/recipes-core/xml-commons/jaxme_0.5.2.bb
@@ -9,6 +9,20 @@ SRC_URI = "\
9 http://ftp.hosting-studio.de/pub/linux/apache/ant/source/apache-ant-1.7.1-src.tar.bz2;name=ant \ 9 http://ftp.hosting-studio.de/pub/linux/apache/ant/source/apache-ant-1.7.1-src.tar.bz2;name=ant \
10 " 10 "
11 11
12# do_compile:
13# 2. ERROR in src/jaxme/org/apache/ws/jaxme/generator/XJCTask.java (at line 30)
14# import org.apache.ws.jaxme.generator.sg.SGFactoryChain;
15# ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
16# The import org.apache.ws.jaxme.generator.sg.SGFactoryChain cannot be resolved
17# ----------
18# 3. ERROR in src/jaxme/org/apache/ws/jaxme/generator/XJCTask.java (at line 1055)
19# if (!SGFactoryChain.class.isAssignableFrom(c)) {
20# ^^^^^^^^^^^^^^
21# SGFactoryChain cannot be resolved to a type
22# ----------
23# ... and many more
24PNBLACKLIST[jaxme] ?= "BROKEN: do_compile fails"
25
12S = "${WORKDIR}/ws-${P}" 26S = "${WORKDIR}/ws-${P}"
13 27
14inherit java-library 28inherit java-library
diff --git a/recipes-core/xml-commons/jdom_1.1.bb b/recipes-core/xml-commons/jdom_1.1.bb
index cb53734..4867e82 100644
--- a/recipes-core/xml-commons/jdom_1.1.bb
+++ b/recipes-core/xml-commons/jdom_1.1.bb
@@ -9,6 +9,8 @@ SRC_URI = "\
9 http://www.jdom.org/dist/binary/archive/jdom-${PV}.tar.gz \ 9 http://www.jdom.org/dist/binary/archive/jdom-${PV}.tar.gz \
10 " 10 "
11 11
12PNBLACKLIST[jdom] ?= "BROKEN: indirectly depends on broken 'xom'"
13
12inherit java-library 14inherit java-library
13 15
14do_compile() { 16do_compile() {
diff --git a/recipes-core/xml-commons/xom_1.1.bb b/recipes-core/xml-commons/xom_1.1.bb
index 7405dab..c37965b 100644
--- a/recipes-core/xml-commons/xom_1.1.bb
+++ b/recipes-core/xml-commons/xom_1.1.bb
@@ -10,6 +10,17 @@ SRC_URI = "\
10 file://04_remove_sun_import.patch \ 10 file://04_remove_sun_import.patch \
11 " 11 "
12 12
13# DEBUG: Executing shell function do_compile
14# ----------
15# 1. ERROR in src/nu/xom/UnicodeUtil.java (at line 0)
16# /* Copyright 2005 Elliotte Rusty Harold
17# ^
18# Internal compiler error: java.lang.StackOverflowError at org.eclipse.jdt.internal.compiler.ast.Expression.checkNPE(Expression.java:511)
19# ----------
20# Exception in thread "main" java.lang.StackOverflowError
21# at org.eclipse.jdt.internal.compiler.ast.Expression.checkNPE(Expression.java:511)
22PNBLACKLIST[xom] ?= "BROKEN: do_compile fails with internal javac error"
23
13S = "${WORKDIR}/XOM" 24S = "${WORKDIR}/XOM"
14 25
15inherit java-library 26inherit java-library