diff options
author | Jens Rehsack <rehsack@gmail.com> | 2015-12-08 14:51:50 +0100 |
---|---|---|
committer | Maxin B. John <maxin.john@intel.com> | 2015-12-08 17:43:35 +0200 |
commit | 04d5d0bf414c05ca59618d77f17ff9898aa1c566 (patch) | |
tree | e4d640f95075d3291a7466a4b8af8f0421e9745b /recipes-core/xml-commons | |
parent | 0d7ba0ff39a332b0f93c4958370b2c7db9ea0e30 (diff) | |
download | meta-java-04d5d0bf414c05ca59618d77f17ff9898aa1c566.tar.gz |
meta-java: rely on well known bootstrap-path
Instead of potential circular depending virtual/javac-native (even this
recipe provides such a useable java-native), rely on well known path
via cacao-native to build up to icedtea7-native in reliable manner.
virtual/javac-native should be used by parts not belonging to the bootstrap
phase.
Signed-off-by: Jens Rehsack <sno@netbsd.org>
Signed-off-by: Maxin B. John <maxin.john@intel.com>
Diffstat (limited to 'recipes-core/xml-commons')
-rw-r--r-- | recipes-core/xml-commons/jaxp1.3_1.4.01.bb | 4 | ||||
-rw-r--r-- | recipes-core/xml-commons/xml-commons-resolver1.1_1.2.bb | 6 | ||||
-rw-r--r-- | recipes-core/xml-commons/xpp2_2.1.10.bb | 2 | ||||
-rw-r--r-- | recipes-core/xml-commons/xpp3_1.1.3.4.O.bb | 2 |
4 files changed, 4 insertions, 10 deletions
diff --git a/recipes-core/xml-commons/jaxp1.3_1.4.01.bb b/recipes-core/xml-commons/jaxp1.3_1.4.01.bb index a6eeb57..765b766 100644 --- a/recipes-core/xml-commons/jaxp1.3_1.4.01.bb +++ b/recipes-core/xml-commons/jaxp1.3_1.4.01.bb | |||
@@ -11,9 +11,7 @@ LIC_FILES_CHKSUM = " \ | |||
11 | 11 | ||
12 | SRC_URI = "http://archive.apache.org/dist/xml/commons/source/xml-commons-external-${PV}-src.tar.gz;subdir=${BPN}-${PV}" | 12 | SRC_URI = "http://archive.apache.org/dist/xml/commons/source/xml-commons-external-${PV}-src.tar.gz;subdir=${BPN}-${PV}" |
13 | 13 | ||
14 | inherit java-library | 14 | inherit java-library java-bootstrap-components |
15 | |||
16 | DEPENDS = "fastjar-native" | ||
17 | 15 | ||
18 | JARFILENAME = "jaxp-1.3.jar" | 16 | JARFILENAME = "jaxp-1.3.jar" |
19 | ALTJARFILENAMES = "xml-apis.jar" | 17 | ALTJARFILENAMES = "xml-apis.jar" |
diff --git a/recipes-core/xml-commons/xml-commons-resolver1.1_1.2.bb b/recipes-core/xml-commons/xml-commons-resolver1.1_1.2.bb index 5853895..ca1f2f2 100644 --- a/recipes-core/xml-commons/xml-commons-resolver1.1_1.2.bb +++ b/recipes-core/xml-commons/xml-commons-resolver1.1_1.2.bb | |||
@@ -6,12 +6,12 @@ LIC_FILES_CHKSUM = "file://LICENSE.resolver.txt;md5=d229da563da18fe5d58cd95a6467 | |||
6 | 6 | ||
7 | SRC_URI = "http://archive.apache.org/dist/xml/commons/xml-commons-resolver-${PV}.tar.gz" | 7 | SRC_URI = "http://archive.apache.org/dist/xml/commons/xml-commons-resolver-${PV}.tar.gz" |
8 | 8 | ||
9 | inherit java-library | 9 | inherit java-library java-bootstrap-components |
10 | 10 | ||
11 | S = "${WORKDIR}/xml-commons-resolver-${PV}" | 11 | S = "${WORKDIR}/xml-commons-resolver-${PV}" |
12 | 12 | ||
13 | DEPENDS = "fastjar-native jaxp1.3" | 13 | DEPENDS = "jaxp1.3" |
14 | DEPENDS_virtclass-native = "fastjar-native jaxp1.3-native" | 14 | DEPENDS_virtclass-native = "jaxp1.3-native" |
15 | 15 | ||
16 | do_unpackpost() { | 16 | do_unpackpost() { |
17 | find src -exec \ | 17 | find src -exec \ |
diff --git a/recipes-core/xml-commons/xpp2_2.1.10.bb b/recipes-core/xml-commons/xpp2_2.1.10.bb index d3baca4..402d38d 100644 --- a/recipes-core/xml-commons/xpp2_2.1.10.bb +++ b/recipes-core/xml-commons/xpp2_2.1.10.bb | |||
@@ -9,8 +9,6 @@ S = "${WORKDIR}/PullParser${PV}" | |||
9 | 9 | ||
10 | inherit java-library | 10 | inherit java-library |
11 | 11 | ||
12 | DEPENDS = "fastjar-native virtual/javac-native" | ||
13 | |||
14 | do_compile() { | 12 | do_compile() { |
15 | if [ -d build-oe ]; then | 13 | if [ -d build-oe ]; then |
16 | rm -rf build-oe | 14 | rm -rf build-oe |
diff --git a/recipes-core/xml-commons/xpp3_1.1.3.4.O.bb b/recipes-core/xml-commons/xpp3_1.1.3.4.O.bb index bedb8a9..a472a0d 100644 --- a/recipes-core/xml-commons/xpp3_1.1.3.4.O.bb +++ b/recipes-core/xml-commons/xpp3_1.1.3.4.O.bb | |||
@@ -8,8 +8,6 @@ SRC_URI = "http://www.extreme.indiana.edu/dist/java-repository/xpp3/distribution | |||
8 | 8 | ||
9 | inherit java-library | 9 | inherit java-library |
10 | 10 | ||
11 | DEPENDS = "fastjar-native virtual/javac-native" | ||
12 | |||
13 | PACKAGES = "libxpp3-xpath-java ${JPN}" | 11 | PACKAGES = "libxpp3-xpath-java ${JPN}" |
14 | 12 | ||
15 | do_compile() { | 13 | do_compile() { |