summaryrefslogtreecommitdiffstats
path: root/recipes-core/xml-commons/jdom_1.1.bb
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2017-05-21 16:25:55 -0700
committerMaxin B. John <maxin.john@intel.com>2017-05-29 13:47:53 +0300
commit4874b7dc73ae9eb922b9bd37d1bbc11ec0125573 (patch)
treecce10c022954b9a8834d64ab77e504bab4765c87 /recipes-core/xml-commons/jdom_1.1.bb
parentd4f8a8aa9eedae4d587e8982fb58cf977be54ec8 (diff)
downloadmeta-java-4874b7dc73ae9eb922b9bd37d1bbc11ec0125573.tar.gz
jdom: unblacklist and update to v1.1.3
- Add SUMMARY and expand DESCRIPTION - Add LIC_FILES_CHECKSUM - Move SRC_URI checksums to recommended location in recipe - Add virtual/javac-native to DEPENDS for RSS Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com> Signed-off-by: Maxin B. John <maxin.john@intel.com>
Diffstat (limited to 'recipes-core/xml-commons/jdom_1.1.bb')
-rw-r--r--recipes-core/xml-commons/jdom_1.1.bb28
1 files changed, 0 insertions, 28 deletions
diff --git a/recipes-core/xml-commons/jdom_1.1.bb b/recipes-core/xml-commons/jdom_1.1.bb
deleted file mode 100644
index 4867e82..0000000
--- a/recipes-core/xml-commons/jdom_1.1.bb
+++ /dev/null
@@ -1,28 +0,0 @@
1DESCRIPTION = "Parses, manipulates, and outputs XML using standard Java constructs"
2LICENSE = "BSD"
3
4HOMEPAGE = "http://jdom.org/"
5
6DEPENDS = "fastjar-native jaxen"
7
8SRC_URI = "\
9 http://www.jdom.org/dist/binary/archive/jdom-${PV}.tar.gz \
10 "
11
12PNBLACKLIST[jdom] ?= "BROKEN: indirectly depends on broken 'xom'"
13
14inherit java-library
15
16do_compile() {
17 mkdir -p build
18
19 oe_makeclasspath cp -s jaxen
20
21 javac -sourcepath src/java -cp $cp -d build `find src/java -name "*.java"`
22
23 fastjar -C build -c -f ${JARFILENAME} .
24}
25
26
27SRC_URI[md5sum] = "22745cbaaddb12884ed8ee09083d8fe2"
28SRC_URI[sha256sum] = "a13549087141be24ad176b659afdc2c675f1ffa5288ff999a193d6d44a282056"