summaryrefslogtreecommitdiffstats
path: root/recipes-core/xerces-j
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2013-05-24 13:50:19 -0700
committerHenning Heinold <heinold@inf.fu-berlin.de>2013-09-29 21:51:20 +0200
commite867b1328c967ffd91b99d08ccbb9ab034d12407 (patch)
treed87aa3b1fa7d48b69bd21bb857b19a849c95d25b /recipes-core/xerces-j
parent311b292972533ab5be8f21dcd527db44afa4954a (diff)
downloadmeta-java-e867b1328c967ffd91b99d08ccbb9ab034d12407.tar.gz
xerces-j: Specify cp instead of bootclasspath
This makes other javac implementations happy Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes-core/xerces-j')
-rw-r--r--recipes-core/xerces-j/xerces-j_2.11.0.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/recipes-core/xerces-j/xerces-j_2.11.0.bb b/recipes-core/xerces-j/xerces-j_2.11.0.bb
index be6d765..f9e497e 100644
--- a/recipes-core/xerces-j/xerces-j_2.11.0.bb
+++ b/recipes-core/xerces-j/xerces-j_2.11.0.bb
@@ -45,11 +45,11 @@ do_compile() {
45 oe_makeclasspath bcp -s jaxp-1.3 resolver 45 oe_makeclasspath bcp -s jaxp-1.3 resolver
46 bcp=$bcp:${STAGING_DATADIR_NATIVE}/classpath/glibj.zip 46 bcp=$bcp:${STAGING_DATADIR_NATIVE}/classpath/glibj.zip
47 47
48 javac -sourcepath src -d build -bootclasspath $bcp `find src -name "*.java"` 48 javac -sourcepath src -d build -cp $bcp `find src -name "*.java"`
49 49
50 (cd src && find org ! -name "*.java" -exec cp {} ../build/{} \;) 50 (cd src && find org ! -name "*.java" -exec cp {} ../build/{} \;)
51 51
52 fastjar -C build -c -m src/manifest.xerces -f ${JARFILENAME} . 52 fastjar cfm ${JARFILENAME} src/manifest.xerces -C build .
53 53
54 # Like Debian we provide a symlink called xmlParserAPIs.jar pointing to the JAXP 54 # Like Debian we provide a symlink called xmlParserAPIs.jar pointing to the JAXP
55 # classes. 55 # classes.