summaryrefslogtreecommitdiffstats
path: root/recipes-core/xerces-j
diff options
context:
space:
mode:
authorHenning Heinold <heinold@inf.fu-berlin.de>2011-11-12 20:58:34 +0100
committerHenning Heinold <heinold@inf.fu-berlin.de>2011-11-26 23:41:44 +0100
commit57e069cde6617f00ca8834a82c6f360af43d5067 (patch)
tree48cbe15e96d217c45acfa64b0c13aad8c6424980 /recipes-core/xerces-j
downloadmeta-java-57e069cde6617f00ca8834a82c6f360af43d5067.tar.gz
meta-java: initial commit
* taken over mostly stuff from oe classic * cleaned up recipes * added license checksums * bump icedtea6-native to 1.8.11 * use jamvm from git as native
Diffstat (limited to 'recipes-core/xerces-j')
-rw-r--r--recipes-core/xerces-j/xerces-j_2.9.1.bb61
1 files changed, 61 insertions, 0 deletions
diff --git a/recipes-core/xerces-j/xerces-j_2.9.1.bb b/recipes-core/xerces-j/xerces-j_2.9.1.bb
new file mode 100644
index 0000000..79aef01
--- /dev/null
+++ b/recipes-core/xerces-j/xerces-j_2.9.1.bb
@@ -0,0 +1,61 @@
1DESCRIPTION = "Reference implementation of XNI, the Xerces Native Interface, and also a fully conforming XML Schema processor."
2AUTHOR = "Apache Software Foundation"
3LICENSE = "AL2.0"
4LIC_FILES_CHKSUM = " \
5 file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
6 file://LICENSE.DOM-documentation.html;md5=b05e182e1962778d7b207cbf3fe4acef \
7 file://LICENSE.DOM-software.html;md5=3aec153ae803c31acdae63bac18506b9 \
8 file://LICENSE.resolver.txt;md5=86d3f3a95c324c9479bd8986968f4327 \
9 file://LICENSE.serializer.txt;md5=86d3f3a95c324c9479bd8986968f4327 \
10 "
11
12SRC_URI = "http://www.apache.org/dist/xerces/j/Xerces-J-src.${PV}.tar.gz"
13
14S = "${WORKDIR}/xerces-2_9_1"
15
16inherit java-library
17
18JPN = "libxerces2-java"
19
20DEPENDS = "fastjar-native jaxp1.3 xml-commons-resolver1.1"
21DEPENDS_virtclass-native = "fastjar-native jaxp1.3-native xml-commons-resolver1.1-native"
22
23RDEPENDS_${PN} = "libjaxp1.3-java libxml-commons-resolver1.1-java"
24RDEPENDS_${PN}_virtclass-native = ""
25
26do_unpackpost() {
27 find src -exec \
28 sed -i -e "s|@impl.name@|Xerces-J ${PV}|" \
29 -e "s|@impl.version@|${PV}|" {} \;
30}
31
32addtask unpackpost after do_unpack before do_patch
33
34JARFILENAME = "xercesImpl.jar"
35ALTJARFILENAMES = ""
36
37do_compile() {
38 mkdir -p build
39
40 # Prepend the bootclasspath with the earlier XML API to make
41 # compilation succeed.
42 oe_makeclasspath bcp -s jaxp-1.3 resolver
43 bcp=$bcp:${STAGING_DATADIR_NATIVE}/classpath/glibj.zip
44
45 javac -sourcepath src -d build -bootclasspath $bcp `find src -name "*.java"`
46
47 (cd src && find org ! -name "*.java" -exec cp {} ../build/{} \;)
48
49 fastjar -C build -c -m src/manifest.xerces -f ${JARFILENAME} .
50
51 # Like Debian we provide a symlink called xmlParserAPIs.jar pointing to the JAXP
52 # classes.
53 ln -sf ${D}${datadir_java}/xmlParserAPIs.jar jaxp-1.3.jar
54
55}
56
57SRC_URI[md5sum] = "e340cba4a2abf4f0f833488380821153"
58SRC_URI[sha256sum] = "13af0062a72a4a0d541ca5336391eafa4d580258cacf4a5e062ea584ca950592"
59
60NATIVE_INSTALL_WORKS = "1"
61BBCLASSEXTEND = "native"