summaryrefslogtreecommitdiffstats
path: root/recipes-core/xerces-j/xerces-j_2.11.0.bb
diff options
context:
space:
mode:
authorHenning Heinold <heinold@inf.fu-berlin.de>2012-07-18 23:02:58 +0200
committerHenning Heinold <heinold@inf.fu-berlin.de>2012-07-19 17:37:00 +0200
commit869530e4af0a419973ee3bdbb6129b6d0126b07f (patch)
tree29d3e0c2b12885a1276db44d4bc4d4df04918bcb /recipes-core/xerces-j/xerces-j_2.11.0.bb
parentfdb5641b45dde93f1e0f843fe6d93b3e356fb4f5 (diff)
downloadmeta-java-869530e4af0a419973ee3bdbb6129b6d0126b07f.tar.gz
xerces-j: update to version 2.11.0
Diffstat (limited to 'recipes-core/xerces-j/xerces-j_2.11.0.bb')
-rw-r--r--recipes-core/xerces-j/xerces-j_2.11.0.bb60
1 files changed, 60 insertions, 0 deletions
diff --git a/recipes-core/xerces-j/xerces-j_2.11.0.bb b/recipes-core/xerces-j/xerces-j_2.11.0.bb
new file mode 100644
index 0000000..ac63645
--- /dev/null
+++ b/recipes-core/xerces-j/xerces-j_2.11.0.bb
@@ -0,0 +1,60 @@
1DESCRIPTION = "Reference implementation of XNI, the Xerces Native Interface, and also a fully conforming XML Schema processor."
2AUTHOR = "Apache Software Foundation"
3LICENSE = "AL2.0"
4LIC_FILES_CHKSUM = " \
5 file://LICENSE;md5=d273d63619c9aeaf15cdaf76422c4f87 \
6 file://LICENSE.DOM-documentation.html;md5=77c27084ca92e9a8efe9314f284acc05 \
7 file://LICENSE.DOM-software.html;md5=1f920675d8473fd5cbabf133a7e39e0d \
8 file://LICENSE.resolver.txt;md5=d229da563da18fe5d58cd95a6467d584 \
9 file://LICENSE.serializer.txt;md5=d229da563da18fe5d58cd95a6467d584 \
10 "
11
12SRC_URI = "http://archive.apache.org/dist/xerces/j/Xerces-J-src.${PV}.tar.gz"
13
14S = "${WORKDIR}/xerces-2_11_0"
15
16inherit java-library
17
18JPN = "libxerces2-java"
19
20DEPENDS = "fastjar-native jaxp1.3 xml-commons-resolver1.1"
21DEPENDS_virtclass-native = "fastjar-native jaxp1.3-native xml-commons-resolver1.1-native"
22
23RDEPENDS_${PN} = "libjaxp1.3-java libxml-commons-resolver1.1-java"
24RDEPENDS_${PN}_virtclass-native = ""
25
26do_unpackpost() {
27 find src -exec \
28 sed -i -e "s|@impl.name@|Xerces-J ${PV}|" \
29 -e "s|@impl.version@|${PV}|" {} \;
30}
31
32addtask unpackpost after do_unpack before do_patch
33
34JARFILENAME = "xercesImpl.jar"
35ALTJARFILENAMES = ""
36
37do_compile() {
38 mkdir -p build
39
40 # Prepend the bootclasspath with the earlier XML API to make
41 # compilation succeed.
42 oe_makeclasspath bcp -s jaxp-1.3 resolver
43 bcp=$bcp:${STAGING_DATADIR_NATIVE}/classpath/glibj.zip
44
45 javac -sourcepath src -d build -bootclasspath $bcp `find src -name "*.java"`
46
47 (cd src && find org ! -name "*.java" -exec cp {} ../build/{} \;)
48
49 fastjar -C build -c -m src/manifest.xerces -f ${JARFILENAME} .
50
51 # Like Debian we provide a symlink called xmlParserAPIs.jar pointing to the JAXP
52 # classes.
53 ln -sf ${D}${datadir_java}/xmlParserAPIs.jar jaxp-1.3.jar
54
55}
56
57SRC_URI[md5sum] = "d01fc11eacbe43b45681cb85ac112ebf"
58SRC_URI[sha256sum] = "f59a5ef7b51bd883f2e9bda37a9360692e6c5e439b98d9b6ac1953e1f98b0680"
59
60BBCLASSEXTEND = "native"