summaryrefslogtreecommitdiffstats
path: root/recipes-core/rhino
diff options
context:
space:
mode:
authorHenning Heinold <heinold@inf.fu-berlin.de>2011-11-12 20:58:34 +0100
committerHenning Heinold <heinold@inf.fu-berlin.de>2011-11-26 23:41:44 +0100
commit57e069cde6617f00ca8834a82c6f360af43d5067 (patch)
tree48cbe15e96d217c45acfa64b0c13aad8c6424980 /recipes-core/rhino
downloadmeta-java-57e069cde6617f00ca8834a82c6f360af43d5067.tar.gz
meta-java: initial commit
* taken over mostly stuff from oe classic * cleaned up recipes * added license checksums * bump icedtea6-native to 1.8.11 * use jamvm from git as native
Diffstat (limited to 'recipes-core/rhino')
-rw-r--r--recipes-core/rhino/rhino/rhino8
-rw-r--r--recipes-core/rhino/rhino/rhino-jsc8
-rw-r--r--recipes-core/rhino/rhino_1.7r2.bb46
3 files changed, 62 insertions, 0 deletions
diff --git a/recipes-core/rhino/rhino/rhino b/recipes-core/rhino/rhino/rhino
new file mode 100644
index 0000000..e2f87f6
--- /dev/null
+++ b/recipes-core/rhino/rhino/rhino
@@ -0,0 +1,8 @@
1#!/bin/sh
2
3if [ ! $JAVA ]; then
4 JAVA=java
5fi
6
7$JAVA -jar /usr/share/java/js.jar $@
8
diff --git a/recipes-core/rhino/rhino/rhino-jsc b/recipes-core/rhino/rhino/rhino-jsc
new file mode 100644
index 0000000..d5f50e8
--- /dev/null
+++ b/recipes-core/rhino/rhino/rhino-jsc
@@ -0,0 +1,8 @@
1#!/bin/sh
2
3if [ ! $JAVA ]; then
4 JAVA=java
5fi
6
7$JAVA -cp .:/usr/share/java/js.jar org.mozilla.javascript.tools.jsc.Main $@
8
diff --git a/recipes-core/rhino/rhino_1.7r2.bb b/recipes-core/rhino/rhino_1.7r2.bb
new file mode 100644
index 0000000..3a3f553
--- /dev/null
+++ b/recipes-core/rhino/rhino_1.7r2.bb
@@ -0,0 +1,46 @@
1DESCRIPTION = "Lexical analyzer generator for Java"
2LICENSE = "GPL MPL"
3LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=b8ba559ba419681dbf8280b6721df0af"
4
5BBCLASSEXTEND = "native"
6
7inherit java-library
8
9SRC_URI = "\
10 ftp://ftp.mozilla.org/pub/mozilla.org/js/rhino1_7R2.zip \
11 file://rhino \
12 file://rhino-jsc \
13 "
14
15S = "${WORKDIR}/rhino1_7R2"
16
17PACKAGES = "${JPN} rhino"
18
19FILES_${PN} = "${bindir}/rhino ${bindir}/rhino-jsc"
20RDEPENDS_${PN} = "java2-runtime ${JPN}"
21RDEPENDS_${PN}_virtclass-native = ""
22
23do_compile() {
24 mkdir -p build
25
26 # Compatibility fix for jamvm which has non-genericised
27 # java.lang classes. :(
28 bcp_arg="-bootclasspath ${STAGING_DATADIR_NATIVE}/classpath/glibj.zip"
29
30 javac $bcp_arg -source 1.5 -sourcepath src -d build `find src -name "*.java"`
31
32 mkdir -p build/org/mozilla/javascript/resources
33 cp src/org/mozilla/javascript/resources/*.properties build/org/mozilla/javascript/resources
34
35 fastjar -m ${S}/src/manifest -C build -c -f ${JARFILENAME} .
36}
37
38do_install_append() {
39 install -d ${D}${bindir}
40
41 install -m 0755 ${WORKDIR}/rhino ${D}${bindir}
42 install -m 0755 ${WORKDIR}/rhino-jsc ${D}${bindir}
43}
44
45SRC_URI[md5sum] = "40d0a9abec8169e42920214b37fa8e0e"
46SRC_URI[sha256sum] = "677f7dc1b67a1587bc03974d5f0720474a56b8f29835e1d860739908df8462dc"