summaryrefslogtreecommitdiffstats
path: root/recipes-core/rhino
diff options
context:
space:
mode:
authorHenning Heinold <heinold@inf.fu-berlin.de>2012-12-08 01:31:37 +0100
committerHenning Heinold <heinold@inf.fu-berlin.de>2012-12-08 01:31:37 +0100
commit2eb6d2643e3833657cfd278b0502945df99ee18a (patch)
tree7fbc758b3a621eef8db9cbec535f715c2834067b /recipes-core/rhino
parent29648bea7c2a40e1f94f0a428ab6f210c41680db (diff)
downloadmeta-java-2eb6d2643e3833657cfd278b0502945df99ee18a.tar.gz
rhino: update to version 1.7r4
* license is now MPL 2.0
Diffstat (limited to 'recipes-core/rhino')
-rw-r--r--recipes-core/rhino/rhino_1.7r4.bb (renamed from recipes-core/rhino/rhino_1.7r2.bb)20
1 files changed, 10 insertions, 10 deletions
diff --git a/recipes-core/rhino/rhino_1.7r2.bb b/recipes-core/rhino/rhino_1.7r4.bb
index fccdfe8..76a3b5f 100644
--- a/recipes-core/rhino/rhino_1.7r2.bb
+++ b/recipes-core/rhino/rhino_1.7r4.bb
@@ -1,18 +1,18 @@
1DESCRIPTION = "Lexical analyzer generator for Java" 1DESCRIPTION = "Lexical analyzer generator for Java"
2LICENSE = "GPL-2.0 MPL-1.1" 2LICENSE = "MPL-2.0"
3LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=b8ba559ba419681dbf8280b6721df0af" 3LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=8e2372bdbf22c99279ae4599a13cc458"
4 4
5BBCLASSEXTEND = "native" 5BBCLASSEXTEND = "native"
6 6
7inherit java-library 7inherit java-library
8 8
9SRC_URI = "\ 9SRC_URI = "\
10 ftp://ftp.mozilla.org/pub/mozilla.org/js/rhino1_7R2.zip \ 10 https://github.com/downloads/mozilla/rhino/rhino1_7R4.zip \
11 file://rhino \ 11 file://rhino \
12 file://rhino-jsc \ 12 file://rhino-jsc \
13 " 13 "
14 14
15S = "${WORKDIR}/rhino1_7R2" 15S = "${WORKDIR}/rhino1_7R4"
16 16
17PACKAGES = "${JPN} rhino" 17PACKAGES = "${JPN} rhino"
18 18
@@ -21,18 +21,18 @@ RDEPENDS_${PN} = "java2-runtime ${JPN}"
21RDEPENDS_${PN}_virtclass-native = "" 21RDEPENDS_${PN}_virtclass-native = ""
22 22
23do_compile() { 23do_compile() {
24 mkdir -p build 24 mkdir -p build
25 25
26 # Compatibility fix for jamvm which has non-genericised 26 # Compatibility fix for jamvm which has non-genericised
27 # java.lang classes. :( 27 # java.lang classes. :(
28 bcp_arg="-bootclasspath ${STAGING_DATADIR_NATIVE}/classpath/glibj.zip" 28 bcp_arg="-bootclasspath ${STAGING_DATADIR_NATIVE}/classpath/glibj.zip"
29 29
30 javac $bcp_arg -source 1.5 -sourcepath src -d build `find src -name "*.java"` 30 javac $bcp_arg -source 1.6 -sourcepath src -d build `find src -name "*.java"`
31 31
32 mkdir -p build/org/mozilla/javascript/resources 32 mkdir -p build/org/mozilla/javascript/resources
33 cp src/org/mozilla/javascript/resources/*.properties build/org/mozilla/javascript/resources 33 cp src/org/mozilla/javascript/resources/*.properties build/org/mozilla/javascript/resources
34 34
35 fastjar -m ${S}/src/manifest -C build -c -f ${JARFILENAME} . 35 fastjar -m ${S}/src/manifest -C build -c -f ${JARFILENAME} .
36} 36}
37 37
38do_install_append() { 38do_install_append() {
@@ -42,5 +42,5 @@ do_install_append() {
42 install -m 0755 ${WORKDIR}/rhino-jsc ${D}${bindir} 42 install -m 0755 ${WORKDIR}/rhino-jsc ${D}${bindir}
43} 43}
44 44
45SRC_URI[md5sum] = "40d0a9abec8169e42920214b37fa8e0e" 45SRC_URI[md5sum] = "ad67a3dff135e3a70f0c3528a2d6edf2"
46SRC_URI[sha256sum] = "677f7dc1b67a1587bc03974d5f0720474a56b8f29835e1d860739908df8462dc" 46SRC_URI[sha256sum] = "9eb08f85bbe7c8e0b9eaffb1cf4984b31fb679f3c8a682acc3bb8ac20626c61e"