summaryrefslogtreecommitdiffstats
path: root/recipes-core/rhino/rhino_1.7r4.bb
diff options
context:
space:
mode:
authorHenning Heinold <heinold@inf.fu-berlin.de>2012-12-08 01:31:37 +0100
committerHenning Heinold <heinold@inf.fu-berlin.de>2012-12-08 01:31:37 +0100
commit2eb6d2643e3833657cfd278b0502945df99ee18a (patch)
tree7fbc758b3a621eef8db9cbec535f715c2834067b /recipes-core/rhino/rhino_1.7r4.bb
parent29648bea7c2a40e1f94f0a428ab6f210c41680db (diff)
downloadmeta-java-2eb6d2643e3833657cfd278b0502945df99ee18a.tar.gz
rhino: update to version 1.7r4
* license is now MPL 2.0
Diffstat (limited to 'recipes-core/rhino/rhino_1.7r4.bb')
-rw-r--r--recipes-core/rhino/rhino_1.7r4.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/recipes-core/rhino/rhino_1.7r4.bb b/recipes-core/rhino/rhino_1.7r4.bb
new file mode 100644
index 0000000..76a3b5f
--- /dev/null
+++ b/recipes-core/rhino/rhino_1.7r4.bb
@@ -0,0 +1,46 @@
1DESCRIPTION = "Lexical analyzer generator for Java"
2LICENSE = "MPL-2.0"
3LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=8e2372bdbf22c99279ae4599a13cc458"
4
5BBCLASSEXTEND = "native"
6
7inherit java-library
8
9SRC_URI = "\
10 https://github.com/downloads/mozilla/rhino/rhino1_7R4.zip \
11 file://rhino \
12 file://rhino-jsc \
13 "
14
15S = "${WORKDIR}/rhino1_7R4"
16
17PACKAGES = "${JPN} rhino"
18
19FILES_${PN} = "${bindir}/rhino ${bindir}/rhino-jsc"
20RDEPENDS_${PN} = "java2-runtime ${JPN}"
21RDEPENDS_${PN}_virtclass-native = ""
22
23do_compile() {
24 mkdir -p build
25
26 # Compatibility fix for jamvm which has non-genericised
27 # java.lang classes. :(
28 bcp_arg="-bootclasspath ${STAGING_DATADIR_NATIVE}/classpath/glibj.zip"
29
30 javac $bcp_arg -source 1.6 -sourcepath src -d build `find src -name "*.java"`
31
32 mkdir -p build/org/mozilla/javascript/resources
33 cp src/org/mozilla/javascript/resources/*.properties build/org/mozilla/javascript/resources
34
35 fastjar -m ${S}/src/manifest -C build -c -f ${JARFILENAME} .
36}
37
38do_install_append() {
39 install -d ${D}${bindir}
40
41 install -m 0755 ${WORKDIR}/rhino ${D}${bindir}
42 install -m 0755 ${WORKDIR}/rhino-jsc ${D}${bindir}
43}
44
45SRC_URI[md5sum] = "ad67a3dff135e3a70f0c3528a2d6edf2"
46SRC_URI[sha256sum] = "9eb08f85bbe7c8e0b9eaffb1cf4984b31fb679f3c8a682acc3bb8ac20626c61e"