summaryrefslogtreecommitdiffstats
path: root/recipes-core/openjdk
diff options
context:
space:
mode:
authorJens Rehsack <rehsack@gmail.com>2015-10-28 18:58:24 +0100
committerOtavio Salvador <otavio@ossystems.com.br>2015-10-29 09:02:28 -0200
commita88718b6a6ec2a9429cbfd364d590ae69eb661e4 (patch)
tree7b55fc01182e0c5802f35d0414053503b27c6dce /recipes-core/openjdk
parentdf20f2d68ba63e0acfb54c1947bd24a01a74f444 (diff)
downloadmeta-java-a88718b6a6ec2a9429cbfd364d590ae69eb661e4.tar.gz
Avoid parse time errors due to dependency on x11, for distros without x11
BitBake raises some errors when processing recipes that depend on x11 for distros that don't have x11 in DISTRO_FEATURES. To work around that issue, REQUIRED_DISTRO_FEATURES = "x11" (from distro_features_check.bbclass) has been set for the following recipes: * cacao (_class-target) * classpath (_class-target) * jamvm (_class-target) * openjdk-7-release That makes BitBake skip those recipes during the cache generation (they'd still be parsed, but ignored). This patch improves the idea from Mario Domenech Goulart <mario@ossystems.com.br> Signed-off-by: Jens Rehsack <sno@netbsd.org> Acked-by: Richard Leitner <richard.leitner@skidata.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-core/openjdk')
-rw-r--r--recipes-core/openjdk/openjdk-7_91b01-2.6.2.bb4
-rw-r--r--recipes-core/openjdk/openjdk-common.inc4
2 files changed, 5 insertions, 3 deletions
diff --git a/recipes-core/openjdk/openjdk-7_91b01-2.6.2.bb b/recipes-core/openjdk/openjdk-7_91b01-2.6.2.bb
index 2cc79d1..df91e4d 100644
--- a/recipes-core/openjdk/openjdk-7_91b01-2.6.2.bb
+++ b/recipes-core/openjdk/openjdk-7_91b01-2.6.2.bb
@@ -1,5 +1,9 @@
1require openjdk-7-release-91b01.inc 1require openjdk-7-release-91b01.inc
2 2
3inherit distro_features_check
4
5REQUIRED_DISTRO_FEATURES = "x11"
6
3PR = "${INC_PR}.1" 7PR = "${INC_PR}.1"
4 8
5SRC_URI[iced.md5sum] = "a16b3e800030db9d9b35f80dfd11883a" 9SRC_URI[iced.md5sum] = "a16b3e800030db9d9b35f80dfd11883a"
diff --git a/recipes-core/openjdk/openjdk-common.inc b/recipes-core/openjdk/openjdk-common.inc
index e3e597a..dc26522 100644
--- a/recipes-core/openjdk/openjdk-common.inc
+++ b/recipes-core/openjdk/openjdk-common.inc
@@ -17,9 +17,7 @@ DEPENDS_append_libc-uclibc = " virtual/libiconv "
17# because structure sizes and/or alignment may differ. 17# because structure sizes and/or alignment may differ.
18DEPENDS_append = " qemu-native " 18DEPENDS_append = " qemu-native "
19 19
20inherit java autotools gettext qemu pkgconfig distro_features_check 20inherit java autotools gettext qemu pkgconfig
21
22REQUIRED_DISTRO_FEATURES = "x11"
23 21
24# OpenJDK uses slightly different names for certain arches. We need to know 22# OpenJDK uses slightly different names for certain arches. We need to know
25# this to create some files which are expected by the build. 23# this to create some files which are expected by the build.