summaryrefslogtreecommitdiffstats
path: root/recipes-core/openjdk/openjdk-7_99b00-2.6.5.bb
diff options
context:
space:
mode:
authorRichard Leitner <richard.leitner@skidata.com>2017-04-26 15:39:12 +0200
committerMaxin B. John <maxin.john@intel.com>2017-05-29 13:52:41 +0300
commit65041a6c16a11ca187734323177591e8fd09f2af (patch)
tree6c8f9384b7c37b81726bde91d3046160f9db2d57 /recipes-core/openjdk/openjdk-7_99b00-2.6.5.bb
parent638680e2616a030e92d9577d89c2b5c907d479f2 (diff)
downloadmeta-java-65041a6c16a11ca187734323177591e8fd09f2af.tar.gz
openjdk-7: fix compile errors with current poky master (gcc6)
Using the current poky master openjdk-7 wasn't buildable. This patch fixes those problems by adding three more patches to openjdk-7. These patches basically add/fix GCC6 support. Furthermore the LDFLAGS_HASH_STYLE variable (which was removed by the icedtea-crosscompile-fix.patch) is re-introduced and set to "both" for compatibility reasons. Following two patches were originally written by Abdur Rehman and taken from meta-mentor [1]: icedtea-flags-to-compile-with-GCC-6.patch icedtea-specify-overloaded-variant-of-fmod.patch [1] https://github.com/MentorEmbedded/meta-mentor Signed-off-by: Richard Leitner <richard.leitner@skidata.com> Signed-off-by: Maxin B. John <maxin.john@intel.com>
Diffstat (limited to 'recipes-core/openjdk/openjdk-7_99b00-2.6.5.bb')
-rw-r--r--recipes-core/openjdk/openjdk-7_99b00-2.6.5.bb12
1 files changed, 11 insertions, 1 deletions
diff --git a/recipes-core/openjdk/openjdk-7_99b00-2.6.5.bb b/recipes-core/openjdk/openjdk-7_99b00-2.6.5.bb
index eba353e..aa165f5 100644
--- a/recipes-core/openjdk/openjdk-7_99b00-2.6.5.bb
+++ b/recipes-core/openjdk/openjdk-7_99b00-2.6.5.bb
@@ -51,6 +51,9 @@ ICEDTEAPATCHES = "\
51 file://icedtea-xawt-crosscompile-fix.patch;apply=no \ 51 file://icedtea-xawt-crosscompile-fix.patch;apply=no \
52 file://icedtea-jdk-unzip.patch;apply=no \ 52 file://icedtea-jdk-unzip.patch;apply=no \
53 file://icedtea-dtrace-std_h.patch;apply=no \ 53 file://icedtea-dtrace-std_h.patch;apply=no \
54 file://icedtea-hotspot-fix-string-literal-marcos.patch;apply=no \
55 file://icedtea-flags-to-compile-with-GCC-6.patch;apply=no \
56 file://icedtea-specify-overloaded-variant-of-fmod.patch;apply=no \
54" 57"
55 58
56DISTRIBUTION_PATCHES = "\ 59DISTRIBUTION_PATCHES = "\
@@ -61,10 +64,17 @@ DISTRIBUTION_PATCHES = "\
61 patches/icedtea-xawt-crosscompile-fix.patch \ 64 patches/icedtea-xawt-crosscompile-fix.patch \
62 patches/icedtea-jdk-unzip.patch \ 65 patches/icedtea-jdk-unzip.patch \
63 patches/icedtea-dtrace-std_h.patch \ 66 patches/icedtea-dtrace-std_h.patch \
67 patches/icedtea-hotspot-fix-string-literal-marcos.patch \
68 patches/icedtea-flags-to-compile-with-GCC-6.patch \
69 patches/icedtea-specify-overloaded-variant-of-fmod.patch \
64" 70"
65 71
66export DISTRIBUTION_PATCHES 72export DISTRIBUTION_PATCHES
67 73
68# readdir_r was deprecated in glibc-2.24. Ignore the error for now 74# readdir_r was deprecated in glibc-2.24. Ignore the error for now
75#
76# Furthermore shifting negative values produces an error in current gcc versions
77# to avoid this error add -fpermissive
78#
69# NOTE: When updating the recipe, please check if this is still needed 79# NOTE: When updating the recipe, please check if this is still needed
70CFLAGS_append = " -Wno-error=deprecated-declarations" 80CFLAGS_append = " -Wno-error=deprecated-declarations -Wno-error=narrowing -fpermissive"