summaryrefslogtreecommitdiffstats
path: root/recipes-core/openjdk/openjdk-7_99b00-2.6.5.bb
diff options
context:
space:
mode:
authorRichard Leitner <richard.leitner@skidata.com>2016-08-16 16:51:28 +0200
committerMaxin B. John <maxin.john@intel.com>2016-08-30 16:48:45 +0300
commit7d9264ca45076b0a0e52e9072989003c0687bda4 (patch)
treeb1ac701d92e2e909bbb7cbf8134df23da8aff4fc /recipes-core/openjdk/openjdk-7_99b00-2.6.5.bb
parent216481ba09c187d0b0fc8f864944af6ae026ff73 (diff)
downloadmeta-java-7d9264ca45076b0a0e52e9072989003c0687bda4.tar.gz
openjdk-7: update to IcedTea 2.6.5 OpenJDK 7u99b00
OpenJDK 7 is updated from from 91b01 (IcedTea 2.6.2) to 99b00 (IcedTea 2.6.5). This update introduces following security updates: * Mar 2016 (IcedTea 2.6.5, OpenJDK 7 u99) [1] * Jan 2016 (IcedTea 2.6.4, OpenJDK 7 u95) [2] * Oct 2015 (IcedTea 2.6.3, OpenJDK 7 u91) [3] Due to the fact some "byte behavior improvements" were not ported to the ARM32-JIT in IcedTea 2.6.6 yet [6], [7] we need to stick IcedTea 2.6.5 for now. [1]http://blog.fuseyism.com/index.php/2016/03/25/security-icedtea-2-6-5-for-openjdk-7-released/ [2]http://blog.fuseyism.com/index.php/2016/01/21/security-icedtea-2-6-4-for-openjdk-7-released/ [3]http://blog.fuseyism.com/index.php/2015/11/17/security-icedtea-2-6-3-for-openjdk-7-released/ [6]http://icedtea.classpath.org/bugzilla/show_bug.cgi?id=2942 [7]http://icedtea.classpath.org/hg/release/icedtea7-forest-2.6/hotspot/rev/1c5c4564204e Signed-off-by: Richard Leitner <richard.leitner@skidata.com> Signed-off-by: Maxin B. John <maxin.john@intel.com>
Diffstat (limited to 'recipes-core/openjdk/openjdk-7_99b00-2.6.5.bb')
-rw-r--r--recipes-core/openjdk/openjdk-7_99b00-2.6.5.bb66
1 files changed, 66 insertions, 0 deletions
diff --git a/recipes-core/openjdk/openjdk-7_99b00-2.6.5.bb b/recipes-core/openjdk/openjdk-7_99b00-2.6.5.bb
new file mode 100644
index 0000000..711f572
--- /dev/null
+++ b/recipes-core/openjdk/openjdk-7_99b00-2.6.5.bb
@@ -0,0 +1,66 @@
1require openjdk-7-common.inc
2
3LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
4
5FILESPATH =. "${FILE_DIRNAME}/patches-openjdk-7:"
6
7inherit distro_features_check
8
9REQUIRED_DISTRO_FEATURES = "x11"
10
11PR = "${INC_PR}.1"
12
13SRC_URI[iced.md5sum] = "cb66b595860c3d99a87c3a853667c145"
14SRC_URI[iced.sha256sum] = "d8bce93bd33b299a52236f03fb57d42ae9de808c8337e6185930799dbfc78795"
15
16SRC_URI[corba.md5sum] = "3345d1939663d1ef94459cf215b76b3f"
17SRC_URI[corba.sha256sum] = "427969fdd78513a11ddd9d5131a068e0b26ca2c8f14951bf8b161fecd07fe77f"
18
19SRC_URI[jaxp.md5sum] = "872a458cde954124eee9913e6ea906b0"
20SRC_URI[jaxp.sha256sum] = "7bb5e1bc9f0807061e157aeb356dd0e3b9fa019fb316beee3aa0181a335ba37a"
21
22SRC_URI[jaxws.md5sum] = "d0d559ca0d797c5dc9640bfa277a23c5"
23SRC_URI[jaxws.sha256sum] = "4e759ade7e47713f6f26afc1ffcd02f2edf967582fae2ec6b4d73dc81be926d0"
24
25SRC_URI[jdk.md5sum] = "13fa99cc310f27818867e8a9d0841892"
26SRC_URI[jdk.sha256sum] = "cd3810553b1066c21f2fe08a73de72e38ba7e72295cd32dec70db481a24421ba"
27
28SRC_URI[langtools.md5sum] = "2e951b311d0cfbd7ebc6e9fbb75de891"
29SRC_URI[langtools.sha256sum] = "6c6c676c60af61638a0c3176f0312fcc0abad16d1d3cdbe11aeefcc3357a78d9"
30
31SRC_URI[openjdk.md5sum] = "48d9f0e76f92d18aff1b9379b052b0cb"
32SRC_URI[openjdk.sha256sum] = "c66f56a91a6fa9e3c889bbbc5432a4e082b7d3735188fb508fa7ec70c142abdb"
33
34# hotspot changeset taken from hotspot/tags
35SRC_URI[hotspot.md5sum] = "7e1bdaf4385c3b7e77d3599c52151485"
36SRC_URI[hotspot.sha256sum] = "43983232fb10abeac99478e7045c04a93fef86185e2b9ee9c7b46f2903441cfc"
37
38###############################################################################
39# PATCHES - split up to allow overriding them separately
40OEPATCHES = "\
41 file://build-hacks.patch \
42 file://fix_hotspot_crosscompile.patch \
43 file://icedtea-makefile-unzip.patch \
44"
45
46ICEDTEAPATCHES = "\
47 file://icedtea-zero-hotspotfix.patch;apply=no \
48 file://icedtea-jdk-nio-use-host-cc.patch;apply=no \
49 file://icedtea-jdk-rmi-crosscompile.patch;apply=no \
50 file://icedtea-crosscompile-fix.patch;apply=no \
51 file://icedtea-xawt-crosscompile-fix.patch;apply=no \
52 file://icedtea-jdk-unzip.patch;apply=no \
53 file://icedtea-dtrace-std_h.patch;apply=no \
54"
55
56DISTRIBUTION_PATCHES = "\
57 patches/icedtea-zero-hotspotfix.patch \
58 patches/icedtea-jdk-nio-use-host-cc.patch \
59 patches/icedtea-jdk-rmi-crosscompile.patch \
60 patches/icedtea-crosscompile-fix.patch \
61 patches/icedtea-xawt-crosscompile-fix.patch \
62 patches/icedtea-jdk-unzip.patch \
63 patches/icedtea-dtrace-std_h.patch \
64"
65
66export DISTRIBUTION_PATCHES