summaryrefslogtreecommitdiffstats
path: root/recipes-core/llvm
diff options
context:
space:
mode:
authorJan Luebbe <jlu@pengutronix.de>2012-05-15 09:56:02 +0000
committerHenning Heinold <heinold@inf.fu-berlin.de>2012-05-25 22:15:56 +0200
commit3738fc4fc2b2bad549c9f7b15626572efc62ca8d (patch)
tree5b54eebb4ad704f02fdc3141622ff5f68f750586 /recipes-core/llvm
parent554f73275be2177e7dc8438fc36bb5c98becf979 (diff)
downloadmeta-java-3738fc4fc2b2bad549c9f7b15626572efc62ca8d.tar.gz
llvm2.8: fix llvm compile error by including unistd.h
Thanks to Jaap de Jong and Khem Raj for reporing the problem and suggesting the fix. Signed-off-by: Jan Luebbe <jlu@pengutronix.de> Signed-off-by: Henning Heinold <heinold@inf.fu-berlin.de>
Diffstat (limited to 'recipes-core/llvm')
-rw-r--r--recipes-core/llvm/llvm2.8/add-unistd.patch12
-rw-r--r--recipes-core/llvm/llvm2.8_2.8.bb3
2 files changed, 15 insertions, 0 deletions
diff --git a/recipes-core/llvm/llvm2.8/add-unistd.patch b/recipes-core/llvm/llvm2.8/add-unistd.patch
new file mode 100644
index 0000000..1c51b30
--- /dev/null
+++ b/recipes-core/llvm/llvm2.8/add-unistd.patch
@@ -0,0 +1,12 @@
1Index: llvm-2.8/lib/ExecutionEngine/JIT/Intercept.cpp
2===================================================================
3--- llvm-2.8.orig/lib/ExecutionEngine/JIT/Intercept.cpp 2012-05-14 18:31:21.008318473 +0200
4+++ llvm-2.8/lib/ExecutionEngine/JIT/Intercept.cpp 2012-05-14 18:32:53.523734850 +0200
5@@ -19,6 +19,7 @@
6 #include "llvm/Support/ErrorHandling.h"
7 #include "llvm/System/DynamicLibrary.h"
8 #include "llvm/Config/config.h"
9+#include <unistd.h>
10 using namespace llvm;
11
12 // AtExitHandlers - List of functions to call when the program exits,
diff --git a/recipes-core/llvm/llvm2.8_2.8.bb b/recipes-core/llvm/llvm2.8_2.8.bb
index 310e94e..3459885 100644
--- a/recipes-core/llvm/llvm2.8_2.8.bb
+++ b/recipes-core/llvm/llvm2.8_2.8.bb
@@ -4,9 +4,12 @@ require llvm.inc
4LICENSE = "NCSA" 4LICENSE = "NCSA"
5LIC_FILES_CHKSUM = "file://LICENSE.TXT;md5=0ac5f799a2d89477c75b0a378b221855" 5LIC_FILES_CHKSUM = "file://LICENSE.TXT;md5=0ac5f799a2d89477c75b0a378b221855"
6 6
7PR = "r1"
8
7SRC_URI += " \ 9SRC_URI += " \
8 file://30may-llvm2.8-pr399-ppc-arm.patch \ 10 file://30may-llvm2.8-pr399-ppc-arm.patch \
9 file://0019-issue6065.patch \ 11 file://0019-issue6065.patch \
12 file://add-unistd.patch \
10 " 13 "
11 14
12SRC_URI_append_arm = " file://llvm-mc_disable.patch " 15SRC_URI_append_arm = " file://llvm-mc_disable.patch "