summaryrefslogtreecommitdiffstats
path: root/recipes-core/junit
diff options
context:
space:
mode:
authorJens Rehsack <rehsack@gmail.com>2015-12-08 14:51:50 +0100
committerMaxin B. John <maxin.john@intel.com>2015-12-08 17:43:35 +0200
commit04d5d0bf414c05ca59618d77f17ff9898aa1c566 (patch)
treee4d640f95075d3291a7466a4b8af8f0421e9745b /recipes-core/junit
parent0d7ba0ff39a332b0f93c4958370b2c7db9ea0e30 (diff)
downloadmeta-java-04d5d0bf414c05ca59618d77f17ff9898aa1c566.tar.gz
meta-java: rely on well known bootstrap-path
Instead of potential circular depending virtual/javac-native (even this recipe provides such a useable java-native), rely on well known path via cacao-native to build up to icedtea7-native in reliable manner. virtual/javac-native should be used by parts not belonging to the bootstrap phase. Signed-off-by: Jens Rehsack <sno@netbsd.org> Signed-off-by: Maxin B. John <maxin.john@intel.com>
Diffstat (limited to 'recipes-core/junit')
-rw-r--r--recipes-core/junit/junit4_4.3.1.bb4
-rw-r--r--recipes-core/junit/junit_3.8.2.bb2
2 files changed, 2 insertions, 4 deletions
diff --git a/recipes-core/junit/junit4_4.3.1.bb b/recipes-core/junit/junit4_4.3.1.bb
index 1cb8674..8d9dd31 100644
--- a/recipes-core/junit/junit4_4.3.1.bb
+++ b/recipes-core/junit/junit4_4.3.1.bb
@@ -8,9 +8,7 @@ SRC_URI = "http://downloads.sourceforge.net/junit/junit-${PV}-src.jar"
8 8
9S = "${WORKDIR}" 9S = "${WORKDIR}"
10 10
11inherit java-library 11inherit java-library java-bootstrap-components
12
13DEPENDS = "fastjar-native"
14 12
15do_compile() { 13do_compile() {
16 mkdir -p build 14 mkdir -p build
diff --git a/recipes-core/junit/junit_3.8.2.bb b/recipes-core/junit/junit_3.8.2.bb
index bae022d..54ce9fe 100644
--- a/recipes-core/junit/junit_3.8.2.bb
+++ b/recipes-core/junit/junit_3.8.2.bb
@@ -11,7 +11,7 @@ S = "${WORKDIR}/junit${PV}"
11 11
12DEPENDS += "unzip-native" 12DEPENDS += "unzip-native"
13 13
14inherit java-library 14inherit java-library java-bootstrap-components
15 15
16do_unpackpost() { 16do_unpackpost() {
17 mkdir -p src 17 mkdir -p src