summaryrefslogtreecommitdiffstats
path: root/recipes-core/junit
diff options
context:
space:
mode:
authorHenning Heinold <heinold@inf.fu-berlin.de>2011-11-12 20:58:34 +0100
committerHenning Heinold <heinold@inf.fu-berlin.de>2011-11-26 23:41:44 +0100
commit57e069cde6617f00ca8834a82c6f360af43d5067 (patch)
tree48cbe15e96d217c45acfa64b0c13aad8c6424980 /recipes-core/junit
downloadmeta-java-57e069cde6617f00ca8834a82c6f360af43d5067.tar.gz
meta-java: initial commit
* taken over mostly stuff from oe classic * cleaned up recipes * added license checksums * bump icedtea6-native to 1.8.11 * use jamvm from git as native
Diffstat (limited to 'recipes-core/junit')
-rw-r--r--recipes-core/junit/junit4_4.3.1.bb29
-rw-r--r--recipes-core/junit/junit_3.8.2.bb39
2 files changed, 68 insertions, 0 deletions
diff --git a/recipes-core/junit/junit4_4.3.1.bb b/recipes-core/junit/junit4_4.3.1.bb
new file mode 100644
index 0000000..bed0e42
--- /dev/null
+++ b/recipes-core/junit/junit4_4.3.1.bb
@@ -0,0 +1,29 @@
1DESCRIPTION = "JUnit is a testing framework for Java"
2LICENSE = "CPL"
3AUTHOR = "junit.org"
4HOMEPAGE = "http://www.junit.org"
5
6SRC_URI = "http://downloads.sourceforge.net/junit/junit-${PV}-src.jar"
7
8S = "${WORKDIR}"
9
10inherit java-library
11
12DEPENDS = "fastjar-native"
13
14do_compile() {
15 mkdir -p build
16
17 # Workaround for jamvm.
18 bcp=${STAGING_DATADIR_NATIVE}/classpath/glibj.zip
19
20 javac -source 5.0 -bootclasspath $bcp -sourcepath . -d build `find . -name "*.java"`
21
22 fastjar -C build -c -f ${JARFILENAME} .
23}
24
25SRC_URI[md5sum] = "170f9645a41398388e8553b32ff5f630"
26SRC_URI[sha256sum] = "57d1e49ee3fd0dbdc0a68a852925c973af5c30b1725b6aa63bfb42df6f7c3349"
27
28NATIVE_INSTALL_WORKS = "1"
29BBCLASSEXTEND = "native"
diff --git a/recipes-core/junit/junit_3.8.2.bb b/recipes-core/junit/junit_3.8.2.bb
new file mode 100644
index 0000000..a628ac4
--- /dev/null
+++ b/recipes-core/junit/junit_3.8.2.bb
@@ -0,0 +1,39 @@
1DESCRIPTION = "JUnit is a testing framework for Java"
2AUTHOR = "junit.org"
3HOMEPAGE = "http://www.junit.org"
4LICENSE = "CPL"
5LIC_FILES_CHKSUM = "file://cpl-v10.html;md5=67a4b75d42edcbd82d2878eba913691b"
6
7SRC_URI = "http://downloads.sourceforge.net/junit/junit${PV}.zip"
8
9S = "${WORKDIR}/junit${PV}"
10
11inherit java-library
12
13do_unpackpost() {
14 mkdir -p src
15
16 # Prevent deletion by do_removebinaries.
17 mv src.jar src.zip
18
19 unzip src.zip -d src
20}
21
22addtask unpackpost before do_removebinaries after do_unpack
23
24do_compile() {
25 mkdir -p build
26
27 # Workaround for jamvm.
28 bcp=${STAGING_DATADIR_NATIVE}/classpath/glibj.zip
29
30 javac -bootclasspath $bcp -sourcepath src -d build `find src -name "*.java"`
31
32 fastjar -C build -c -f ${JARFILENAME} .
33}
34
35SRC_URI[md5sum] = "9b8963ba2147a64bd5f1574b6fd289cb"
36SRC_URI[sha256sum] = "aae23d20e6f4dc45b4bf0b10fedcbd209c100342a0cafce1aa07d2da6da1f24a"
37
38NATIVE_INSTALL_WORKS = "1"
39BBCLASSEXTEND = "native"