summaryrefslogtreecommitdiffstats
path: root/recipes-core/jlex
diff options
context:
space:
mode:
authorHenning Heinold <heinold@inf.fu-berlin.de>2011-11-12 20:58:34 +0100
committerHenning Heinold <heinold@inf.fu-berlin.de>2011-11-26 23:41:44 +0100
commit57e069cde6617f00ca8834a82c6f360af43d5067 (patch)
tree48cbe15e96d217c45acfa64b0c13aad8c6424980 /recipes-core/jlex
downloadmeta-java-57e069cde6617f00ca8834a82c6f360af43d5067.tar.gz
meta-java: initial commit
* taken over mostly stuff from oe classic * cleaned up recipes * added license checksums * bump icedtea6-native to 1.8.11 * use jamvm from git as native
Diffstat (limited to 'recipes-core/jlex')
-rwxr-xr-xrecipes-core/jlex/files/jlex5
-rw-r--r--recipes-core/jlex/jlex_1.2.6.bb47
2 files changed, 52 insertions, 0 deletions
diff --git a/recipes-core/jlex/files/jlex b/recipes-core/jlex/files/jlex
new file mode 100755
index 0000000..7a9e756
--- /dev/null
+++ b/recipes-core/jlex/files/jlex
@@ -0,0 +1,5 @@
1#!/bin/sh
2
3cp=OE_STAGING_DATADIR_JAVA/OE_JLEX_JAR
4
5exec OE_STAGING_BINDIR/java -cp $cp JLex.Main "$@"
diff --git a/recipes-core/jlex/jlex_1.2.6.bb b/recipes-core/jlex/jlex_1.2.6.bb
new file mode 100644
index 0000000..e0fe186
--- /dev/null
+++ b/recipes-core/jlex/jlex_1.2.6.bb
@@ -0,0 +1,47 @@
1DESCRIPTION = "Lexical analyzer generator for Java"
2AUTHOR = "Elliot Berk, A. Appel, C. Scott Ananian"
3LICENSE = "JLEX"
4LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
5 file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420 \
6 "
7
8RDEPENDS_${PN} = "java2-runtime"
9RDEPENDS_${PN}_virtclass-native = ""
10
11inherit java-library
12
13SRC_URI = "http://www.cs.princeton.edu/~appel/modern/java/JLex/Archive/${PV}/Main.java \
14 file://jlex \
15 "
16
17S = "${WORKDIR}"
18
19do_configure() {
20 sed -i \
21 -e "s|OE_STAGING_BINDIR|${bindir}|" \
22 -e "s|OE_STAGING_DATADIR_JAVA|${datadir_java}|" \
23 -e "s|OE_JLEX_JAR|${BP}.jar|" \
24 ${WORKDIR}/jlex
25}
26
27do_compile() {
28 mkdir -p build
29
30 javac -d build Main.java
31
32 fastjar -C build -c -f ${BP}.jar .
33}
34
35do_install_append() {
36 install -d ${D}${bindir}
37 install -m 0755 jlex ${D}${bindir}/
38}
39
40PACKAGES = "${PN}"
41
42FILES_${PN} += "${datadir_java}"
43
44SRC_URI[md5sum] = "fe0cff5db3e2f0f5d67a153cf6c783af"
45SRC_URI[sha256sum] = "aeebaece3b3a53972bb0ba0f810540386c267070ee9dca6ffa43c6ff74a54bd7"
46
47BBCLASSEXTEND = "native"