summaryrefslogtreecommitdiffstats
path: root/recipes-core/jamvm
diff options
context:
space:
mode:
authorJan Luebbe <jlu@pengutronix.de>2012-05-15 09:56:31 +0000
committerHenning Heinold <heinold@inf.fu-berlin.de>2012-05-25 22:16:20 +0200
commit5d528acac0eab6cfaa4ed3c290c7db3acd5047bf (patch)
tree0c42eb97627667a890023266703bffa06a9021dd /recipes-core/jamvm
parent3738fc4fc2b2bad549c9f7b15626572efc62ca8d (diff)
downloadmeta-java-5d528acac0eab6cfaa4ed3c290c7db3acd5047bf.tar.gz
jamvm: work around min heap size greater than max error
On system with large amounts of RAM (such as 96GB), the default initial heap size is larger than the max heap size specified in some build commands. Set min_heap to the max_heap value in those cases instead. Signed-off-by: Jan Luebbe <jlu@pengutronix.de> Signed-off-by: Henning Heinold <heinold@inf.fu-berlin.de>
Diffstat (limited to 'recipes-core/jamvm')
-rw-r--r--recipes-core/jamvm/jamvm/jamvm-minmax-heap.patch15
-rw-r--r--recipes-core/jamvm/jamvm_git.bb3
2 files changed, 17 insertions, 1 deletions
diff --git a/recipes-core/jamvm/jamvm/jamvm-minmax-heap.patch b/recipes-core/jamvm/jamvm/jamvm-minmax-heap.patch
new file mode 100644
index 0000000..bf0fda5
--- /dev/null
+++ b/recipes-core/jamvm/jamvm/jamvm-minmax-heap.patch
@@ -0,0 +1,15 @@
1diff --git a/src/jam.c b/src/jam.c
2index b76ce8b..dc5eac3 100644
3--- a/src/jam.c
4+++ b/src/jam.c
5@@ -133,9 +133,7 @@ int parseCommandLine(int argc, char *argv[], InitArgs *args) {
6 for(i = 1; i < argc; i++) {
7 if(*argv[i] != '-') {
8 if(args->min_heap > args->max_heap) {
9- printf("Minimum heap size greater than max!\n");
10- status = 1;
11- goto exit;
12+ args->min_heap = args->max_heap;
13 }
14
15 if(args->props_count) {
diff --git a/recipes-core/jamvm/jamvm_git.bb b/recipes-core/jamvm/jamvm_git.bb
index 2a4213b..7b28600 100644
--- a/recipes-core/jamvm/jamvm_git.bb
+++ b/recipes-core/jamvm/jamvm_git.bb
@@ -6,11 +6,12 @@ require jamvm.inc
6SRCREV = "4617da717ecb05654ea5bb9572338061106a414d" 6SRCREV = "4617da717ecb05654ea5bb9572338061106a414d"
7PV = "1.5.5+1.6.0-devel+git${SRCPV}" 7PV = "1.5.5+1.6.0-devel+git${SRCPV}"
8 8
9PR = "r1" 9PR = "r2"
10 10
11SRC_URI = "git://git.berlios.de/jamvm;protocol=git \ 11SRC_URI = "git://git.berlios.de/jamvm;protocol=git \
12 file://jamvm-jni_h-noinst.patch \ 12 file://jamvm-jni_h-noinst.patch \
13 file://libffi.patch \ 13 file://libffi.patch \
14 file://jamvm-minmax-heap.patch \
14 " 15 "
15 16
16S = "${WORKDIR}/git" 17S = "${WORKDIR}/git"