summaryrefslogtreecommitdiffstats
path: root/recipes-core/jamvm
diff options
context:
space:
mode:
authorHenning Heinold <heinold@inf.fu-berlin.de>2013-07-29 09:04:02 +0000
committerHenning Heinold <heinold@inf.fu-berlin.de>2013-09-29 21:52:23 +0200
commit1f41f82b9241a69a4a1d61e2c547477a1ac84b5a (patch)
treed7039e6a1cedb21c0b7fe0e7a88ddf6b1ec5b7ce /recipes-core/jamvm
parent2e8a124faf208f6ea1aa3a16a3aab4c3a69ac2e8 (diff)
downloadmeta-java-1f41f82b9241a69a4a1d61e2c547477a1ac84b5a.tar.gz
jamvm: update to git revision ac22c9948434e528ece451642b4ebde40953ee7e
* fix gnuclasspath annotations
Diffstat (limited to 'recipes-core/jamvm')
-rw-r--r--recipes-core/jamvm/jamvm/annotations.patch31
-rw-r--r--recipes-core/jamvm/jamvm_git.bb6
2 files changed, 34 insertions, 3 deletions
diff --git a/recipes-core/jamvm/jamvm/annotations.patch b/recipes-core/jamvm/jamvm/annotations.patch
new file mode 100644
index 0000000..6279366
--- /dev/null
+++ b/recipes-core/jamvm/jamvm/annotations.patch
@@ -0,0 +1,31 @@
1Index: git/src/classlib/gnuclasspath/annotations.c
2===================================================================
3--- git.orig/src/classlib/gnuclasspath/annotations.c 2013-07-29 10:44:38.597241346 +0000
4+++ git/src/classlib/gnuclasspath/annotations.c 2013-07-29 11:03:42.927744962 +0000
5@@ -247,7 +247,7 @@
6 return anno;
7 }
8
9-Object *parseAnnotations(Class *class, AnnotationData *annotations) {
10+Object *parseAnnotations(Class *class, AttributeData *annotations) {
11 if(!anno_inited && !initAnnotation())
12 return NULL;
13
14@@ -290,7 +290,7 @@
15 }
16
17 Object *getMethodParameterAnnotations(MethodBlock *mb) {
18- AnnotationData *annotations;
19+ AttributeData *annotations;
20 Object **outer_array_data;
21 Object *outer_array;
22 int no_params, i;
23@@ -342,7 +342,7 @@
24 }
25
26 Object *getMethodDefaultValue(MethodBlock *mb) {
27- AnnotationData *annotations;
28+ AttributeData *annotations;
29
30 if(!anno_inited && !initAnnotation())
31 return NULL;
diff --git a/recipes-core/jamvm/jamvm_git.bb b/recipes-core/jamvm/jamvm_git.bb
index 88df6fc..97ed1cc 100644
--- a/recipes-core/jamvm/jamvm_git.bb
+++ b/recipes-core/jamvm/jamvm_git.bb
@@ -3,15 +3,15 @@
3 3
4require jamvm.inc 4require jamvm.inc
5 5
6SRCREV = "0972452d441544f7dd29c55d64f1ce3a5db90d82" 6SRCREV = "ac22c9948434e528ece451642b4ebde40953ee7e"
7PV = "1.5.5+1.6.0-devel+git${SRCPV}" 7PV = "1.5.5+1.6.0-devel+git${SRCPV}"
8 8
9PR = "r4"
10
11SRC_URI = "git://git.berlios.de/jamvm;protocol=git \ 9SRC_URI = "git://git.berlios.de/jamvm;protocol=git \
12 file://jamvm-jni_h-noinst.patch \ 10 file://jamvm-jni_h-noinst.patch \
13 file://libffi.patch \ 11 file://libffi.patch \
14 file://jamvm-minmax-heap.patch \ 12 file://jamvm-minmax-heap.patch \
13 file://annotations.patch \
14 file://java \
15 " 15 "
16 16
17S = "${WORKDIR}/git" 17S = "${WORKDIR}/git"