summaryrefslogtreecommitdiffstats
path: root/recipes-core/jamvm
diff options
context:
space:
mode:
authorMagnus Olsson <magnus@minimum.se>2015-03-10 13:19:54 +0100
committerOtavio Salvador <otavio@ossystems.com.br>2015-03-11 10:43:53 -0300
commitbd9c60238c4c62d9a0f2d60b89aef429a1b71e34 (patch)
tree0c1a1d5aeb46ad29e6dfadb45c54f4ec59b2b0bc /recipes-core/jamvm
parentbd76e577a9f12b3036b0e7923b223dcd8b8ab7ed (diff)
downloadmeta-java-bd9c60238c4c62d9a0f2d60b89aef429a1b71e34.tar.gz
initials: silence "populate_sysroot manifest not found" warnings
A number of recipes in meta-java use autotools.bbclass for building; internally it uses the sstate-control populate_sysroot manifests to locate and copy aslocals for configure dependencies as part of the do_configure step. The manifest path differs depending on if it's a native package or not so autotools.bbclass looks at the package name to determine if its native or not (it's native if it ends with "-native"). The warnings are emitted because a few (native) recipes in meta-java (such as cacao-initial, classpath-initial and more) are incorrectly being classified as non-native by autotools.bbclass, which makes it look for the manifest in the wrong place and finally gives up with the warning: WARNING: /home/oe/tmp-glibc/sstate-control/manifest-mymachine-libecj-bootstrap.populate_sysroot not found This happens for cacao-initial, classpath-initial, ecj-initial, libecj-boostrap, jamvm-initial and jikes-initial since they are all native and rely on autotools. This patch renames the recipes so they end with -native, e.g ecj-initial-native. It also updates the recipes so they DEPEND on the corresponding new name. This helps autotools.bbclass to properly classify the recipes are native and silence the warnings. Signed-off-by: Magnus Olsson <magnus@minimum.se> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-core/jamvm')
-rw-r--r--recipes-core/jamvm/jamvm-initial-native_1.4.5.bb (renamed from recipes-core/jamvm/jamvm-initial_1.4.5.bb)2
-rw-r--r--recipes-core/jamvm/jamvm.inc2
2 files changed, 2 insertions, 2 deletions
diff --git a/recipes-core/jamvm/jamvm-initial_1.4.5.bb b/recipes-core/jamvm/jamvm-initial-native_1.4.5.bb
index 4c64f6a..25b42b0 100644
--- a/recipes-core/jamvm/jamvm-initial_1.4.5.bb
+++ b/recipes-core/jamvm/jamvm-initial-native_1.4.5.bb
@@ -3,7 +3,7 @@ HOMEPAGE = "http://jamvm.sourceforge.net/"
3LICENSE = "GPL" 3LICENSE = "GPL"
4LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3" 4LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
5 5
6DEPENDS = "zlib-native classpath-initial jikes-initial libffi-native" 6DEPENDS = "zlib-native classpath-initial-native jikes-initial-native libffi-native"
7 7
8PROVIDES = "virtual/java-initial" 8PROVIDES = "virtual/java-initial"
9 9
diff --git a/recipes-core/jamvm/jamvm.inc b/recipes-core/jamvm/jamvm.inc
index 094b22b..5893cbc 100644
--- a/recipes-core/jamvm/jamvm.inc
+++ b/recipes-core/jamvm/jamvm.inc
@@ -4,7 +4,7 @@ LICENSE = "GPL-2.0"
4LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3" 4LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
5 5
6DEPENDS = "zlib classpath virtual/javac-native libffi" 6DEPENDS = "zlib classpath virtual/javac-native libffi"
7DEPENDS_virtclass-native = "zlib-native classpath-native ecj-initial libffi-native" 7DEPENDS_virtclass-native = "zlib-native classpath-native ecj-initial-native libffi-native"
8 8
9RDEPENDS_${PN} = "classpath" 9RDEPENDS_${PN} = "classpath"
10RDEPENDS_${PN}_virtclass-native = "" 10RDEPENDS_${PN}_virtclass-native = ""