summaryrefslogtreecommitdiffstats
path: root/recipes-core/jamvm/jamvm-1.4.5
diff options
context:
space:
mode:
authorHenning Heinold <heinold@inf.fu-berlin.de>2013-01-10 19:42:26 +0100
committerHenning Heinold <heinold@inf.fu-berlin.de>2013-01-24 22:32:08 +0100
commit74770df7e31271be5056ab757cc3d5875ef002e8 (patch)
tree6e7f4a39fe65bf278491543f69ee0465291bd82e /recipes-core/jamvm/jamvm-1.4.5
parentf861d37eb4851245d36889c2d5f44177dfe873f0 (diff)
downloadmeta-java-74770df7e31271be5056ab757cc3d5875ef002e8.tar.gz
jamvm-initial: rename patches directory for newer bitbake
Diffstat (limited to 'recipes-core/jamvm/jamvm-1.4.5')
-rw-r--r--recipes-core/jamvm/jamvm-1.4.5/jamvm-initial.patch63
-rw-r--r--recipes-core/jamvm/jamvm-1.4.5/libffi.patch68
2 files changed, 131 insertions, 0 deletions
diff --git a/recipes-core/jamvm/jamvm-1.4.5/jamvm-initial.patch b/recipes-core/jamvm/jamvm-1.4.5/jamvm-initial.patch
new file mode 100644
index 0000000..fb069f8
--- /dev/null
+++ b/recipes-core/jamvm/jamvm-1.4.5/jamvm-initial.patch
@@ -0,0 +1,63 @@
1Index: jamvm-1.4.5/configure.ac
2===================================================================
3--- jamvm-1.4.5.orig/configure.ac
4+++ jamvm-1.4.5/configure.ac
5@@ -1,6 +1,6 @@
6 dnl Process this file with autoconf to produce a configure script.
7 AC_INIT(src/jam.c)
8-AM_INIT_AUTOMAKE(jamvm, 1.4.5)
9+AM_INIT_AUTOMAKE(jamvm-initial, 1.4.5)
10 AC_CONFIG_HEADERS([src/config.h])
11 AC_PREFIX_DEFAULT(/usr/local/jamvm)
12
13Index: jamvm-1.4.5/lib/Makefile.am
14===================================================================
15--- jamvm-1.4.5.orig/lib/Makefile.am
16+++ jamvm-1.4.5/lib/Makefile.am
17@@ -1,4 +1,4 @@
18-@use_zip_yes@ GLIBJ_ZIP = ${with_classpath_install_dir}/share/classpath/glibj.zip
19+@use_zip_yes@ GLIBJ_ZIP = ${with_classpath_install_dir}/share/classpath-initial/glibj.zip
20 @use_zip_no@ GLIBJ_ZIP = ${with_classpath_install_dir}/share/classpath/
21
22 SUBDIRS = jamvm java gnu sun
23Index: jamvm-1.4.5/src/dll.c
24===================================================================
25--- jamvm-1.4.5.orig/src/dll.c
26+++ jamvm-1.4.5/src/dll.c
27@@ -294,7 +294,7 @@ char *getDllPath() {
28 }
29
30 char *getBootDllPath() {
31- return CLASSPATH_INSTALL_DIR"/lib/classpath";
32+ return CLASSPATH_INSTALL_DIR"/lib/classpath-initial";
33 }
34
35 char *getDllName(char *name) {
36Index: jamvm-1.4.5/src/Makefile.am
37===================================================================
38--- jamvm-1.4.5.orig/src/Makefile.am
39+++ jamvm-1.4.5/src/Makefile.am
40@@ -2,7 +2,7 @@ SUBDIRS = os
41 DIST_SUBDIRS = os arch
42
43 bin_PROGRAMS = jamvm
44-include_HEADERS = jni.h
45+noinst_HEADERS = jni.h
46
47 lib_LTLIBRARIES = libjvm.la
48 noinst_LTLIBRARIES = libcore.la
49Index: jamvm-1.4.5/src/class.c
50===================================================================
51--- jamvm-1.4.5.orig/src/class.c
52+++ jamvm-1.4.5/src/class.c
53@@ -1653,8 +1653,8 @@ void scanDirsForJars(char *directories)
54 }
55
56 #ifdef USE_ZIP
57-#define JAMVM_CLASSES INSTALL_DIR"/share/jamvm/classes.zip"
58-#define CLASSPATH_CLASSES CLASSPATH_INSTALL_DIR"/share/classpath/glibj.zip"
59+#define JAMVM_CLASSES INSTALL_DIR"/share/jamvm-initial/classes.zip"
60+#define CLASSPATH_CLASSES CLASSPATH_INSTALL_DIR"/share/classpath-initial/glibj.zip"
61 #else
62 #define JAMVM_CLASSES INSTALL_DIR"/share/jamvm/classes"
63 #define CLASSPATH_CLASSES CLASSPATH_INSTALL_DIR"/share/classpath"
diff --git a/recipes-core/jamvm/jamvm-1.4.5/libffi.patch b/recipes-core/jamvm/jamvm-1.4.5/libffi.patch
new file mode 100644
index 0000000..216f03c
--- /dev/null
+++ b/recipes-core/jamvm/jamvm-1.4.5/libffi.patch
@@ -0,0 +1,68 @@
1Index: jamvm-1.4.5/configure.ac
2===================================================================
3--- jamvm-1.4.5.orig/configure.ac 2007-02-05 04:18:05.000000000 +0100
4+++ jamvm-1.4.5/configure.ac 2011-11-25 19:34:58.473683844 +0100
5@@ -166,10 +166,25 @@
6 enable_zip=no
7 fi])
8
9-AC_CHECK_LIB(ffi,ffi_call,,
10- [if test "$enable_ffi" != no; then
11- AC_MSG_ERROR(cannot find libffi)
12- fi])
13+LIBFFI_FOUND=no
14+if test "$enable_ffi" = yes
15+then
16+PKG_CHECK_MODULES([LIBFFI], [libffi], [LIBFFI_FOUND=yes], [LIBFFI_FOUND=no])
17+if test "x${LIBFFI_FOUND}" = xno
18+then
19+ LIBFFI_FOUND=
20+ AC_CHECK_HEADER([ffi.h],[LIBFFI_CFLAGS=],[LIBFFI_FOUND=no])
21+ AC_SEARCH_LIBS([ffi_call], [ffi],[LIBFFI_LIBS=-lffi],[LIBFFI_FOUND=no])
22+ if test "x${LIBFFI_FOUND}" = xno
23+ then
24+ AC_MSG_ERROR([Could not find libffi headers - \
25+ Instal libffi-devel or libffi-dev.])
26+ fi
27+fi
28+fi
29+AC_SUBST(LIBFFI_CFLAGS)
30+AC_SUBST(LIBFFI_LIBS)
31+
32
33 dnl Checks for header files.
34 AC_HEADER_STDC
35@@ -180,11 +195,6 @@
36 enable_zip=no
37 fi])
38
39-AC_CHECK_HEADER(ffi.h,,
40- [if test "$enable_ffi" != no; then
41- AC_MSG_ERROR(cannot find ffi.h)
42- fi])
43-
44 if test "$enable_zip" != no; then
45 AC_DEFINE([USE_ZIP],1,[use zip])
46 use_zip_yes=
47@@ -197,7 +207,7 @@
48 AC_SUBST(use_zip_yes)
49 AC_SUBST(use_zip_no)
50
51-if test "$enable_ffi" != no; then
52+if test "x${LIBFFI_FOUND}" != no; then
53 AC_DEFINE([USE_FFI],1,[use FFI])
54 fi
55
56Index: jamvm-1.4.5/src/Makefile.am
57===================================================================
58--- jamvm-1.4.5.orig/src/Makefile.am 2006-12-25 05:10:18.000000000 +0100
59+++ jamvm-1.4.5/src/Makefile.am 2011-11-25 19:35:26.537723112 +0100
60@@ -19,6 +19,7 @@
61
62 jamvm_LDADD = libcore.la
63 libjvm_la_LIBADD = libcore.la
64-libcore_la_LIBADD = os/@os@/@arch@/libnative.la os/@os@/libos.la
65+libcore_la_LIBADD = os/@os@/@arch@/libnative.la os/@os@/libos.la $(LIBFFI_LIBS)
66+libcore_la_CPPFLAGS = $(LIBFFI_CFLAGS)
67
68 DISTCLEANFILES = arch.h