summaryrefslogtreecommitdiffstats
path: root/recipes-core/jacl
diff options
context:
space:
mode:
authorHenning Heinold <heinold@inf.fu-berlin.de>2011-11-12 20:58:34 +0100
committerHenning Heinold <heinold@inf.fu-berlin.de>2011-11-26 23:41:44 +0100
commit57e069cde6617f00ca8834a82c6f360af43d5067 (patch)
tree48cbe15e96d217c45acfa64b0c13aad8c6424980 /recipes-core/jacl
downloadmeta-java-57e069cde6617f00ca8834a82c6f360af43d5067.tar.gz
meta-java: initial commit
* taken over mostly stuff from oe classic * cleaned up recipes * added license checksums * bump icedtea6-native to 1.8.11 * use jamvm from git as native
Diffstat (limited to 'recipes-core/jacl')
-rw-r--r--recipes-core/jacl/jacl_1.4.1.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes-core/jacl/jacl_1.4.1.bb b/recipes-core/jacl/jacl_1.4.1.bb
new file mode 100644
index 0000000..80635e1
--- /dev/null
+++ b/recipes-core/jacl/jacl_1.4.1.bb
@@ -0,0 +1,29 @@
1DESCRIPTION = "Tcl interpreter for Java"
2# see this case study about JACL http://olex.openlogic.com/wazi/2008/jacl-license-case-study/
3LICENSE = "JACL"
4LIC_FILES_CHKSUM = " \
5 file://license.ucb;md5=997c6617d2f2a747e39945c0f2d1a264 \
6 file://license.terms;md5=ce3ac33515250b3a438b2633ccb29aac \
7 "
8
9HOMEPAGE = "http://sourceforge.net/projects/tcljava"
10
11SRC_URI = "http://downloads.sourceforge.net/tcljava/jacl${PV}.tar.gz"
12
13inherit java-library
14
15S = "${WORKDIR}/jacl${PV}"
16
17do_compile() {
18 mkdir -p build
19
20 javac -sourcepath src/tcljava:src/jacl -d build `find src/tcljava src/jacl -name "*.java"`
21
22 fastjar -C build -c -f ${JARFILENAME} .
23}
24
25SRC_URI[md5sum] = "a7ec8300e8933164e854460c73ac6269"
26SRC_URI[sha256sum] = "0edac0a7d2253c29c44ccc92427fa9ad4ee81b6c82142e417f72399a8584b749"
27
28NATIVE_INSTALL_WORKS = "1"
29BBCLASSEXTEND = "native"