summaryrefslogtreecommitdiffstats
path: root/recipes-core/icedtea
diff options
context:
space:
mode:
authorAlex Gonzalez <alex.gonzalez@digi.com>2014-12-31 16:24:45 +0100
committerOtavio Salvador <otavio@ossystems.com.br>2014-12-31 19:21:05 -0200
commitc600dd3ab5a6308c513f5fbf7243de1799d9ce62 (patch)
tree20f25f8b636562ba7a045c27b11f7dcd0251bcce /recipes-core/icedtea
parenta7461bf7393c516c63c49a4b099d659ee467e93e (diff)
downloadmeta-java-c600dd3ab5a6308c513f5fbf7243de1799d9ce62.tar.gz
icedtea: openjdk: Remove currency data generation expiration date.
The currency data generation class makes a 10 years expiration date check. It might be reasonable to make sure the input data is updated periodically, but on an embedded system we don't want to have this type of built in time expirations. This commit removes the date expiration check. Signed-off-by: Alex Gonzalez <alex.gonzalez@digi.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-core/icedtea')
-rw-r--r--recipes-core/icedtea/icedtea6-native-1.8.11/icedtea-openjdk-remove-currency-data-generation-expi.patch25
-rw-r--r--recipes-core/icedtea/icedtea6-native_1.8.11.bb1
2 files changed, 26 insertions, 0 deletions
diff --git a/recipes-core/icedtea/icedtea6-native-1.8.11/icedtea-openjdk-remove-currency-data-generation-expi.patch b/recipes-core/icedtea/icedtea6-native-1.8.11/icedtea-openjdk-remove-currency-data-generation-expi.patch
new file mode 100644
index 0000000..eabee67
--- /dev/null
+++ b/recipes-core/icedtea/icedtea6-native-1.8.11/icedtea-openjdk-remove-currency-data-generation-expi.patch
@@ -0,0 +1,25 @@
1From 5f5ed54f7f1ed82583f0f42abfa2625a93e96dd9 Mon Sep 17 00:00:00 2001
2From: Alex Gonzalez <alex.gonzalez@digi.com>
3Date: Wed, 31 Dec 2014 15:04:10 +0100
4Subject: [PATCH] icedtea: openjdk: remove currency data generation expiration
5 date.
6
7Signed-off-by: Alex Gonzalez <alex.gonzalez@digi.com>
8---
9 .../src/build/tools/generatecurrencydata/GenerateCurrencyData.java | 3 ---
10 1 file changed, 3 deletions(-)
11
12diff --git a/jdk/make/tools/src/build/tools/generatecurrencydata/GenerateCurrencyData.java b/jdk/make/tools/src/build/tools/generatecurrencydata/GenerateCurrencyData.java
13index 29201c25909a..f66f523de5bd 100644
14--- a/jdk/make/tools/src/build/tools/generatecurrencydata/GenerateCurrencyData.java
15+++ b/jdk/make/tools/src/build/tools/generatecurrencydata/GenerateCurrencyData.java
16@@ -281,9 +281,6 @@ public class GenerateCurrencyData {
17 checkCurrencyCode(newCurrency);
18 String timeString = currencyInfo.substring(4, length - 4);
19 long time = format.parse(timeString).getTime();
20- if (Math.abs(time - System.currentTimeMillis()) > ((long) 10) * 365 * 24 * 60 * 60 * 1000) {
21- throw new RuntimeException("time is more than 10 years from present: " + time);
22- }
23 specialCaseCutOverTimes[specialCaseCount] = time;
24 specialCaseOldCurrencies[specialCaseCount] = oldCurrency;
25 specialCaseOldCurrenciesDefaultFractionDigits[specialCaseCount] = getDefaultFractionDigits(oldCurrency);
diff --git a/recipes-core/icedtea/icedtea6-native_1.8.11.bb b/recipes-core/icedtea/icedtea6-native_1.8.11.bb
index f0709f4..78d24e6 100644
--- a/recipes-core/icedtea/icedtea6-native_1.8.11.bb
+++ b/recipes-core/icedtea/icedtea6-native_1.8.11.bb
@@ -18,6 +18,7 @@ SRC_URI = "\
18 file://build-hacks-native.patch \ 18 file://build-hacks-native.patch \
19 file://icedtea-sane-x86-arch-name.patch \ 19 file://icedtea-sane-x86-arch-name.patch \
20 file://icedtea-fix-jar-path.patch \ 20 file://icedtea-fix-jar-path.patch \
21 file://icedtea-openjdk-remove-currency-data-generation-expi.patch;patchdir=../openjdk-src-dir \
21 ${ICEDTEA_PATCHES} \ 22 ${ICEDTEA_PATCHES} \
22 " 23 "
23SRC_URI[ojdk.md5sum] = "94db01691ab38f98b7d42b2ebf4d5c0b" 24SRC_URI[ojdk.md5sum] = "94db01691ab38f98b7d42b2ebf4d5c0b"