summaryrefslogtreecommitdiffstats
path: root/recipes-core/icedtea/openjdk-7-03b147/icedtea-corba-parallel-make.patch
diff options
context:
space:
mode:
authorHenning Heinold <heinold@inf.fu-berlin.de>2012-11-22 18:47:13 +0100
committerHenning Heinold <heinold@inf.fu-berlin.de>2012-11-22 18:49:40 +0100
commit7dbdd2420d3888d8b7e4e1418ba1bbfe0b1f687c (patch)
treeca625d3583eee077c9750bd47a97b83e8ffef540 /recipes-core/icedtea/openjdk-7-03b147/icedtea-corba-parallel-make.patch
parente6e59540e4540dfca17c5904aad6fdc23cf6934e (diff)
downloadmeta-java-7dbdd2420d3888d8b7e4e1418ba1bbfe0b1f687c.tar.gz
icedtea7-native: simple copy over from openjdk-7 branch
Diffstat (limited to 'recipes-core/icedtea/openjdk-7-03b147/icedtea-corba-parallel-make.patch')
-rw-r--r--recipes-core/icedtea/openjdk-7-03b147/icedtea-corba-parallel-make.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/recipes-core/icedtea/openjdk-7-03b147/icedtea-corba-parallel-make.patch b/recipes-core/icedtea/openjdk-7-03b147/icedtea-corba-parallel-make.patch
new file mode 100644
index 0000000..09f7511
--- /dev/null
+++ b/recipes-core/icedtea/openjdk-7-03b147/icedtea-corba-parallel-make.patch
@@ -0,0 +1,31 @@
1diff --git openjdk/corba/make/Makefile openjdk/corba/make/Makefile
2index aef5c1b..62e2216 100644
3--- openjdk/corba/make/Makefile
4+++ openjdk/corba/make/Makefile
5@@ -134,7 +134,7 @@ default: all
6 #----- classes.jar
7
8 CLASSES_JAR = $(LIB_DIR)/classes.jar
9-$(CLASSES_JAR):
10+$(CLASSES_JAR): build
11 $(MKDIR) -p $(@D)
12 $(BOOT_JAR_CMD) -cf $@ -C $(CLASSES_DIR) .
13
14@@ -144,6 +144,7 @@ SRC_ZIP_FILES = $(shell $(FIND) $(SRC_CLASSES_DIR) \( -name \*-template \) -prun
15
16 SRC_ZIP = $(LIB_DIR)/src.zip
17 $(SRC_ZIP): $(SRC_ZIP_FILES)
18+ $(MKDIR) -p $(@D)
19 abs_src_zip=`cd $(@D) ; pwd`/$(@F) ; \
20 ( cd $(SRC_CLASSES_DIR) ; $(FIND) . \( -name \*-template \) -prune -o -type f -print | $(ZIP) -q $$abs_src_zip -@ ) ; \
21 ( cd $(GENSRC_DIR) ; $(FIND) . -type f -print | $(ZIP) -q $$abs_src_zip -@ ) ;
22@@ -153,7 +154,8 @@ $(SRC_ZIP): $(SRC_ZIP_FILES)
23 BIN_ZIP_FILES = $(BUILD_DIR/lib/orb.idl $(BUILD_DIR)/lib/ir.idl
24
25 BIN_ZIP = $(LIB_DIR)/bin.zip
26-$(BIN_ZIP): $(BIN_ZIP_FILES)
27+$(BIN_ZIP): build $(BIN_ZIP_FILES)
28+ $(MKDIR) -p $(@D)
29 abs_bin_zip=`cd $(@D) ; pwd`/$(@F) ; \
30 ( cd $(BUILD_DIR) ; $(FIND) lib -name "*.idl" -print | $(ZIP) -q $$abs_bin_zip -@ ) ;
31