summaryrefslogtreecommitdiffstats
path: root/recipes-core/ecj
diff options
context:
space:
mode:
authorHenning Heinold <heinold@inf.fu-berlin.de>2012-03-19 00:18:02 +0100
committerHenning Heinold <heinold@inf.fu-berlin.de>2012-05-25 22:12:33 +0200
commitdc42af0846fb690ef79471af9690597cad1257e4 (patch)
tree8d91214c1c7c80480b4ae1ea63904ecfb3f7d345 /recipes-core/ecj
parent9fa973a195775e7c17966dce68e4c92338257612 (diff)
downloadmeta-java-dc42af0846fb690ef79471af9690597cad1257e4.tar.gz
ecj-bootstrap: rework javac script and bump PR
Diffstat (limited to 'recipes-core/ecj')
-rw-r--r--recipes-core/ecj/ecj-bootstrap-native.bb1
-rwxr-xr-xrecipes-core/ecj/files/ecj.in20
2 files changed, 14 insertions, 7 deletions
diff --git a/recipes-core/ecj/ecj-bootstrap-native.bb b/recipes-core/ecj/ecj-bootstrap-native.bb
index df05be5..dded41b 100644
--- a/recipes-core/ecj/ecj-bootstrap-native.bb
+++ b/recipes-core/ecj/ecj-bootstrap-native.bb
@@ -10,6 +10,7 @@ LICENSE = "MIT"
10LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \ 10LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
11 file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420 \ 11 file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420 \
12 " 12 "
13PR = "r1"
13 14
14DEPENDS = "libecj-bootstrap virtual/java-native" 15DEPENDS = "libecj-bootstrap virtual/java-native"
15 16
diff --git a/recipes-core/ecj/files/ecj.in b/recipes-core/ecj/files/ecj.in
index 30c3862..e054f24 100755
--- a/recipes-core/ecj/files/ecj.in
+++ b/recipes-core/ecj/files/ecj.in
@@ -1,12 +1,18 @@
1error_counter=0; 1error_counter=1
2error_occured=139 2error_max=21
3while [ ${error_counter} -le 50 -a ${error_occured} -eq 139 ]; do 3error_occured=true
4error_number=0
5while [ ${error_counter} -le ${error_max} -a ${error_occured} == true ]; do
4 ${RUNTIME} -Xmx1024m -cp ${ECJ_JAR} org.eclipse.jdt.internal.compiler.batch.Main ${1+"$@"} 6 ${RUNTIME} -Xmx1024m -cp ${ECJ_JAR} org.eclipse.jdt.internal.compiler.batch.Main ${1+"$@"}
5 error_occured=$? 7 error_number=$?
6 if [ ${error_occured} -eq 139 ]; then 8 if [ ${error_number} -eq 139 -o ${error_number} -eq 134 ]; then
7 echo "ecj crashed - silently trying again" 9 echo "ecj crashed ${error_counter} - silently trying again"
10 error_occured=true
8 error_counter=$(( $error_counter + 1 )) 11 error_counter=$(( $error_counter + 1 ))
12 else
13 error_occured=false
9 fi 14 fi
10done 15done
11 16
12exit ${error_occured} 17exit ${error_number}
18