summaryrefslogtreecommitdiffstats
path: root/recipes-core/ecj
diff options
context:
space:
mode:
authorMagnus Olsson <magnus@minimum.se>2015-03-10 13:19:54 +0100
committerOtavio Salvador <otavio@ossystems.com.br>2015-03-11 10:43:53 -0300
commitbd9c60238c4c62d9a0f2d60b89aef429a1b71e34 (patch)
tree0c1a1d5aeb46ad29e6dfadb45c54f4ec59b2b0bc /recipes-core/ecj
parentbd76e577a9f12b3036b0e7923b223dcd8b8ab7ed (diff)
downloadmeta-java-bd9c60238c4c62d9a0f2d60b89aef429a1b71e34.tar.gz
initials: silence "populate_sysroot manifest not found" warnings
A number of recipes in meta-java use autotools.bbclass for building; internally it uses the sstate-control populate_sysroot manifests to locate and copy aslocals for configure dependencies as part of the do_configure step. The manifest path differs depending on if it's a native package or not so autotools.bbclass looks at the package name to determine if its native or not (it's native if it ends with "-native"). The warnings are emitted because a few (native) recipes in meta-java (such as cacao-initial, classpath-initial and more) are incorrectly being classified as non-native by autotools.bbclass, which makes it look for the manifest in the wrong place and finally gives up with the warning: WARNING: /home/oe/tmp-glibc/sstate-control/manifest-mymachine-libecj-bootstrap.populate_sysroot not found This happens for cacao-initial, classpath-initial, ecj-initial, libecj-boostrap, jamvm-initial and jikes-initial since they are all native and rely on autotools. This patch renames the recipes so they end with -native, e.g ecj-initial-native. It also updates the recipes so they DEPEND on the corresponding new name. This helps autotools.bbclass to properly classify the recipes are native and silence the warnings. Signed-off-by: Magnus Olsson <magnus@minimum.se> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-core/ecj')
-rw-r--r--recipes-core/ecj/ecj-bootstrap-native.bb2
-rw-r--r--recipes-core/ecj/ecj-initial-native.bb (renamed from recipes-core/ecj/ecj-initial.bb)2
-rw-r--r--recipes-core/ecj/libecj-bootstrap-native_3.6.2.bb (renamed from recipes-core/ecj/libecj-bootstrap_3.6.2.bb)0
-rw-r--r--recipes-core/ecj/libecj-bootstrap.inc2
4 files changed, 3 insertions, 3 deletions
diff --git a/recipes-core/ecj/ecj-bootstrap-native.bb b/recipes-core/ecj/ecj-bootstrap-native.bb
index c9be269..e159c9d 100644
--- a/recipes-core/ecj/ecj-bootstrap-native.bb
+++ b/recipes-core/ecj/ecj-bootstrap-native.bb
@@ -12,7 +12,7 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d
12 " 12 "
13PR = "r1" 13PR = "r1"
14 14
15DEPENDS = "libecj-bootstrap virtual/java-native" 15DEPENDS = "libecj-bootstrap-native virtual/java-native"
16 16
17PROVIDES = "virtual/javac-native" 17PROVIDES = "virtual/javac-native"
18 18
diff --git a/recipes-core/ecj/ecj-initial.bb b/recipes-core/ecj/ecj-initial-native.bb
index 45317a6..ed334ed 100644
--- a/recipes-core/ecj/ecj-initial.bb
+++ b/recipes-core/ecj/ecj-initial-native.bb
@@ -8,7 +8,7 @@ HOMEPAGE = "http://www.eclipse.org/"
8LICENSE = "MIT" 8LICENSE = "MIT"
9LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302" 9LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
10 10
11DEPENDS = "libecj-bootstrap" 11DEPENDS = "libecj-bootstrap-native"
12 12
13SRC_URI = "file://ecj-initial.in" 13SRC_URI = "file://ecj-initial.in"
14 14
diff --git a/recipes-core/ecj/libecj-bootstrap_3.6.2.bb b/recipes-core/ecj/libecj-bootstrap-native_3.6.2.bb
index 51dbca0..51dbca0 100644
--- a/recipes-core/ecj/libecj-bootstrap_3.6.2.bb
+++ b/recipes-core/ecj/libecj-bootstrap-native_3.6.2.bb
diff --git a/recipes-core/ecj/libecj-bootstrap.inc b/recipes-core/ecj/libecj-bootstrap.inc
index cd9d90f..9fb4156 100644
--- a/recipes-core/ecj/libecj-bootstrap.inc
+++ b/recipes-core/ecj/libecj-bootstrap.inc
@@ -5,7 +5,7 @@ HOMEPAGE = "http://www.eclipse.org/"
5LICENSE = "EPL-1.0" 5LICENSE = "EPL-1.0"
6LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/EPL-1.0;md5=57f8d5e2b3e98ac6e088986c12bf94e6" 6LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/EPL-1.0;md5=57f8d5e2b3e98ac6e088986c12bf94e6"
7 7
8DEPENDS = "fastjar-native jikes-initial virtual/java-initial" 8DEPENDS = "fastjar-native jikes-initial-native virtual/java-initial"
9 9
10INC_PR = "r5" 10INC_PR = "r5"
11 11