summaryrefslogtreecommitdiffstats
path: root/recipes-core/cup
diff options
context:
space:
mode:
authorHenning Heinold <heinold@inf.fu-berlin.de>2011-11-12 20:58:34 +0100
committerHenning Heinold <heinold@inf.fu-berlin.de>2011-11-26 23:41:44 +0100
commit57e069cde6617f00ca8834a82c6f360af43d5067 (patch)
tree48cbe15e96d217c45acfa64b0c13aad8c6424980 /recipes-core/cup
downloadmeta-java-57e069cde6617f00ca8834a82c6f360af43d5067.tar.gz
meta-java: initial commit
* taken over mostly stuff from oe classic * cleaned up recipes * added license checksums * bump icedtea6-native to 1.8.11 * use jamvm from git as native
Diffstat (limited to 'recipes-core/cup')
-rw-r--r--recipes-core/cup/cup_0.10k.bb47
-rwxr-xr-xrecipes-core/cup/files/cup5
2 files changed, 52 insertions, 0 deletions
diff --git a/recipes-core/cup/cup_0.10k.bb b/recipes-core/cup/cup_0.10k.bb
new file mode 100644
index 0000000..5b76fcc
--- /dev/null
+++ b/recipes-core/cup/cup_0.10k.bb
@@ -0,0 +1,47 @@
1DESCRIPTION = "Lexical analyzer generator for Java"
2AUTHOR = "Elliot Berk, A. Appel, C. Scott Ananian"
3LICENSE = "CUP"
4LIC_FILES_CHKSUM = "file://${WORKDIR}/LICENSE;md5=2c9db91c00f38e52cfc8e67bafaa7c33"
5
6
7RDEPENDS_${PN} = "java2-runtime"
8RDEPENDS_${PN}_virtclass-native = ""
9
10inherit java-library
11
12SRC_URI = "http://www.cs.princeton.edu/~appel/modern/java/CUP/java_${BPN}_v10k.tar.gz \
13 file://cup \
14 "
15
16S = "${WORKDIR}/java_cup"
17
18do_configure() {
19 sed -i \
20 -e "s|OE_STAGING_BINDIR|${bindir}|" \
21 -e "s|OE_STAGING_DATADIR_JAVA|${data_java}|" \
22 -e "s|OE_CUP_JAR|${BP}.jar|" \
23 ${WORKDIR}/cup
24}
25
26do_compile() {
27 mkdir -p build
28
29 javac -d build `find . -name "*.java"`
30
31 fastjar -C build -c -f ${BP}.jar .
32}
33
34do_install_append() {
35 install -d ${D}${bindir}
36 install -m 0755 ${WORKDIR}/cup ${D}${bindir}
37}
38
39PACKAGES = "${PN}"
40
41FILES_${PN} += "${datadir_java}"
42
43SRC_URI[md5sum] = "8b11edfec13c590ea443d0f0ae0da479"
44SRC_URI[sha256sum] = "7e6dc5be74ae56c7e86e69ad0ad88dae3b2847afa9e73a76635918a6b1eb75cd"
45
46BBCLASSEXTEND = "native"
47
diff --git a/recipes-core/cup/files/cup b/recipes-core/cup/files/cup
new file mode 100755
index 0000000..34b4f05
--- /dev/null
+++ b/recipes-core/cup/files/cup
@@ -0,0 +1,5 @@
1#!/bin/sh
2
3cp=OE_STAGING_DATADIR_JAVA/OE_CUP_JAR
4
5exec OE_STAGING_BINDIR/java -cp $cp java_cup.Main "$@"