summaryrefslogtreecommitdiffstats
path: root/recipes-core/classpath
diff options
context:
space:
mode:
authorHenning Heinold <heinold@inf.fu-berlin.de>2012-07-18 22:48:50 +0200
committerHenning Heinold <heinold@inf.fu-berlin.de>2012-07-19 17:37:39 +0200
commitea76b80108b4c292379e37e01cdbb9d984d74759 (patch)
tree8b3d9567925bfaaaa295e396c6f2ecb907356afe /recipes-core/classpath
parent817d88937ea7fed7d8812ba905a88e2c24d661d7 (diff)
downloadmeta-java-ea76b80108b4c292379e37e01cdbb9d984d74759.tar.gz
classpath: update to version 0.99
* switch to INC_PR for native and initial * clean up dependencies * inherit gettext class instead of depeding directly on the package * clean up patches
Diffstat (limited to 'recipes-core/classpath')
-rw-r--r--recipes-core/classpath/classpath-0.98/SimpleName.diff66
-rw-r--r--recipes-core/classpath/classpath-0.98/javanet-local.patch37
-rw-r--r--recipes-core/classpath/classpath-0.99/autotools.patch118
-rw-r--r--recipes-core/classpath/classpath-0.99/ecj_java_dir.patch (renamed from recipes-core/classpath/classpath-0.98/ecj_java_dir.patch)0
-rw-r--r--recipes-core/classpath/classpath-0.99/fix-gmp.patch (renamed from recipes-core/classpath/classpath-0.98/fix-gmp.patch)0
-rw-r--r--recipes-core/classpath/classpath-0.99/miscompilation.patch (renamed from recipes-core/classpath/classpath-0.98/miscompilation.patch)0
-rw-r--r--recipes-core/classpath/classpath-0.99/sun-security-getproperty.patch (renamed from recipes-core/classpath/classpath-0.98/sun-security-getproperty.patch)72
-rw-r--r--recipes-core/classpath/classpath-0.99/toolwrapper-exithook.patch (renamed from recipes-core/classpath/classpath-0.98/toolwrapper-exithook.patch)0
-rw-r--r--recipes-core/classpath/classpath-initial-0.93/autotools.patch (renamed from recipes-core/classpath/files/autotools.patch)0
-rw-r--r--recipes-core/classpath/classpath-initial_0.93.bb3
-rw-r--r--recipes-core/classpath/classpath-native.inc12
-rw-r--r--recipes-core/classpath/classpath-native_0.99.bb (renamed from recipes-core/classpath/classpath-native_0.98.bb)21
-rw-r--r--recipes-core/classpath/classpath.inc6
-rw-r--r--recipes-core/classpath/classpath_0.98.bb15
-rw-r--r--recipes-core/classpath/classpath_0.99.bb14
15 files changed, 180 insertions, 184 deletions
diff --git a/recipes-core/classpath/classpath-0.98/SimpleName.diff b/recipes-core/classpath/classpath-0.98/SimpleName.diff
deleted file mode 100644
index ff2bec0..0000000
--- a/recipes-core/classpath/classpath-0.98/SimpleName.diff
+++ /dev/null
@@ -1,66 +0,0 @@
1Index: vm/reference/java/lang/VMClass.java
2===================================================================
3RCS file: /sources/classpath/classpath/vm/reference/java/lang/VMClass.java,v
4retrieving revision 1.20
5diff -u -r1.20 VMClass.java
6--- vm/reference/java/lang/VMClass.java 18 Sep 2007 21:52:38 -0000 1.20
7+++ vm/reference/java/lang/VMClass.java 19 Apr 2008 15:19:00 -0000
8@@ -296,27 +296,43 @@
9 */
10 static String getSimpleName(Class klass)
11 {
12+ int arrayCount = 0;
13+ while (klass.isArray())
14+ {
15+ klass = klass.getComponentType();
16+ ++arrayCount;
17+ }
18+ // now klass is the component type
19+
20+ String simpleComponentName = null;
21 if (isAnonymousClass(klass))
22- return "";
23- if (isArray(klass))
24 {
25- return getComponentType(klass).getSimpleName() + "[]";
26+ simpleComponentName = "";
27 }
28- String fullName = getName(klass);
29- int pos = fullName.lastIndexOf("$");
30- if (pos == -1)
31- pos = 0;
32 else
33 {
34- ++pos;
35- while (Character.isDigit(fullName.charAt(pos)))
36- ++pos;
37+ String fullName = getName(klass);
38+ int pos = fullName.lastIndexOf("$");
39+ if (pos != -1)
40+ { //inner class or local class
41+ // skip digits of local classes
42+ while (Character.isDigit(fullName.charAt(pos+1)))
43+ pos++;
44+ }
45+ else
46+ {
47+ pos = fullName.lastIndexOf(".");
48+ }
49+ simpleComponentName = fullName.substring(pos+1);
50 }
51- int packagePos = fullName.lastIndexOf(".", pos);
52- if (packagePos == -1)
53- return fullName.substring(pos);
54- else
55- return fullName.substring(packagePos + 1);
56+
57+ if (arrayCount == 0)
58+ return simpleComponentName;
59+
60+ StringBuffer sb = new StringBuffer(simpleComponentName);
61+ while (arrayCount-- > 0)
62+ sb.append("[]");
63+ return sb.toString();
64 }
65
66 /**
diff --git a/recipes-core/classpath/classpath-0.98/javanet-local.patch b/recipes-core/classpath/classpath-0.98/javanet-local.patch
deleted file mode 100644
index b8d1584..0000000
--- a/recipes-core/classpath/classpath-0.98/javanet-local.patch
+++ /dev/null
@@ -1,37 +0,0 @@
1Index: native/jni/java-net/local.c
2===================================================================
3RCS file: /sources/classpath/classpath/native/jni/java-net/local.c,v
4retrieving revision 1.4
5diff -u -r1.4 local.c
6--- native/jni/java-net/local.c 17 Apr 2007 21:46:27 -0000 1.4
7+++ native/jni/java-net/local.c 27 Jun 2008 13:14:40 -0000
8@@ -73,27 +73,18 @@
9 return socket (PF_UNIX, stream ? SOCK_STREAM : SOCK_DGRAM, 0);
10 }
11
12-static int gcc_sucks = 0;
13-
14 int
15 local_bind (int fd, const char *addr)
16 {
17 struct sockaddr_un saddr;
18
19- /* For some reason, GCC 4.0.1 on Darwin/x86 MODIFIES the `addr'
20- pointer in the CALLER's STACK FRAME after calling this function,
21- but if we add this statement below, it doesn't! */
22- if (gcc_sucks)
23- fprintf (stderr, "bind %p\n", addr);
24-
25- if (strlen (addr) > sizeof (saddr.sun_path))
26+ if (strlen (addr) >= sizeof (saddr.sun_path))
27 {
28 errno = ENAMETOOLONG;
29 return -1;
30 }
31
32- strncpy (saddr.sun_path, addr, sizeof (saddr.sun_path));
33- saddr.sun_path[sizeof (saddr.sun_path)] = '\0';
34+ strcpy (saddr.sun_path, addr);
35 saddr.sun_family = AF_LOCAL;
36
37 return bind (fd, (struct sockaddr *) &saddr, SUN_LEN (&saddr));
diff --git a/recipes-core/classpath/classpath-0.99/autotools.patch b/recipes-core/classpath/classpath-0.99/autotools.patch
new file mode 100644
index 0000000..6a077a0
--- /dev/null
+++ b/recipes-core/classpath/classpath-0.99/autotools.patch
@@ -0,0 +1,118 @@
1Index: classpath-0.99/configure.ac
2===================================================================
3--- classpath-0.99.orig/configure.ac 2012-03-08 19:03:15.000000000 +0100
4+++ classpath-0.99/configure.ac 2012-07-18 23:16:41.047796558 +0200
5@@ -42,6 +42,9 @@
6 AC_CONFIG_HEADERS([include/config.h])
7 AC_PREFIX_DEFAULT(/usr/local/classpath)
8
9+AC_PROG_MKDIR_P
10+AM_ICONV_LINK
11+
12 dnl -----------------------------------------------------------
13 dnl Enable collections.jar (disabled by default)
14 dnl -----------------------------------------------------------
15@@ -382,6 +385,7 @@
16 AC_PROG_CC
17 AM_PROG_CC_C_O
18 AC_PROG_CPP
19+AM_PROG_CC_C_O
20
21 # Handle -Werror default case.
22 if test "$ENABLE_WERROR" = default; then
23Index: classpath-0.99/examples/Makefile.am
24===================================================================
25--- classpath-0.99.orig/examples/Makefile.am 2008-09-14 18:49:43.000000000 +0200
26+++ classpath-0.99/examples/Makefile.am 2012-07-18 23:17:58.604498498 +0200
27@@ -96,9 +96,9 @@
28 endif
29
30 $(EXAMPLE_ZIP): $(EXAMPLE_JAVA_FILES)
31- @mkdir_p@ classes/gnu/classpath/examples/icons
32+ $(MKDIR_P) classes/gnu/classpath/examples/icons
33 cp $(EXAMPLE_ICONS) classes/gnu/classpath/examples/icons
34- @mkdir_p@ classes/gnu/classpath/examples/swing
35+ $(MKDIR_P) classes/gnu/classpath/examples/swing
36 cp $(EXAMPLE_HTML) classes/gnu/classpath/examples/swing
37 $(JCOMPILER) -d classes $(EXAMPLE_JAVA_FILES)
38 (cd classes; \
39Index: classpath-0.99/lib/Makefile.am
40===================================================================
41--- classpath-0.99.orig/lib/Makefile.am 2011-05-29 11:07:06.000000000 +0200
42+++ classpath-0.99/lib/Makefile.am 2012-07-18 23:18:55.769018757 +0200
43@@ -83,18 +83,18 @@
44 resources: copy-vmresources.sh
45 @list=`cd $(top_srcdir)/resource && $(FIND) gnu java javax org -name \*\.properties -print -o -name \*\.css -print`; for p in $$list; do \
46 dirname=`dirname $$p`; \
47- if ! test -d "$$dirname"; then @mkdir_p@ "$$dirname"; fi; \
48+ if ! test -d "$$dirname"; then $(MKDIR_P) "$$dirname"; fi; \
49 cp $(top_srcdir)/resource/$$p $$p; \
50 done
51 @list=`cd $(top_srcdir)/resource && $(FIND) META-INF -name CVS -prune -o -name .svn -prune -o -name \*\.in -prune -o -type f -print`; for p in $$list; do \
52 dirname=`dirname $$p`; \
53- if ! test -d "$$dirname"; then @mkdir_p@ "$$dirname"; fi; \
54+ if ! test -d "$$dirname"; then $(MKDIR_P) "$$dirname"; fi; \
55 cp $(top_srcdir)/resource/$$p $$p; \
56 done
57 @$(SHELL) ./copy-vmresources.sh
58 @list=`cd $(top_srcdir) && $(FIND) gnu/javax/swing/plaf/gtk/icons -name *.png -type f -print`; for p in $$list; do \
59 dirname=`dirname $$p`; \
60- if ! test -d "$$dirname"; then @mkdir_p@ "$$dirname"; fi; \
61+ if ! test -d "$$dirname"; then $(MKDIR_P) "$$dirname"; fi; \
62 cp $(top_srcdir)/$$p $$p; \
63 done
64 touch resources
65@@ -102,7 +102,7 @@
66 classes: genclasses
67
68 $(top_builddir)/gnu/java/locale/LocaleData.java: $(top_srcdir)/scripts/generate-locale-list.sh
69- @mkdir_p@ $(top_builddir)/gnu/java/locale
70+ $(MKDIR_P) $(top_builddir)/gnu/java/locale
71 $(top_srcdir)/scripts/generate-locale-list.sh > $(top_builddir)/gnu/java/locale/LocaleData.java
72
73 genclasses: gen-classlist.sh standard.omit $(top_builddir)/gnu/java/locale/LocaleData.java gen-xpath-parser
74@@ -160,7 +160,7 @@
75 -rm -rf lists
76
77 dist-hook:
78- @mkdir_p@ $(distdir)
79+ $(MKDIR_P) $(distdir)
80 cp -pdfR $(top_srcdir)/gnu $(top_srcdir)/java $(top_srcdir)/javax $(top_srcdir)/org $(top_srcdir)/sun $(top_srcdir)/vm $(top_srcdir)/resource $(distdir)/..
81 # Delete not wanted files.
82 $(FIND) $(distdir)/../gnu $(distdir)/../java $(distdir)/../javax $(distdir)/../org $(distdir)/../sun $(distdir)/../vm $(distdir)/../resource -name CVS -print | xargs rm -fr
83Index: classpath-0.99/tools/Makefile.am
84===================================================================
85--- classpath-0.99.orig/tools/Makefile.am 2012-07-18 23:13:23.782018215 +0200
86+++ classpath-0.99/tools/Makefile.am 2012-07-18 23:20:02.701629749 +0200
87@@ -314,11 +314,11 @@
88 # so they get also included.
89 $(TOOLS_ZIP): $(ALL_TOOLS_FILES)
90 @rm -rf classes asm
91- @mkdir_p@ classes asm
92+ $(MKDIR_P) classes asm
93 if CREATE_GJDOC
94 if CREATE_GJDOC_PARSER
95 ## Generate antlr sources.
96- @mkdir_p@ $(gjdoc_gendir)/gnu/classpath/tools/gjdoc/expr
97+ $(MKDIR_P) $(gjdoc_gendir)/gnu/classpath/tools/gjdoc/expr
98 $(ANTLR) -o $(gjdoc_gendir)/gnu/classpath/tools/gjdoc/expr/ \
99 $(srcdir)/gnu/classpath/tools/gjdoc/expr/java-expression.g
100 endif
101@@ -348,7 +348,7 @@
102 sun/rmi/rmic $(GJDOC_EX) -name \*.properties -print -o -name \*.jav -print`; \
103 for p in $$list; do \
104 dirname=classes/`dirname $$p`; \
105- if ! test -d "$$dirname"; then @mkdir_p@ "$$dirname"; fi; \
106+ if ! test -d "$$dirname"; then $(MKDIR_P) "$$dirname"; fi; \
107 echo " cp $(srcdir)/resource/$$p classes/$$p"; \
108 cp $(srcdir)/resource/$$p classes/$$p; \
109 done
110@@ -356,7 +356,7 @@
111 ## Copy over gjdoc resource files.
112 for res in $(gjdoc_resources); do \
113 dir=classes/`dirname $$res`; \
114- if ! test -d "$$dir"; then @mkdir_p@ "$$dir"; fi; \
115+ if ! test -d "$$dir"; then $(MKDIR_P) "$$dir"; fi; \
116 echo " cp $(srcdir)/resource/gnu/classpath/tools/gjdoc/$$res classes/$$res"; \
117 cp $(srcdir)/resource/gnu/classpath/tools/gjdoc/$$res classes/$$res; \
118 done
diff --git a/recipes-core/classpath/classpath-0.98/ecj_java_dir.patch b/recipes-core/classpath/classpath-0.99/ecj_java_dir.patch
index 1455a24..1455a24 100644
--- a/recipes-core/classpath/classpath-0.98/ecj_java_dir.patch
+++ b/recipes-core/classpath/classpath-0.99/ecj_java_dir.patch
diff --git a/recipes-core/classpath/classpath-0.98/fix-gmp.patch b/recipes-core/classpath/classpath-0.99/fix-gmp.patch
index 3f0dfbe..3f0dfbe 100644
--- a/recipes-core/classpath/classpath-0.98/fix-gmp.patch
+++ b/recipes-core/classpath/classpath-0.99/fix-gmp.patch
diff --git a/recipes-core/classpath/classpath-0.98/miscompilation.patch b/recipes-core/classpath/classpath-0.99/miscompilation.patch
index c61b214..c61b214 100644
--- a/recipes-core/classpath/classpath-0.98/miscompilation.patch
+++ b/recipes-core/classpath/classpath-0.99/miscompilation.patch
diff --git a/recipes-core/classpath/classpath-0.98/sun-security-getproperty.patch b/recipes-core/classpath/classpath-0.99/sun-security-getproperty.patch
index fb9cd9d..4ec8b1e 100644
--- a/recipes-core/classpath/classpath-0.98/sun-security-getproperty.patch
+++ b/recipes-core/classpath/classpath-0.99/sun-security-getproperty.patch
@@ -1,7 +1,7 @@
1Index: gnu/classpath/debug/Simple1LineFormatter.java 1Index: gnu/classpath/debug/Simple1LineFormatter.java
2=================================================================== 2===================================================================
3--- gnu/classpath/debug/Simple1LineFormatter.java.orig 2006-07-11 18:03:59.000000000 +0200 3--- gnu/classpath/debug/Simple1LineFormatter.java.orig 2006-07-11 18:03:59.000000000 +0200
4+++ gnu/classpath/debug/Simple1LineFormatter.java 2009-03-19 19:00:47.000000000 +0100 4+++ gnu/classpath/debug/Simple1LineFormatter.java 2012-07-18 23:08:46.803554178 +0200
5@@ -38,8 +38,6 @@ 5@@ -38,8 +38,6 @@
6 6
7 package gnu.classpath.debug; 7 package gnu.classpath.debug;
@@ -22,8 +22,8 @@ Index: gnu/classpath/debug/Simple1LineFormatter.java
22 * by default in the JDK logging handlers. 22 * by default in the JDK logging handlers.
23Index: gnu/classpath/debug/SystemLogger.java 23Index: gnu/classpath/debug/SystemLogger.java
24=================================================================== 24===================================================================
25--- gnu/classpath/debug/SystemLogger.java.orig 2006-12-10 21:25:41.000000000 +0100 25--- gnu/classpath/debug/SystemLogger.java.orig 2010-06-03 21:11:20.000000000 +0200
26+++ gnu/classpath/debug/SystemLogger.java 2009-03-19 19:00:47.000000000 +0100 26+++ gnu/classpath/debug/SystemLogger.java 2012-07-18 23:08:46.803554178 +0200
27@@ -38,13 +38,13 @@ 27@@ -38,13 +38,13 @@
28 28
29 package gnu.classpath.debug; 29 package gnu.classpath.debug;
@@ -42,8 +42,8 @@ Index: gnu/classpath/debug/SystemLogger.java
42 public static final SystemLogger SYSTEM = new SystemLogger(); 42 public static final SystemLogger SYSTEM = new SystemLogger();
43Index: gnu/java/security/PolicyFile.java 43Index: gnu/java/security/PolicyFile.java
44=================================================================== 44===================================================================
45--- gnu/java/security/PolicyFile.java.orig 2008-06-16 00:07:30.000000000 +0200 45--- gnu/java/security/PolicyFile.java.orig 2010-06-03 21:11:53.000000000 +0200
46+++ gnu/java/security/PolicyFile.java 2009-03-19 19:01:31.000000000 +0100 46+++ gnu/java/security/PolicyFile.java 2012-07-18 23:08:46.803554178 +0200
47@@ -41,7 +41,6 @@ 47@@ -41,7 +41,6 @@
48 import gnu.classpath.debug.SystemLogger; 48 import gnu.classpath.debug.SystemLogger;
49 49
@@ -63,7 +63,7 @@ Index: gnu/java/security/PolicyFile.java
63 * permissions are specified by a <em>policy file</em>. 63 * permissions are specified by a <em>policy file</em>.
64Index: gnu/java/security/action/GetPropertyAction.java 64Index: gnu/java/security/action/GetPropertyAction.java
65=================================================================== 65===================================================================
66--- gnu/java/security/action/GetPropertyAction.java 2006-12-10 21:25:42.000000000 +0100 66--- gnu/java/security/action/GetPropertyAction.java 2010-06-03 21:11:54.000000000 +0200
67+++ /dev/null 1970-01-01 00:00:00.000000000 +0000 67+++ /dev/null 1970-01-01 00:00:00.000000000 +0000
68@@ -1,89 +0,0 @@ 68@@ -1,89 +0,0 @@
69-/* GetPropertyAction.java 69-/* GetPropertyAction.java
@@ -125,7 +125,7 @@ Index: gnu/java/security/action/GetPropertyAction.java
125- public GetPropertyAction() 125- public GetPropertyAction()
126- { 126- {
127- } 127- }
128- 128-
129- public GetPropertyAction(String propName) 129- public GetPropertyAction(String propName)
130- { 130- {
131- setParameters(propName); 131- setParameters(propName);
@@ -135,12 +135,12 @@ Index: gnu/java/security/action/GetPropertyAction.java
135- { 135- {
136- setParameters(propName, defaultValue); 136- setParameters(propName, defaultValue);
137- } 137- }
138- 138-
139- public String run() 139- public String run()
140- { 140- {
141- return System.getProperty(name, value); 141- return System.getProperty(name, value);
142- } 142- }
143- 143-
144- public GetPropertyAction setParameters(String propName) 144- public GetPropertyAction setParameters(String propName)
145- { 145- {
146- this.name = propName; 146- this.name = propName;
@@ -157,8 +157,8 @@ Index: gnu/java/security/action/GetPropertyAction.java
157-} 157-}
158Index: gnu/java/security/key/dss/DSSKey.java 158Index: gnu/java/security/key/dss/DSSKey.java
159=================================================================== 159===================================================================
160--- gnu/java/security/key/dss/DSSKey.java.orig 2008-03-16 23:04:49.000000000 +0100 160--- gnu/java/security/key/dss/DSSKey.java.orig 2010-06-03 21:11:56.000000000 +0200
161+++ gnu/java/security/key/dss/DSSKey.java 2009-03-19 19:00:47.000000000 +0100 161+++ gnu/java/security/key/dss/DSSKey.java 2012-07-18 23:08:46.803554178 +0200
162@@ -41,7 +41,6 @@ 162@@ -41,7 +41,6 @@
163 import gnu.java.lang.CPStringBuilder; 163 import gnu.java.lang.CPStringBuilder;
164 164
@@ -178,8 +178,8 @@ Index: gnu/java/security/key/dss/DSSKey.java
178 * Standard) keys. It encapsulates the three DSS numbers: <code>p</code>, 178 * Standard) keys. It encapsulates the three DSS numbers: <code>p</code>,
179Index: gnu/java/security/key/dss/DSSPrivateKey.java 179Index: gnu/java/security/key/dss/DSSPrivateKey.java
180=================================================================== 180===================================================================
181--- gnu/java/security/key/dss/DSSPrivateKey.java.orig 2008-03-16 23:04:49.000000000 +0100 181--- gnu/java/security/key/dss/DSSPrivateKey.java.orig 2010-06-03 21:11:56.000000000 +0200
182+++ gnu/java/security/key/dss/DSSPrivateKey.java 2009-03-19 19:00:47.000000000 +0100 182+++ gnu/java/security/key/dss/DSSPrivateKey.java 2012-07-18 23:08:46.803554178 +0200
183@@ -42,7 +42,6 @@ 183@@ -42,7 +42,6 @@
184 184
185 import gnu.java.security.Configuration; 185 import gnu.java.security.Configuration;
@@ -196,11 +196,11 @@ Index: gnu/java/security/key/dss/DSSPrivateKey.java
196+ 196+
197 /** 197 /**
198 * An object that embodies a DSS (Digital Signature Standard) private key. 198 * An object that embodies a DSS (Digital Signature Standard) private key.
199 * 199 *
200Index: gnu/java/security/key/dss/DSSPublicKey.java 200Index: gnu/java/security/key/dss/DSSPublicKey.java
201=================================================================== 201===================================================================
202--- gnu/java/security/key/dss/DSSPublicKey.java.orig 2008-03-16 23:04:49.000000000 +0100 202--- gnu/java/security/key/dss/DSSPublicKey.java.orig 2010-06-03 21:11:56.000000000 +0200
203+++ gnu/java/security/key/dss/DSSPublicKey.java 2009-03-19 19:00:47.000000000 +0100 203+++ gnu/java/security/key/dss/DSSPublicKey.java 2012-07-18 23:08:46.803554178 +0200
204@@ -41,7 +41,6 @@ 204@@ -41,7 +41,6 @@
205 import gnu.java.lang.CPStringBuilder; 205 import gnu.java.lang.CPStringBuilder;
206 206
@@ -217,11 +217,11 @@ Index: gnu/java/security/key/dss/DSSPublicKey.java
217+ 217+
218 /** 218 /**
219 * An object that embodies a DSS (Digital Signature Standard) public key. 219 * An object that embodies a DSS (Digital Signature Standard) public key.
220 * 220 *
221Index: gnu/java/security/key/rsa/GnuRSAKey.java 221Index: gnu/java/security/key/rsa/GnuRSAKey.java
222=================================================================== 222===================================================================
223--- gnu/java/security/key/rsa/GnuRSAKey.java.orig 2008-03-16 23:04:49.000000000 +0100 223--- gnu/java/security/key/rsa/GnuRSAKey.java.orig 2010-06-03 21:11:56.000000000 +0200
224+++ gnu/java/security/key/rsa/GnuRSAKey.java 2009-03-19 19:00:47.000000000 +0100 224+++ gnu/java/security/key/rsa/GnuRSAKey.java 2012-07-18 23:08:46.803554178 +0200
225@@ -41,7 +41,6 @@ 225@@ -41,7 +41,6 @@
226 import gnu.java.lang.CPStringBuilder; 226 import gnu.java.lang.CPStringBuilder;
227 227
@@ -241,8 +241,8 @@ Index: gnu/java/security/key/rsa/GnuRSAKey.java
241 */ 241 */
242Index: gnu/java/security/key/rsa/GnuRSAPrivateKey.java 242Index: gnu/java/security/key/rsa/GnuRSAPrivateKey.java
243=================================================================== 243===================================================================
244--- gnu/java/security/key/rsa/GnuRSAPrivateKey.java.orig 2008-03-16 23:04:50.000000000 +0100 244--- gnu/java/security/key/rsa/GnuRSAPrivateKey.java.orig 2010-06-03 21:11:56.000000000 +0200
245+++ gnu/java/security/key/rsa/GnuRSAPrivateKey.java 2009-03-19 19:00:47.000000000 +0100 245+++ gnu/java/security/key/rsa/GnuRSAPrivateKey.java 2012-07-18 23:08:46.803554178 +0200
246@@ -41,7 +41,6 @@ 246@@ -41,7 +41,6 @@
247 import gnu.java.lang.CPStringBuilder; 247 import gnu.java.lang.CPStringBuilder;
248 248
@@ -262,8 +262,8 @@ Index: gnu/java/security/key/rsa/GnuRSAPrivateKey.java
262 * <p> 262 * <p>
263Index: gnu/java/security/key/rsa/GnuRSAPublicKey.java 263Index: gnu/java/security/key/rsa/GnuRSAPublicKey.java
264=================================================================== 264===================================================================
265--- gnu/java/security/key/rsa/GnuRSAPublicKey.java.orig 2008-03-16 23:04:50.000000000 +0100 265--- gnu/java/security/key/rsa/GnuRSAPublicKey.java.orig 2010-06-03 21:11:56.000000000 +0200
266+++ gnu/java/security/key/rsa/GnuRSAPublicKey.java 2009-03-19 19:00:47.000000000 +0100 266+++ gnu/java/security/key/rsa/GnuRSAPublicKey.java 2012-07-18 23:08:46.803554178 +0200
267@@ -41,7 +41,6 @@ 267@@ -41,7 +41,6 @@
268 import gnu.java.lang.CPStringBuilder; 268 import gnu.java.lang.CPStringBuilder;
269 269
@@ -283,8 +283,8 @@ Index: gnu/java/security/key/rsa/GnuRSAPublicKey.java
283 * <p> 283 * <p>
284Index: gnu/javax/crypto/key/dh/GnuDHKey.java 284Index: gnu/javax/crypto/key/dh/GnuDHKey.java
285=================================================================== 285===================================================================
286--- gnu/javax/crypto/key/dh/GnuDHKey.java.orig 2006-07-11 18:03:59.000000000 +0200 286--- gnu/javax/crypto/key/dh/GnuDHKey.java.orig 2010-06-03 21:12:05.000000000 +0200
287+++ gnu/javax/crypto/key/dh/GnuDHKey.java 2009-03-19 19:00:47.000000000 +0100 287+++ gnu/javax/crypto/key/dh/GnuDHKey.java 2012-07-18 23:08:46.803554178 +0200
288@@ -39,7 +39,6 @@ 288@@ -39,7 +39,6 @@
289 package gnu.javax.crypto.key.dh; 289 package gnu.javax.crypto.key.dh;
290 290
@@ -304,8 +304,8 @@ Index: gnu/javax/crypto/key/dh/GnuDHKey.java
304 * encapsulates the two DH numbers: <code>p</code>, and <code>g</code>. 304 * encapsulates the two DH numbers: <code>p</code>, and <code>g</code>.
305Index: gnu/javax/crypto/key/dh/GnuDHPrivateKey.java 305Index: gnu/javax/crypto/key/dh/GnuDHPrivateKey.java
306=================================================================== 306===================================================================
307--- gnu/javax/crypto/key/dh/GnuDHPrivateKey.java.orig 2006-07-11 18:03:59.000000000 +0200 307--- gnu/javax/crypto/key/dh/GnuDHPrivateKey.java.orig 2010-06-03 21:12:05.000000000 +0200
308+++ gnu/javax/crypto/key/dh/GnuDHPrivateKey.java 2009-03-19 19:00:47.000000000 +0100 308+++ gnu/javax/crypto/key/dh/GnuDHPrivateKey.java 2012-07-18 23:08:46.803554178 +0200
309@@ -40,7 +40,6 @@ 309@@ -40,7 +40,6 @@
310 310
311 import gnu.java.security.Configuration; 311 import gnu.java.security.Configuration;
@@ -325,8 +325,8 @@ Index: gnu/javax/crypto/key/dh/GnuDHPrivateKey.java
325 * <p> 325 * <p>
326Index: gnu/javax/crypto/key/dh/GnuDHPublicKey.java 326Index: gnu/javax/crypto/key/dh/GnuDHPublicKey.java
327=================================================================== 327===================================================================
328--- gnu/javax/crypto/key/dh/GnuDHPublicKey.java.orig 2006-07-11 18:03:59.000000000 +0200 328--- gnu/javax/crypto/key/dh/GnuDHPublicKey.java.orig 2010-06-03 21:12:05.000000000 +0200
329+++ gnu/javax/crypto/key/dh/GnuDHPublicKey.java 2009-03-19 19:00:47.000000000 +0100 329+++ gnu/javax/crypto/key/dh/GnuDHPublicKey.java 2012-07-18 23:08:46.803554178 +0200
330@@ -39,7 +39,6 @@ 330@@ -39,7 +39,6 @@
331 package gnu.javax.crypto.key.dh; 331 package gnu.javax.crypto.key.dh;
332 332
@@ -346,8 +346,8 @@ Index: gnu/javax/crypto/key/dh/GnuDHPublicKey.java
346 * <p> 346 * <p>
347Index: gnu/javax/crypto/sasl/plain/PasswordFile.java 347Index: gnu/javax/crypto/sasl/plain/PasswordFile.java
348=================================================================== 348===================================================================
349--- gnu/javax/crypto/sasl/plain/PasswordFile.java.orig 2008-05-05 23:29:46.000000000 +0200 349--- gnu/javax/crypto/sasl/plain/PasswordFile.java.orig 2010-06-03 21:12:10.000000000 +0200
350+++ gnu/javax/crypto/sasl/plain/PasswordFile.java 2009-03-19 19:00:47.000000000 +0100 350+++ gnu/javax/crypto/sasl/plain/PasswordFile.java 2012-07-18 23:08:46.803554178 +0200
351@@ -40,7 +40,6 @@ 351@@ -40,7 +40,6 @@
352 352
353 import gnu.java.lang.CPStringBuilder; 353 import gnu.java.lang.CPStringBuilder;
@@ -367,8 +367,8 @@ Index: gnu/javax/crypto/sasl/plain/PasswordFile.java
367 */ 367 */
368Index: gnu/javax/net/ssl/provider/X509TrustManagerFactory.java 368Index: gnu/javax/net/ssl/provider/X509TrustManagerFactory.java
369=================================================================== 369===================================================================
370--- gnu/javax/net/ssl/provider/X509TrustManagerFactory.java.orig 2006-12-10 21:25:43.000000000 +0100 370--- gnu/javax/net/ssl/provider/X509TrustManagerFactory.java.orig 2010-06-03 21:12:17.000000000 +0200
371+++ gnu/javax/net/ssl/provider/X509TrustManagerFactory.java 2009-03-19 19:00:47.000000000 +0100 371+++ gnu/javax/net/ssl/provider/X509TrustManagerFactory.java 2012-07-18 23:08:46.803554178 +0200
372@@ -66,11 +66,12 @@ 372@@ -66,11 +66,12 @@
373 import javax.net.ssl.TrustManagerFactorySpi; 373 import javax.net.ssl.TrustManagerFactorySpi;
374 import javax.net.ssl.X509TrustManager; 374 import javax.net.ssl.X509TrustManager;
@@ -385,8 +385,8 @@ Index: gnu/javax/net/ssl/provider/X509TrustManagerFactory.java
385 * for the ``JessieX509'' algorithm. 385 * for the ``JessieX509'' algorithm.
386Index: gnu/xml/aelfred2/XmlParser.java 386Index: gnu/xml/aelfred2/XmlParser.java
387=================================================================== 387===================================================================
388--- gnu/xml/aelfred2/XmlParser.java.orig 2008-01-11 22:22:59.000000000 +0100 388--- gnu/xml/aelfred2/XmlParser.java.orig 2010-06-03 21:12:21.000000000 +0200
389+++ gnu/xml/aelfred2/XmlParser.java 2009-03-19 19:00:47.000000000 +0100 389+++ gnu/xml/aelfred2/XmlParser.java 2012-07-18 23:08:46.807554239 +0200
390@@ -53,8 +53,6 @@ 390@@ -53,8 +53,6 @@
391 391
392 package gnu.xml.aelfred2; 392 package gnu.xml.aelfred2;
@@ -407,7 +407,7 @@ Index: gnu/xml/aelfred2/XmlParser.java
407Index: sun/security/action/GetPropertyAction.java 407Index: sun/security/action/GetPropertyAction.java
408=================================================================== 408===================================================================
409--- /dev/null 1970-01-01 00:00:00.000000000 +0000 409--- /dev/null 1970-01-01 00:00:00.000000000 +0000
410+++ sun/security/action/GetPropertyAction.java 2009-03-19 19:00:47.000000000 +0100 410+++ sun/security/action/GetPropertyAction.java 2012-07-18 23:08:46.807554239 +0200
411@@ -0,0 +1,92 @@ 411@@ -0,0 +1,92 @@
412+/* GetPropertyAction.java 412+/* GetPropertyAction.java
413+ Copyright (C) 2004, 2008 Free Software Foundation, Inc. 413+ Copyright (C) 2004, 2008 Free Software Foundation, Inc.
diff --git a/recipes-core/classpath/classpath-0.98/toolwrapper-exithook.patch b/recipes-core/classpath/classpath-0.99/toolwrapper-exithook.patch
index 49b6631..49b6631 100644
--- a/recipes-core/classpath/classpath-0.98/toolwrapper-exithook.patch
+++ b/recipes-core/classpath/classpath-0.99/toolwrapper-exithook.patch
diff --git a/recipes-core/classpath/files/autotools.patch b/recipes-core/classpath/classpath-initial-0.93/autotools.patch
index 663c034..663c034 100644
--- a/recipes-core/classpath/files/autotools.patch
+++ b/recipes-core/classpath/classpath-initial-0.93/autotools.patch
diff --git a/recipes-core/classpath/classpath-initial_0.93.bb b/recipes-core/classpath/classpath-initial_0.93.bb
index 13ede10..7c2683c 100644
--- a/recipes-core/classpath/classpath-initial_0.93.bb
+++ b/recipes-core/classpath/classpath-initial_0.93.bb
@@ -5,8 +5,9 @@ require classpath-native.inc
5 5
6DESCRIPTION="Java1.4-compatible GNU Classpath variant that is used as bootclasspath for jikes-native." 6DESCRIPTION="Java1.4-compatible GNU Classpath variant that is used as bootclasspath for jikes-native."
7LIC_FILES_CHKSUM = "file://COPYING;md5=af0004801732bc4b20d90f351cf80510" 7LIC_FILES_CHKSUM = "file://COPYING;md5=af0004801732bc4b20d90f351cf80510"
8DEPENDS += "jikes-native"
8 9
9DEPENDS = "zip-native fastjar-native jikes-native gettext-native" 10PR = "${INC_PR}.0"
10 11
11SRC_URI += " \ 12SRC_URI += " \
12 file://autotools.patch \ 13 file://autotools.patch \
diff --git a/recipes-core/classpath/classpath-native.inc b/recipes-core/classpath/classpath-native.inc
index 16c1498..541c243 100644
--- a/recipes-core/classpath/classpath-native.inc
+++ b/recipes-core/classpath/classpath-native.inc
@@ -2,18 +2,13 @@ DESCRIPTION = "GNU Classpath standard Java libraries - For native Java-dependent
2HOMEPAGE = "http://www.gnu.org/software/classpath/" 2HOMEPAGE = "http://www.gnu.org/software/classpath/"
3LICENSE = "Classpath" 3LICENSE = "Classpath"
4 4
5DEPENDS = "ecj-initial fastjar-native zip-native gettext-native" 5DEPENDS = "fastjar-native zip-native"
6 6
7PR = "r1" 7inherit autotools native gettext
8
9inherit autotools native
10 8
11SRC_URI = "${GNU_MIRROR}/classpath/classpath-${PV}.tar.gz" 9SRC_URI = "${GNU_MIRROR}/classpath/classpath-${PV}.tar.gz"
12 10
13do_configure_prepend () { 11INC_PR = "r5"
14
15 cp ${STAGING_DATADIR_NATIVE}/gettext/config.rpath ${S}
16}
17 12
18export JAVA="${STAGING_BINDIR_NATIVE}/java-initial" 13export JAVA="${STAGING_BINDIR_NATIVE}/java-initial"
19export JAVAC="${STAGING_BINDIR_NATIVE}/ecj-initial" 14export JAVAC="${STAGING_BINDIR_NATIVE}/ecj-initial"
@@ -33,4 +28,3 @@ EXTRA_OECONF = " \
33 --enable-tools \ 28 --enable-tools \
34 --includedir=${STAGING_INCDIR}/classpath \ 29 --includedir=${STAGING_INCDIR}/classpath \
35 " 30 "
36
diff --git a/recipes-core/classpath/classpath-native_0.98.bb b/recipes-core/classpath/classpath-native_0.99.bb
index 32c3fb3..ece10c3 100644
--- a/recipes-core/classpath/classpath-native_0.98.bb
+++ b/recipes-core/classpath/classpath-native_0.99.bb
@@ -1,11 +1,11 @@
1require classpath-native.inc 1require classpath-native.inc
2 2
3LIC_FILES_CHKSUM = "file://COPYING;md5=af0004801732bc4b20d90f351cf80510" 3LIC_FILES_CHKSUM = "file://COPYING;md5=af0004801732bc4b20d90f351cf80510"
4DEPENDS += "ecj-initial"
4 5
5PR = "r1" 6PR = "${INC_PR}.0"
6 7
7SRC_URI += " \ 8SRC_URI += " \
8 file://SimpleName.diff;striplevel=0 \
9 file://sun-security-getproperty.patch;striplevel=0 \ 9 file://sun-security-getproperty.patch;striplevel=0 \
10 file://ecj_java_dir.patch \ 10 file://ecj_java_dir.patch \
11 file://autotools.patch \ 11 file://autotools.patch \
@@ -13,19 +13,6 @@ SRC_URI += " \
13 file://toolwrapper-exithook.patch \ 13 file://toolwrapper-exithook.patch \
14 " 14 "
15 15
16do_unpackpost() {
17 # Kind of patch: Moves package "org.w3c.dom.html2" to "org.w3c.dom.html"
18 mv external/w3c_dom/org/w3c/dom/html2 \
19 external/w3c_dom/org/w3c/dom/html
20
21 find examples/gnu/classpath/examples/html gnu/xml/dom/html2 external/w3c_dom/org/w3c/dom/html -name "*.java" \
22 -exec sed -i -e"s|org.w3c.dom.html2|org.w3c.dom.html|" {} \;
23
24 sed -i -e"s|org/w3c/dom/html2|org/w3c/dom/html|" external/w3c_dom/Makefile.am
25}
26
27addtask unpackpost after do_unpack before do_patch
28
29# tools using java-initial rather than java sed it out 16# tools using java-initial rather than java sed it out
30do_compile_append () { 17do_compile_append () {
31 18
@@ -40,6 +27,6 @@ do_compile_append () {
40 done 27 done
41} 28}
42 29
43SRC_URI[md5sum] = "90c6571b8b0309e372faa0f9f6255ea9" 30SRC_URI[md5sum] = "0ae1571249172acd82488724a3b8acb4"
44SRC_URI[sha256sum] = "501b5acd4dff79b6100da22cef15080f31071821ce3cea6f1b739bc1b56fac3f" 31SRC_URI[sha256sum] = "f929297f8ae9b613a1a167e231566861893260651d913ad9b6c11933895fecc8"
45 32
diff --git a/recipes-core/classpath/classpath.inc b/recipes-core/classpath/classpath.inc
index 55a3f6c..4c3174b 100644
--- a/recipes-core/classpath/classpath.inc
+++ b/recipes-core/classpath/classpath.inc
@@ -7,9 +7,9 @@ LICENSE = "Classpath"
7 7
8PBN = "classpath" 8PBN = "classpath"
9 9
10inherit autotools java 10inherit autotools java gettext
11 11
12DEPENDS = "virtual/javac-native fastjar-native zip-native gettext-native gmp antlr-native gtk+ gconf libxtst" 12DEPENDS = "virtual/javac-native fastjar-native zip-native gmp antlr-native gtk+ gconf libxtst"
13 13
14RPROVIDES_${PN} = "" 14RPROVIDES_${PN} = ""
15 15
@@ -21,7 +21,7 @@ RPROVIDES_${PN} = "${PBN}"
21RPROVIDES_${PN}-common = "${PBN}-common" 21RPROVIDES_${PN}-common = "${PBN}-common"
22RPROVIDES_${PN}-gtk = "${PBN}-awt" 22RPROVIDES_${PN}-gtk = "${PBN}-awt"
23 23
24PR = "r1" 24PR = "r0"
25 25
26SRC_URI = "${GNU_MIRROR}/classpath/classpath-${PV}.tar.gz" 26SRC_URI = "${GNU_MIRROR}/classpath/classpath-${PV}.tar.gz"
27 27
diff --git a/recipes-core/classpath/classpath_0.98.bb b/recipes-core/classpath/classpath_0.98.bb
deleted file mode 100644
index d822452..0000000
--- a/recipes-core/classpath/classpath_0.98.bb
+++ /dev/null
@@ -1,15 +0,0 @@
1require classpath.inc
2
3LIC_FILES_CHKSUM = "file://LICENSE;md5=92acc79f1f429143f4624d07b253702a"
4
5SRC_URI += " \
6 file://SimpleName.diff;striplevel=0 \
7 file://ecj_java_dir.patch \
8 file://autotools.patch \
9 file://fix-gmp.patch \
10 file://toolwrapper-exithook.patch \
11 "
12
13SRC_URI[md5sum] = "90c6571b8b0309e372faa0f9f6255ea9"
14SRC_URI[sha256sum] = "501b5acd4dff79b6100da22cef15080f31071821ce3cea6f1b739bc1b56fac3f"
15
diff --git a/recipes-core/classpath/classpath_0.99.bb b/recipes-core/classpath/classpath_0.99.bb
new file mode 100644
index 0000000..72c9c24
--- /dev/null
+++ b/recipes-core/classpath/classpath_0.99.bb
@@ -0,0 +1,14 @@
1require classpath.inc
2
3LIC_FILES_CHKSUM = "file://LICENSE;md5=af0004801732bc4b20d90f351cf80510"
4
5SRC_URI += " \
6 file://sun-security-getproperty.patch;striplevel=0 \
7 file://ecj_java_dir.patch \
8 file://autotools.patch \
9 file://miscompilation.patch \
10 file://toolwrapper-exithook.patch \
11 "
12
13SRC_URI[md5sum] = "0ae1571249172acd82488724a3b8acb4"
14SRC_URI[sha256sum] = "f929297f8ae9b613a1a167e231566861893260651d913ad9b6c11933895fecc8"