summaryrefslogtreecommitdiffstats
path: root/recipes-core/classpath
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2012-04-04 05:20:56 +0000
committerOtavio Salvador <otavio@ossystems.com.br>2012-04-04 05:24:16 +0000
commit2538fdffd3f5728b788ede09e2b0b576ad362ce2 (patch)
tree0ba10d8ab1621de5dcffaa0906be47d7af28011a /recipes-core/classpath
parente90110b85733f9cdda26861bc29588257173c11c (diff)
downloadmeta-java-2538fdffd3f5728b788ede09e2b0b576ad362ce2.tar.gz
classpath-initial: fix installation of tools.zip file
This fixes an unpredicability of sysroot tools.zip version as classpath-initial and classpath-native were installing the tools.zip at same path. We also bump PR of affected recipes to force them to rebuild. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-core/classpath')
-rw-r--r--recipes-core/classpath/classpath-initial_0.93.bb3
-rw-r--r--recipes-core/classpath/classpath-native.inc2
-rw-r--r--recipes-core/classpath/classpath.inc2
3 files changed, 7 insertions, 0 deletions
diff --git a/recipes-core/classpath/classpath-initial_0.93.bb b/recipes-core/classpath/classpath-initial_0.93.bb
index 77831c1..13ede10 100644
--- a/recipes-core/classpath/classpath-initial_0.93.bb
+++ b/recipes-core/classpath/classpath-initial_0.93.bb
@@ -32,6 +32,9 @@ EXTRA_OECONF = " \
32 --with-vm=java \ 32 --with-vm=java \
33 " 33 "
34 34
35# Ensure tools.zip is not installed at same path as classpath-native
36EXTRA_OEMAKE += "pkgdatadir=${STAGING_DATADIR_NATIVE}/classpath-initial"
37
35SRC_URI[md5sum] = "ffa9e9cac31c5acbf0ea9eff9efa923d" 38SRC_URI[md5sum] = "ffa9e9cac31c5acbf0ea9eff9efa923d"
36SRC_URI[sha256sum] = "df2d093612abd23fe67e9409d89bb2a8e79b1664fe2b2da40e1c8ed693e32945" 39SRC_URI[sha256sum] = "df2d093612abd23fe67e9409d89bb2a8e79b1664fe2b2da40e1c8ed693e32945"
37 40
diff --git a/recipes-core/classpath/classpath-native.inc b/recipes-core/classpath/classpath-native.inc
index aefbf6d..16c1498 100644
--- a/recipes-core/classpath/classpath-native.inc
+++ b/recipes-core/classpath/classpath-native.inc
@@ -4,6 +4,8 @@ LICENSE = "Classpath"
4 4
5DEPENDS = "ecj-initial fastjar-native zip-native gettext-native" 5DEPENDS = "ecj-initial fastjar-native zip-native gettext-native"
6 6
7PR = "r1"
8
7inherit autotools native 9inherit autotools native
8 10
9SRC_URI = "${GNU_MIRROR}/classpath/classpath-${PV}.tar.gz" 11SRC_URI = "${GNU_MIRROR}/classpath/classpath-${PV}.tar.gz"
diff --git a/recipes-core/classpath/classpath.inc b/recipes-core/classpath/classpath.inc
index 38037f3..55a3f6c 100644
--- a/recipes-core/classpath/classpath.inc
+++ b/recipes-core/classpath/classpath.inc
@@ -21,6 +21,8 @@ RPROVIDES_${PN} = "${PBN}"
21RPROVIDES_${PN}-common = "${PBN}-common" 21RPROVIDES_${PN}-common = "${PBN}-common"
22RPROVIDES_${PN}-gtk = "${PBN}-awt" 22RPROVIDES_${PN}-gtk = "${PBN}-awt"
23 23
24PR = "r1"
25
24SRC_URI = "${GNU_MIRROR}/classpath/classpath-${PV}.tar.gz" 26SRC_URI = "${GNU_MIRROR}/classpath/classpath-${PV}.tar.gz"
25 27
26S = "${WORKDIR}/${PBN}-${PV}" 28S = "${WORKDIR}/${PBN}-${PV}"