summaryrefslogtreecommitdiffstats
path: root/recipes-core/classpath/classpath-native_0.99.bb
diff options
context:
space:
mode:
authorAndré Draszik <andre.draszik@jci.com>2018-04-25 16:02:58 +0100
committerRichard Leitner <richard.leitner@skidata.com>2018-06-19 09:56:17 +0200
commit3918402ea146a93747170de3a3fd266ec89e521f (patch)
tree91ef167fd65cfeb6519c03e790f75da93e3bba7a /recipes-core/classpath/classpath-native_0.99.bb
parentc99c748d587df0f1e294ecf817f1391b9175797e (diff)
downloadmeta-java-3918402ea146a93747170de3a3fd266ec89e521f.tar.gz
classpath: harmonise -native and -initial-native recipes
removing lots of code-duplication Signed-off-by: André Draszik <andre.draszik@jci.com> Tested-by: Richard Leitner <richard.leitner@skidata.com> Signed-off-by: Richard Leitner <richard.leitner@skidata.com>
Diffstat (limited to 'recipes-core/classpath/classpath-native_0.99.bb')
-rw-r--r--recipes-core/classpath/classpath-native_0.99.bb31
1 files changed, 15 insertions, 16 deletions
diff --git a/recipes-core/classpath/classpath-native_0.99.bb b/recipes-core/classpath/classpath-native_0.99.bb
index a97cae0..a1e1e0f 100644
--- a/recipes-core/classpath/classpath-native_0.99.bb
+++ b/recipes-core/classpath/classpath-native_0.99.bb
@@ -1,6 +1,5 @@
1require classpath-native.inc 1require classpath-native.inc
2 2
3LIC_FILES_CHKSUM = "file://COPYING;md5=af0004801732bc4b20d90f351cf80510"
4DEPENDS += "classpath-initial-native ecj-initial-native virtual/java-initial-native" 3DEPENDS += "classpath-initial-native ecj-initial-native virtual/java-initial-native"
5 4
6PR = "${INC_PR}.0" 5PR = "${INC_PR}.0"
@@ -12,21 +11,21 @@ SRC_URI += " \
12 file://miscompilation.patch \ 11 file://miscompilation.patch \
13 file://toolwrapper-exithook.patch \ 12 file://toolwrapper-exithook.patch \
14 " 13 "
15
16# tools using java-initial rather than java sed it out
17do_compile_append () {
18
19 COMMANDS="gappletviewer gjarsigner gkeytool \
20 gjar gnative2ascii gserialver grmiregistry \
21 gtnameserv gorbd grmid grmic gjavah \
22 "
23
24 for i in ${COMMANDS};
25 do
26 sed -i -e "s/java-initial/java/g" tools/${i}
27 done
28}
29
30SRC_URI[md5sum] = "0ae1571249172acd82488724a3b8acb4" 14SRC_URI[md5sum] = "0ae1571249172acd82488724a3b8acb4"
31SRC_URI[sha256sum] = "f929297f8ae9b613a1a167e231566861893260651d913ad9b6c11933895fecc8" 15SRC_URI[sha256sum] = "f929297f8ae9b613a1a167e231566861893260651d913ad9b6c11933895fecc8"
32 16
17EXTRA_OECONF += "\
18 --enable-local-sockets \
19 --disable-gjdoc \
20 --enable-tools \
21 --includedir=${STAGING_INCDIR}/classpath \
22"
23
24do_compile_append () {
25 # tools using java-initial rather than java sed it out
26 cd tools
27 sed -e "s/java-initial/java/g" \
28 -i gappletviewer gjarsigner gkeytool \
29 gjar gnative2ascii gserialver grmiregistry \
30 gtnameserv gorbd grmid grmic gjavah
31}