summaryrefslogtreecommitdiffstats
path: root/recipes-core/classpath/classpath-initial-native_0.93.bb
diff options
context:
space:
mode:
authorMagnus Olsson <magnus@minimum.se>2015-03-10 13:19:54 +0100
committerOtavio Salvador <otavio@ossystems.com.br>2015-03-11 10:43:53 -0300
commitbd9c60238c4c62d9a0f2d60b89aef429a1b71e34 (patch)
tree0c1a1d5aeb46ad29e6dfadb45c54f4ec59b2b0bc /recipes-core/classpath/classpath-initial-native_0.93.bb
parentbd76e577a9f12b3036b0e7923b223dcd8b8ab7ed (diff)
downloadmeta-java-bd9c60238c4c62d9a0f2d60b89aef429a1b71e34.tar.gz
initials: silence "populate_sysroot manifest not found" warnings
A number of recipes in meta-java use autotools.bbclass for building; internally it uses the sstate-control populate_sysroot manifests to locate and copy aslocals for configure dependencies as part of the do_configure step. The manifest path differs depending on if it's a native package or not so autotools.bbclass looks at the package name to determine if its native or not (it's native if it ends with "-native"). The warnings are emitted because a few (native) recipes in meta-java (such as cacao-initial, classpath-initial and more) are incorrectly being classified as non-native by autotools.bbclass, which makes it look for the manifest in the wrong place and finally gives up with the warning: WARNING: /home/oe/tmp-glibc/sstate-control/manifest-mymachine-libecj-bootstrap.populate_sysroot not found This happens for cacao-initial, classpath-initial, ecj-initial, libecj-boostrap, jamvm-initial and jikes-initial since they are all native and rely on autotools. This patch renames the recipes so they end with -native, e.g ecj-initial-native. It also updates the recipes so they DEPEND on the corresponding new name. This helps autotools.bbclass to properly classify the recipes are native and silence the warnings. Signed-off-by: Magnus Olsson <magnus@minimum.se> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-core/classpath/classpath-initial-native_0.93.bb')
-rw-r--r--recipes-core/classpath/classpath-initial-native_0.93.bb50
1 files changed, 50 insertions, 0 deletions
diff --git a/recipes-core/classpath/classpath-initial-native_0.93.bb b/recipes-core/classpath/classpath-initial-native_0.93.bb
new file mode 100644
index 0000000..0cfa693
--- /dev/null
+++ b/recipes-core/classpath/classpath-initial-native_0.93.bb
@@ -0,0 +1,50 @@
1# No later version of Classpath may be used because this is the latest that can be compiled
2# by jikes!
3
4require classpath-native.inc
5
6DESCRIPTION="Java1.4-compatible GNU Classpath variant that is used as bootclasspath for jikes-native."
7LIC_FILES_CHKSUM = "file://COPYING;md5=af0004801732bc4b20d90f351cf80510"
8DEPENDS += "jikes-native"
9
10PR = "${INC_PR}.2"
11
12SRC_URI += " \
13 file://autotools.patch \
14 file://miscompilation.patch \
15 "
16
17EXTRA_OECONF = " \
18 --with-jikes=jikes \
19 --with-fastjar=fastjar \
20 --with-glibj \
21 --disable-Werror \
22 --disable-local-sockets \
23 --disable-alsa \
24 --disable-gconf-peer \
25 --disable-gtk-peer \
26 --disable-plugin \
27 --disable-dssi \
28 --disable-examples \
29 --with-glibj-dir=${STAGING_DATADIR_NATIVE}/classpath-initial \
30 --with-native-libdir=${STAGING_LIBDIR_NATIVE}/classpath-initial \
31 --includedir=${STAGING_INCDIR_NATIVE}/classpath-initial \
32 --with-vm=java \
33 "
34
35# Ensure tools.zip is not installed at same path as classpath-native
36EXTRA_OEMAKE += "pkgdatadir=${STAGING_DATADIR_NATIVE}/classpath-initial"
37
38# remove files clashing with classpath-native in sysroot
39do_install_append() {
40
41 for i in gappletviewer gjarsigner gkeytool gjar gnative2ascii gserialver grmiregistry gtnameserv gorbd grmid
42 do
43 rm ${D}${bindir}/${i}
44 done
45 rm ${D}${libdir}/logging.properties
46 rm ${D}${libdir}/security/classpath.security
47}
48SRC_URI[md5sum] = "ffa9e9cac31c5acbf0ea9eff9efa923d"
49SRC_URI[sha256sum] = "df2d093612abd23fe67e9409d89bb2a8e79b1664fe2b2da40e1c8ed693e32945"
50