summaryrefslogtreecommitdiffstats
path: root/recipes-core/cacao
diff options
context:
space:
mode:
authorMagnus Olsson <magnus@minimum.se>2015-03-10 13:19:54 +0100
committerOtavio Salvador <otavio@ossystems.com.br>2015-03-11 10:43:53 -0300
commitbd9c60238c4c62d9a0f2d60b89aef429a1b71e34 (patch)
tree0c1a1d5aeb46ad29e6dfadb45c54f4ec59b2b0bc /recipes-core/cacao
parentbd76e577a9f12b3036b0e7923b223dcd8b8ab7ed (diff)
downloadmeta-java-bd9c60238c4c62d9a0f2d60b89aef429a1b71e34.tar.gz
initials: silence "populate_sysroot manifest not found" warnings
A number of recipes in meta-java use autotools.bbclass for building; internally it uses the sstate-control populate_sysroot manifests to locate and copy aslocals for configure dependencies as part of the do_configure step. The manifest path differs depending on if it's a native package or not so autotools.bbclass looks at the package name to determine if its native or not (it's native if it ends with "-native"). The warnings are emitted because a few (native) recipes in meta-java (such as cacao-initial, classpath-initial and more) are incorrectly being classified as non-native by autotools.bbclass, which makes it look for the manifest in the wrong place and finally gives up with the warning: WARNING: /home/oe/tmp-glibc/sstate-control/manifest-mymachine-libecj-bootstrap.populate_sysroot not found This happens for cacao-initial, classpath-initial, ecj-initial, libecj-boostrap, jamvm-initial and jikes-initial since they are all native and rely on autotools. This patch renames the recipes so they end with -native, e.g ecj-initial-native. It also updates the recipes so they DEPEND on the corresponding new name. This helps autotools.bbclass to properly classify the recipes are native and silence the warnings. Signed-off-by: Magnus Olsson <magnus@minimum.se> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-core/cacao')
-rw-r--r--recipes-core/cacao/cacao-initial-native_0.98.bb (renamed from recipes-core/cacao/cacao-initial_0.98.bb)2
-rw-r--r--recipes-core/cacao/cacao_1.6.1.bb2
2 files changed, 2 insertions, 2 deletions
diff --git a/recipes-core/cacao/cacao-initial_0.98.bb b/recipes-core/cacao/cacao-initial-native_0.98.bb
index ad9436b..181faca 100644
--- a/recipes-core/cacao/cacao-initial_0.98.bb
+++ b/recipes-core/cacao/cacao-initial-native_0.98.bb
@@ -8,7 +8,7 @@ PROVIDES = "virtual/java-initial"
8 8
9inherit native autotools-brokensep 9inherit native autotools-brokensep
10 10
11DEPENDS = "zlib-native libtool-native fastjar-native classpath-initial jikes-initial" 11DEPENDS = "zlib-native libtool-native fastjar-native classpath-initial-native jikes-initial-native"
12 12
13SRC_URI = "\ 13SRC_URI = "\
14 http://www.complang.tuwien.ac.at/cacaojvm/download/cacao-${PV}/cacao-${PV}.tar.bz2; \ 14 http://www.complang.tuwien.ac.at/cacaojvm/download/cacao-${PV}/cacao-${PV}.tar.bz2; \
diff --git a/recipes-core/cacao/cacao_1.6.1.bb b/recipes-core/cacao/cacao_1.6.1.bb
index 2bd06c6..9f07946 100644
--- a/recipes-core/cacao/cacao_1.6.1.bb
+++ b/recipes-core/cacao/cacao_1.6.1.bb
@@ -4,7 +4,7 @@ LICENSE = "GPL-2.0"
4LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552" 4LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
5SECTION = "interpreters" 5SECTION = "interpreters"
6 6
7DEPENDS_class-native = "zlib-native libtool-native ecj-initial fastjar-native classpath-native" 7DEPENDS_class-native = "zlib-native libtool-native ecj-initial-native fastjar-native classpath-native"
8PROVIDES_class-native = "virtual/java-native" 8PROVIDES_class-native = "virtual/java-native"
9 9
10DEPENDS = "zlib libtool classpath virtual/javac-native" 10DEPENDS = "zlib libtool classpath virtual/javac-native"