summaryrefslogtreecommitdiffstats
path: root/recipes-core/cacao/cacao_1.6.1.bb
diff options
context:
space:
mode:
authorErkka Kääriä <erkka.kaaria@intel.com>2016-04-29 09:48:19 +0300
committerMaxin B. John <maxin.john@intel.com>2016-04-29 13:17:07 +0300
commit1b975523b8d0467b2e3a44097825c30cdc9e3944 (patch)
treea8b7c140356ed765a6f1455a94fabbf35ad8ec93 /recipes-core/cacao/cacao_1.6.1.bb
parent000a7f770faa7312b912937a585185334dec4caf (diff)
downloadmeta-java-1b975523b8d0467b2e3a44097825c30cdc9e3944.tar.gz
java-bootstrapping: Do not rely on hardcoded paths
Various paths to files are hardcoded in either helper scripts or the resulting binaries (like path to Java class libraries). While this works well when using the files on the build machine, things start breaking down when the sstate gets shared between multiple workers in CI, as the paths between workers can differ. Instead of using these hardcoded paths, form the paths at runtime and pass them as parameters when required. Signed-off-by: Erkka Kääriä <erkka.kaaria@intel.com> Signed-off-by: Maxin B. John <maxin.john@intel.com>
Diffstat (limited to 'recipes-core/cacao/cacao_1.6.1.bb')
-rw-r--r--recipes-core/cacao/cacao_1.6.1.bb21
1 files changed, 6 insertions, 15 deletions
diff --git a/recipes-core/cacao/cacao_1.6.1.bb b/recipes-core/cacao/cacao_1.6.1.bb
index 83f216c..ec13cc5 100644
--- a/recipes-core/cacao/cacao_1.6.1.bb
+++ b/recipes-core/cacao/cacao_1.6.1.bb
@@ -11,7 +11,10 @@ DEPENDS = "zlib libtool classpath virtual/javac-native bdwgc"
11RPROVIDES_${PN} = "java2-runtime" 11RPROVIDES_${PN} = "java2-runtime"
12 12
13SRC_URI = "http://www.complang.tuwien.ac.at/cacaojvm/download/cacao-${PV}/cacao-${PV}.tar.xz \ 13SRC_URI = "http://www.complang.tuwien.ac.at/cacaojvm/download/cacao-${PV}/cacao-${PV}.tar.xz \
14 file://system-boehm-gc.patch" 14 file://system-boehm-gc.patch \
15 file://cacao-1.6.1-do-not-rely-on-absolute-paths.patch \
16"
17
15SRC_URI[md5sum] = "2c18478404afd1cffdd15ad1e9d85a57" 18SRC_URI[md5sum] = "2c18478404afd1cffdd15ad1e9d85a57"
16SRC_URI[sha256sum] = "eecc8bd1b528a028f43d9d1d0c06b97855bbf1d40e03826d911ebbc0b6971e12" 19SRC_URI[sha256sum] = "eecc8bd1b528a028f43d9d1d0c06b97855bbf1d40e03826d911ebbc0b6971e12"
17 20
@@ -23,13 +26,12 @@ REQUIRED_DISTRO_FEATURES_class-native := ""
23EXTRA_OECONF_class-native = "\ 26EXTRA_OECONF_class-native = "\
24 --enable-debug \ 27 --enable-debug \
25 --with-vm-zip=${datadir}/cacao/vm.zip \ 28 --with-vm-zip=${datadir}/cacao/vm.zip \
26 --disable-libjvm \
27 \
28 --with-java-runtime-library-classes=${datadir}/classpath/glibj.zip \ 29 --with-java-runtime-library-classes=${datadir}/classpath/glibj.zip \
29 --with-java-runtime-library-libdir=${libdir_jni}:${libdir} \ 30 --with-java-runtime-library-libdir=${libdir_jni}:${libdir} \
30 --with-jni_md_h=${includedir}/classpath \ 31 --with-jni_md_h=${includedir}/classpath \
31 --with-jni_h=${includedir}/classpath \ 32 --with-jni_h=${includedir}/classpath \
32 --disable-test-dependency-checks \ 33 --disable-test-dependency-checks \
34 --disable-libjvm \
33" 35"
34 36
35CACHED_CONFIGUREVARS_class-native += "ac_cv_prog_JAVAC=${STAGING_BINDIR_NATIVE}/ecj-initial" 37CACHED_CONFIGUREVARS_class-native += "ac_cv_prog_JAVAC=${STAGING_BINDIR_NATIVE}/ecj-initial"
@@ -37,11 +39,9 @@ CACHED_CONFIGUREVARS_class-native += "ac_cv_prog_JAVAC=${STAGING_BINDIR_NATIVE}/
37EXTRA_OECONF = "\ 39EXTRA_OECONF = "\
38 --with-vm-zip=${datadir}/cacao/vm.zip \ 40 --with-vm-zip=${datadir}/cacao/vm.zip \
39 --disable-libjvm \ 41 --disable-libjvm \
40 \
41 --with-build-java-runtime-library-classes=${STAGING_DATADIR}/classpath/glibj.zip \ 42 --with-build-java-runtime-library-classes=${STAGING_DATADIR}/classpath/glibj.zip \
42 --with-jni_h=${STAGING_INCDIR}/classpath \ 43 --with-jni_h=${STAGING_INCDIR}/classpath \
43 --with-jni_md_h=${STAGING_INCDIR}/classpath \ 44 --with-jni_md_h=${STAGING_INCDIR}/classpath \
44 \
45 --with-java-runtime-library-classes=${datadir}/classpath/glibj.zip \ 45 --with-java-runtime-library-classes=${datadir}/classpath/glibj.zip \
46 --with-java-runtime-library-libdir=${libdir_jni}:${libdir} \ 46 --with-java-runtime-library-libdir=${libdir_jni}:${libdir} \
47 --disable-test-dependency-checks \ 47 --disable-test-dependency-checks \
@@ -54,21 +54,12 @@ do_configure_prepend () {
54 mkdir -p src/mm/boehm-gc/m4 54 mkdir -p src/mm/boehm-gc/m4
55} 55}
56 56
57do_install_append () { 57do_install_append_class-target() {
58 rm ${D}/${bindir}/java 58 rm ${D}/${bindir}/java
59} 59}
60 60
61do_install_append_class-native () {
62 ln -sf cacao ${D}/${bindir}/java
63}
64
65FILES_${PN} = "${bindir}/${PN} ${libdir}/cacao/lib*.so ${libdir}/lib*.so* ${datadir}/${PN}" 61FILES_${PN} = "${bindir}/${PN} ${libdir}/cacao/lib*.so ${libdir}/lib*.so* ${datadir}/${PN}"
66FILES_${PN}-dbg += "${bindir}/.debug ${libdir}/.debug/lib*.so*" 62FILES_${PN}-dbg += "${bindir}/.debug ${libdir}/.debug/lib*.so*"
67FILES_${PN}-doc += "${datadir}/gc" 63FILES_${PN}-doc += "${datadir}/gc"
68 64
69ALTERNATIVE_${PN} = "java"
70ALTERNATIVE_LINK = "${bindir}/java"
71ALTERNATIVE_TARGET = "${bindir}/cacao"
72ALTERNATIVE_PRIORITY = "10"
73
74BBCLASSEXTEND = "native" 65BBCLASSEXTEND = "native"