summaryrefslogtreecommitdiffstats
path: root/recipes-core/antlr
diff options
context:
space:
mode:
authorHenning Heinold <heinold@inf.fu-berlin.de>2011-11-12 20:58:34 +0100
committerHenning Heinold <heinold@inf.fu-berlin.de>2011-11-26 23:41:44 +0100
commit57e069cde6617f00ca8834a82c6f360af43d5067 (patch)
tree48cbe15e96d217c45acfa64b0c13aad8c6424980 /recipes-core/antlr
downloadmeta-java-57e069cde6617f00ca8834a82c6f360af43d5067.tar.gz
meta-java: initial commit
* taken over mostly stuff from oe classic * cleaned up recipes * added license checksums * bump icedtea6-native to 1.8.11 * use jamvm from git as native
Diffstat (limited to 'recipes-core/antlr')
-rw-r--r--recipes-core/antlr/antlr_2.7.7.bb33
-rwxr-xr-xrecipes-core/antlr/files/runantlr11
2 files changed, 44 insertions, 0 deletions
diff --git a/recipes-core/antlr/antlr_2.7.7.bb b/recipes-core/antlr/antlr_2.7.7.bb
new file mode 100644
index 0000000..105b5e8
--- /dev/null
+++ b/recipes-core/antlr/antlr_2.7.7.bb
@@ -0,0 +1,33 @@
1DESCRIPTION = "Framework for constructing recognizers, interpreters, compilers, and translators"
2HOMEPAGE = "http://www.antlr2.org"
3# see http://www.antlr2.org/license.html
4LICENSE = "PD"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=361934e706423915b4d9f413ad37fb65"
6
7SRC_URI = "http://www.antlr2.org/download/${BP}.tar.gz"
8SRC_URI_virtclass_native += "file://runantlr"
9
10inherit java-library
11
12do_configure_virtclass_native() {
13 sed -i -e"s|@JAR_FILE@|${STAGING_DATADIR_JAVA_NATIVE}/antlr.jar|" ${WORKDIR}/runantlr
14}
15
16do_compile() {
17 mkdir -p build
18
19 javac -sourcepath . -d build `find antlr -name "*.java"`
20
21 fastjar -C build -c -f ${JARFILENAME} .
22}
23
24do_install_virtclass_native() {
25 install ${D}${bindir}
26 install -m 0755 ${WORKDIR}/runantlr {D}${bindir}/
27}
28
29SRC_URI[md5sum] = "01cc9a2a454dd33dcd8c856ec89af090"
30SRC_URI[sha256sum] = "853aeb021aef7586bda29e74a6b03006bcb565a755c86b66032d8ec31b67dbb9"
31
32BBCLASSEXTEND = "native"
33
diff --git a/recipes-core/antlr/files/runantlr b/recipes-core/antlr/files/runantlr
new file mode 100755
index 0000000..b924bf4
--- /dev/null
+++ b/recipes-core/antlr/files/runantlr
@@ -0,0 +1,11 @@
1#!/bin/sh
2echo Running 'java antlr.Tool $*' with @JAR_FILE@ appended to the CLASSPATH variable
3
4export CLASSPATH
5CLASSPATH=$CLASSPATH:@JAR_FILE@
6
7if [ ! $JAVA ];then
8 JAVA=java
9fi
10
11$JAVA antlr.Tool $*