summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicola Lunghi <nick83ola@gmail.com>2019-06-17 14:14:37 +0100
committerRichard Leitner <richard.leitner@skidata.com>2020-08-17 13:02:40 +0200
commitf4a4ee10d31dc39bf641c420a41fca189130eb5d (patch)
treefde2abd14b52250ed3c8aa99a355f8069431d70e
parentd0a9fe08be6e1c2e7f7afc79abc292d3bffeb9fe (diff)
downloadmeta-java-f4a4ee10d31dc39bf641c420a41fca189130eb5d.tar.gz
openjdk-8: Enable HotSpot builds on 5.x Linux kernels
This is a backport of a patch to enable hotspot builds with 5.x kernels. Signed-off-by: Nicola Lunghi <nick83ola@gmail.com> Signed-off-by: Richard Leitner <richard.leitner@skidata.com>
-rw-r--r--recipes-core/openjdk/openjdk-8-release-172b11-common.inc1
-rw-r--r--recipes-core/openjdk/patches-openjdk-8/0020-Enable-HotSpot-builds-on-5.x-Linux-kernels.patch43
2 files changed, 44 insertions, 0 deletions
diff --git a/recipes-core/openjdk/openjdk-8-release-172b11-common.inc b/recipes-core/openjdk/openjdk-8-release-172b11-common.inc
index ad20585..a8d3ccb 100644
--- a/recipes-core/openjdk/openjdk-8-release-172b11-common.inc
+++ b/recipes-core/openjdk/openjdk-8-release-172b11-common.inc
@@ -29,6 +29,7 @@ HOTSPOT_UB_PATCH = "\
29 file://0017-hotspot-Missing-return-statement-in-__sync_val_compa.patch \ 29 file://0017-hotspot-Missing-return-statement-in-__sync_val_compa.patch \
30 file://0018-hotspot-Fix-debug-build-after-8062808-Turn-on-the-Wr.patch \ 30 file://0018-hotspot-Fix-debug-build-after-8062808-Turn-on-the-Wr.patch \
31 file://0019-hotspot-Turn-on-the-Wreturn-type-warning.patch \ 31 file://0019-hotspot-Turn-on-the-Wreturn-type-warning.patch \
32 file://0020-Enable-HotSpot-builds-on-5.x-Linux-kernels.patch \
32" 33"
33HOTSPOT_UB_PATCH_prepend_aarch64 = "\ 34HOTSPOT_UB_PATCH_prepend_aarch64 = "\
34 file://0012-hotspot-aarch64-fix-undefined-behaviour-gcc-v8-fix.patch \ 35 file://0012-hotspot-aarch64-fix-undefined-behaviour-gcc-v8-fix.patch \
diff --git a/recipes-core/openjdk/patches-openjdk-8/0020-Enable-HotSpot-builds-on-5.x-Linux-kernels.patch b/recipes-core/openjdk/patches-openjdk-8/0020-Enable-HotSpot-builds-on-5.x-Linux-kernels.patch
new file mode 100644
index 0000000..f9feca0
--- /dev/null
+++ b/recipes-core/openjdk/patches-openjdk-8/0020-Enable-HotSpot-builds-on-5.x-Linux-kernels.patch
@@ -0,0 +1,43 @@
1From 90220d41f65910b108c901977eefe78fc1edecc5 Mon Sep 17 00:00:00 2001
2From: Nicola Lunghi <nicola.lunghi@jci.com>
3Date: Mon, 17 Jun 2019 13:59:26 +0100
4Subject: [PATCH] Enable HotSpot builds on 5.x Linux kernels
5
68217753: Enable HotSpot builds on 5.x Linux kernels
7Summary: Remove Linux kernel version check as very unlikely a kernel older than 2.4 will be used.
8Reviewed-by: erikj
9
10Upstream-Status: Backport (http://hg.openjdk.java.net/jdk8u/jdk8u/hotspot/rev/5af8ec63c21c)
11---
12 hotspot/make/linux/Makefile | 15 +--------------
13 1 file changed, 1 insertion(+), 14 deletions(-)
14
15diff --git a/hotspot/make/linux/Makefile b/hotspot/make/linux/Makefile
16index 17c14097..e8f20104 100644
17--- a/hotspot/make/linux/Makefile
18+++ b/hotspot/make/linux/Makefile
19@@ -227,20 +227,7 @@ all:
20 @echo " $(TARGETS_SHARK)"
21 @echo " $(TARGETS_MINIMAL1)"
22
23-checks: check_os_version check_j2se_version
24-
25-# We do not want people accidentally building on old systems (e.g. Linux 2.2.x,
26-# Solaris 2.5.1, 2.6).
27-# Disable this check by setting DISABLE_HOTSPOT_OS_VERSION_CHECK=ok.
28-
29-SUPPORTED_OS_VERSION = 2.4% 2.5% 2.6% 3% 4%
30-OS_VERSION := $(shell uname -r)
31-EMPTY_IF_NOT_SUPPORTED = $(filter $(SUPPORTED_OS_VERSION),$(OS_VERSION))
32-
33-check_os_version:
34-ifeq ($(DISABLE_HOTSPOT_OS_VERSION_CHECK)$(EMPTY_IF_NOT_SUPPORTED),)
35- $(QUIETLY) >&2 echo "*** This OS is not supported:" `uname -a`; exit 1;
36-endif
37+checks: check_j2se_version
38
39 # jvmti.make requires XSLT (J2SE 1.4.x or newer):
40 XSLT_CHECK = $(REMOTE) $(RUN.JAVAP) javax.xml.transform.TransformerFactory
41--
422.20.1
43