summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Leitner <richard.leitner@skidata.com>2020-08-20 13:55:04 +0200
committerRichard Leitner <richard.leitner@skidata.com>2020-09-02 10:58:39 +0200
commit5cc89228ab844c8ada7e69cdd6849bc21dd32c06 (patch)
treecf4c9d94c3da02452014b4759ebb82765beb1712
parent3ee0b12a0eaed4f4fc0499a6186bb82af1444a3f (diff)
downloadmeta-java-5cc89228ab844c8ada7e69cdd6849bc21dd32c06.tar.gz
cacao: update to latest git version
As the cacao-staging mercurial repository was removed update the recipe to use the git repository instead. Furthermore update to the latest revision. Signed-off-by: Richard Leitner <richard.leitner@skidata.com> (cherry-picked from: 00cb61feb07098d55b78237af6eb55fc4b906a0e)
-rw-r--r--recipes-core/cacao/cacao/0001-java.in-Do-not-use-hardcode-paths.patch (renamed from recipes-core/cacao/cacao-2d6f6c14daf9/cacao-1.6.1-do-not-rely-on-absolute-paths.patch)33
-rw-r--r--recipes-core/cacao/cacao/0002-cacao-use-system-s-boehm-garbage-collector.patch (renamed from recipes-core/cacao/cacao-2d6f6c14daf9/system-boehm-gc.patch)21
-rw-r--r--recipes-core/cacao/cacao_git.bb (renamed from recipes-core/cacao/cacao_2d6f6c14daf9.bb)12
3 files changed, 41 insertions, 25 deletions
diff --git a/recipes-core/cacao/cacao-2d6f6c14daf9/cacao-1.6.1-do-not-rely-on-absolute-paths.patch b/recipes-core/cacao/cacao/0001-java.in-Do-not-use-hardcode-paths.patch
index 2b046cf..54b937c 100644
--- a/recipes-core/cacao/cacao-2d6f6c14daf9/cacao-1.6.1-do-not-rely-on-absolute-paths.patch
+++ b/recipes-core/cacao/cacao/0001-java.in-Do-not-use-hardcode-paths.patch
@@ -1,25 +1,31 @@
1java.in: Do not use hardcode paths 1From 51a63cdac93caf69d1b6ace40f73f6147ba37de5 Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Erkka=20K=C3=A4=C3=A4ri=C3=A4?= <erkka.kaaria@intel.com>
3Date: Thu, 20 Aug 2020 13:48:38 +0200
4Subject: [PATCH 1/2] java.in: Do not use hardcode paths
5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit
2 8
3Cacao uses hardcoded paths to various files, if these paths are not 9Cacao uses hardcoded paths to various files, if these paths are not
4provided. This causes issues when sharing sstate with otherwise 10provided. This causes issues when sharing sstate with otherwise
5identical workers, if build time paths are not identical. 11identical workers, if build time paths are not identical.
6 12
7Signed-off-by: Erkka Kääriä <erkka.kaaria@intel.com>
8
9Upstream-Status: Inappropriate [Yocto-specific fixes] 13Upstream-Status: Inappropriate [Yocto-specific fixes]
10 14
15Signed-off-by: Erkka Kääriä <erkka.kaaria@intel.com>
16Signed-off-by: Richard Leitner <richard.leitner@skidata.com>
11--- 17---
12 cacao-1.6.1/src/scripts/java.in | 16 ++++++++++++++-- 18 src/scripts/java.in | 15 +++++++++++++--
13 1 file changed, 14 insertions(+), 2 deletions(-) 19 1 file changed, 13 insertions(+), 2 deletions(-)
14 20
15diff --git cacao-1.6.1/src/scripts/java.in cacao-1.6.1/src/scripts/java.in 21diff --git a/src/scripts/java.in b/src/scripts/java.in
16index 0790f02..2118de7 100644 22index 0790f0255..a4f16ecdc 100644
17--- cacao-1.6.1/src/scripts/java.in 23--- a/src/scripts/java.in
18+++ cacao-1.6.1/src/scripts/java.in 24+++ b/src/scripts/java.in
19@@ -22,5 +22,17 @@ 25@@ -22,5 +22,16 @@
20 ## Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 26 ## Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA
21 ## 02110-1301, USA. 27 ## 02110-1301, USA.
22 28
23-IFS="" 29-IFS=""
24-exec $(dirname ${0})/cacao ${1+"$@"} 30-exec $(dirname ${0})/cacao ${1+"$@"}
25+SH_DIR=`dirname "$0"` 31+SH_DIR=`dirname "$0"`
@@ -35,7 +41,6 @@ index 0790f02..2118de7 100644
35+export BOOTCLASSPATH="${PARENT_DIR}/share/cacao/vm.zip:${PARENT_DIR}/share/classpath/glibj.zip" 41+export BOOTCLASSPATH="${PARENT_DIR}/share/cacao/vm.zip:${PARENT_DIR}/share/classpath/glibj.zip"
36+LIBRARY_PATH="-Djava.library.path=${PARENT_DIR}/lib/classpath" 42+LIBRARY_PATH="-Djava.library.path=${PARENT_DIR}/lib/classpath"
37+exec ${REAL_DIR}/cacao ${LIBRARY_PATH} ${1+"$@"} 43+exec ${REAL_DIR}/cacao ${LIBRARY_PATH} ${1+"$@"}
38+ 44--
39-- 452.28.0
402.7.4
41 46
diff --git a/recipes-core/cacao/cacao-2d6f6c14daf9/system-boehm-gc.patch b/recipes-core/cacao/cacao/0002-cacao-use-system-s-boehm-garbage-collector.patch
index c30f5be..102e9a7 100644
--- a/recipes-core/cacao/cacao-2d6f6c14daf9/system-boehm-gc.patch
+++ b/recipes-core/cacao/cacao/0002-cacao-use-system-s-boehm-garbage-collector.patch
@@ -1,4 +1,7 @@
1cacao: use system's boehm garbage collector 1From 7833101c8c8938d58a32e355b9af1b56e4229a87 Mon Sep 17 00:00:00 2001
2From: Hugo Vasconcelos Saldanha <hugo.saldanha@aker.com.br>
3Date: Thu, 20 Aug 2020 13:50:47 +0200
4Subject: [PATCH 2/2] cacao: use system's boehm garbage collector
2 5
3This is a Gentoo's patch [1] to force the use of system's bdwgc. 6This is a Gentoo's patch [1] to force the use of system's bdwgc.
4 7
@@ -10,11 +13,17 @@ with the system's version.
10Upstream-Status: Inappropriate [not author] 13Upstream-Status: Inappropriate [not author]
11 14
12Signed-off-by: Hugo Vasconcelos Saldanha <hugo.saldanha@aker.com.br> 15Signed-off-by: Hugo Vasconcelos Saldanha <hugo.saldanha@aker.com.br>
16Signed-off-by: Richard Leitner <richard.leitner@skidata.com>
17---
18 configure.ac | 8 ++------
19 src/mm/Makefile.am | 9 ++++-----
20 2 files changed, 6 insertions(+), 11 deletions(-)
13 21
14diff --git a/configure.ac b/configure.ac 22diff --git a/configure.ac b/configure.ac
23index aceb2033b..db8a9770e 100644
15--- a/configure.ac 24--- a/configure.ac
16+++ b/configure.ac 25+++ b/configure.ac
17@@ -691,6 +691,8 @@ 26@@ -738,6 +738,8 @@ AC_CHECK_ENABLE_GCC_PR40134
18 27
19 AC_CHECK_ENABLE_PIC_ASM 28 AC_CHECK_ENABLE_PIC_ASM
20 29
@@ -23,7 +32,7 @@ diff --git a/configure.ac b/configure.ac
23 dnl Define version numbers. 32 dnl Define version numbers.
24 AC_VERSION_DETAIL 33 AC_VERSION_DETAIL
25 AC_VERSION_CONFIG 34 AC_VERSION_CONFIG
26@@ -793,12 +795,6 @@ 35@@ -855,12 +857,6 @@ AC_CONFIG_FILES([Makefile]
27 ) 36 )
28 37
29 38
@@ -37,9 +46,10 @@ diff --git a/configure.ac b/configure.ac
37 46
38 47
39diff --git a/src/mm/Makefile.am b/src/mm/Makefile.am 48diff --git a/src/mm/Makefile.am b/src/mm/Makefile.am
49index 9d0945a29..cbd7dc963 100644
40--- a/src/mm/Makefile.am 50--- a/src/mm/Makefile.am
41+++ b/src/mm/Makefile.am 51+++ b/src/mm/Makefile.am
42@@ -35,14 +35,13 @@ 52@@ -35,14 +35,13 @@ GC_FILE = \
43 endif 53 endif
44 54
45 if ENABLE_GC_BOEHM 55 if ENABLE_GC_BOEHM
@@ -58,3 +68,6 @@ diff --git a/src/mm/Makefile.am b/src/mm/Makefile.am
58 endif 68 endif
59 69
60 if ENABLE_GC_CACAO 70 if ENABLE_GC_CACAO
71--
722.28.0
73
diff --git a/recipes-core/cacao/cacao_2d6f6c14daf9.bb b/recipes-core/cacao/cacao_git.bb
index 91a03fc..6d8914f 100644
--- a/recipes-core/cacao/cacao_2d6f6c14daf9.bb
+++ b/recipes-core/cacao/cacao_git.bb
@@ -10,14 +10,12 @@ PROVIDES_class-native = "virtual/java-native"
10DEPENDS = "zlib libtool classpath virtual/javac-native bdwgc" 10DEPENDS = "zlib libtool classpath virtual/javac-native bdwgc"
11RPROVIDES_${PN} = "java2-runtime" 11RPROVIDES_${PN} = "java2-runtime"
12 12
13SRC_URI = "https://bitbucket.org/cacaovm/cacao-staging/get/${PV}.zip \ 13SRCREV = "6c4694f9bd175386a8c451531e9a5ad97aa23b6f"
14 file://system-boehm-gc.patch \ 14SRC_URI = "git://bitbucket.org/cacaovm/cacao.git;protocol=https \
15 file://cacao-1.6.1-do-not-rely-on-absolute-paths.patch \ 15 file://0001-java.in-Do-not-use-hardcode-paths.patch \
16 file://0002-cacao-use-system-s-boehm-garbage-collector.patch \
16" 17"
17S = "${WORKDIR}/cacaovm-cacao-staging-${PV}" 18S = "${WORKDIR}/git"
18
19SRC_URI[md5sum] = "5157d0bb9eb1332f7a6b6186eaac01aa"
20SRC_URI[sha256sum] = "34b51d660d69c2a83225fd75eab5e1fac002fb5974cb4a74b7478baf923a76cd"
21 19
22inherit java autotools-brokensep update-alternatives pkgconfig distro_features_check 20inherit java autotools-brokensep update-alternatives pkgconfig distro_features_check
23 21