summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Crowe <mac@mcrowe.com>2018-05-08 10:36:31 +0100
committerRichard Leitner <richard.leitner@skidata.com>2018-06-15 12:06:25 +0200
commit228b3517835d6c278876e48c2dcb9d4f09b4bf86 (patch)
treeb7037677ef3cb12770a29ced05674186ee83c17c
parent27e4ffb925cc60f18a4062098ed63d0826812249 (diff)
downloadmeta-java-228b3517835d6c278876e48c2dcb9d4f09b4bf86.tar.gz
jdepend: Retrieve source from Git rather than tarball
When Bitbake downloads jdepend-2.9.1.zip itself and I download https://github.com/clarkware/jdepend/blob/master/dist/jdepend-2.9.1.zip , the calculated hashes don't match the ones included in the recipe. The hashes were last changed in commit dd5c43fca8289b8795a9214aee616775e1493109 on 1st March, but GitHub claims that the file being downloaded was published on 20th January, so I can't explain why they are wrong. Ross Burton has provided a plausible reason in http://lists.openembedded.org/pipermail/openembedded-devel/2017-September/114916.html where he also advocates switching to using Git repositories rather than GitHub-generated tarballs. It seems that we can't really rely on these tarballs to remain unchanged, so let's download the Git hash that corresponds to v2.9.1 instead. This should always remain valid. Cc: André Draszik <andre.draszik@jci.com> Cc: Khem Raj <raj.khem@gmail.com> Cc: Ross Burton <ross.burton@intel.com> Signed-off-by: Mike Crowe <mac@mcrowe.com> Tested-by: Richard Leitner <richard.leitner@skidata.com> Signed-off-by: Richard Leitner <richard.leitner@skidata.com>
-rw-r--r--recipes-core/jdepend/jdepend_2.9.1.bb7
1 files changed, 3 insertions, 4 deletions
diff --git a/recipes-core/jdepend/jdepend_2.9.1.bb b/recipes-core/jdepend/jdepend_2.9.1.bb
index 5f09a8b..dfbf493 100644
--- a/recipes-core/jdepend/jdepend_2.9.1.bb
+++ b/recipes-core/jdepend/jdepend_2.9.1.bb
@@ -6,7 +6,9 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=f5777d32a7709d558c2877d4a6616230"
6 6
7HOMEPAGE = "https://github.com/clarkware/jdepend" 7HOMEPAGE = "https://github.com/clarkware/jdepend"
8 8
9SRC_URI = "https://github.com/clarkware/jdepend/archive/${PV}.zip;downloadfilename=${BP}.zip" 9SRC_URI = "git://github.com/clarkware/jdepend"
10SRCREV = "57980590313a5dbde236a3eb2c8958e9e53e6a10"
11S = "${WORKDIR}/git"
10 12
11inherit java-library 13inherit java-library
12 14
@@ -18,7 +20,4 @@ do_compile() {
18 fastjar cf ${JARFILENAME} -C build . 20 fastjar cf ${JARFILENAME} -C build .
19} 21}
20 22
21SRC_URI[md5sum] = "9b91efe1d770e023893f89f4dde8434e"
22SRC_URI[sha256sum] = "536b5082d64e4f4dddd514ce30178f36c7a31b34d969275f278f72e522e7f7c9"
23
24BBCLASSEXTEND = "native" 23BBCLASSEXTEND = "native"