summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndré Draszik <andre.draszik@jci.com>2018-08-13 11:09:33 +0100
committerRichard Leitner <richard.leitner@skidata.com>2018-08-13 15:03:29 +0200
commita8802f2a03487ae41f3b479914a589004b2dc483 (patch)
tree4fff1c4a88c9f72368adb64b77020680b32f622b
parent3737e0d040dd89737ef4d3a7c45f71c4ff9ad2a8 (diff)
downloadmeta-java-a8802f2a03487ae41f3b479914a589004b2dc483.tar.gz
openjdk-8: gcc-8 fix #2: silence build warnings/errors (return-type)
Similar to the patch just reverted, we silence the build warnings regarding return type of functions, but we only do this for gcc versions where it matters, now that our infrastructure for doing so works again: | <<PKGBUILDDIR>>/hotspot/src/share/vm/utilities/globalDefinitions_gcc.hpp:223:32: error: control reaches end of non-void function [-Werror=return-type] | #define BREAKPOINT ::breakpoint() | ~~~~~~~~~~~~^~ | <<PKGBUILDDIR>>/hotspot/src/share/vm/utilities/debug.hpp:192:3: note: in expansion of macro 'BREAKPOINT' | BREAKPOINT; \ | ^~~~~~~~~~ | <<PKGBUILDDIR>>/hotspot/src/cpu/aarch64/vm/c1_LIRAssembler_aarch64.cpp:197:2: note: in expansion of macro 'ShouldNotReachHere' | ShouldNotReachHere(); | ^~~~~~~~~~~~~~~~~~ etc. Signed-off-by: André Draszik <andre.draszik@jci.com> Signed-off-by: Richard Leitner <richard.leitner@skidata.com>
-rw-r--r--recipes-core/openjdk/openjdk-8-common.inc1
1 files changed, 1 insertions, 0 deletions
diff --git a/recipes-core/openjdk/openjdk-8-common.inc b/recipes-core/openjdk/openjdk-8-common.inc
index 744c062..41e008f 100644
--- a/recipes-core/openjdk/openjdk-8-common.inc
+++ b/recipes-core/openjdk/openjdk-8-common.inc
@@ -216,6 +216,7 @@ EXTRA_OECONF_append = "\
216# of these changes. 216# of these changes.
217FLAGS_GCC6 = "-fno-lifetime-dse -fno-delete-null-pointer-checks" 217FLAGS_GCC6 = "-fno-lifetime-dse -fno-delete-null-pointer-checks"
218FLAGS_GCC7 = "-fno-lifetime-dse -fno-delete-null-pointer-checks" 218FLAGS_GCC7 = "-fno-lifetime-dse -fno-delete-null-pointer-checks"
219FLAGS_GCC8 = "-Wno-error=return-type"
219 220
220# All supported cross compilers support the compiler flags that were 221# All supported cross compilers support the compiler flags that were
221# added to make compilation with gcc6 work. But the host compiler for 222# added to make compilation with gcc6 work. But the host compiler for